CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   openfoam installation for algeria (dz) (http://www.cfd-online.com/Forums/openfoam-installation/90637-openfoam-installation-algeria-dz.html)

abbes July 16, 2011 12:30

openfoam installation for algeria (dz)
 
Hi,
I have installed a virtual machine on my windows pc, then ubuntu-10.04.2-desktop-i386... as described in http://www.openfoam.com/resources/windows.php
it's ok.
then I moved to install openfoam, but unsuccessfully.
when opening the sources.list file in /etc/apt/
I found the following messages:
if I understand right, as I am in Algeria (dz), I don't have right to use openfoam.
If someone have an idea, thanks to answer me.
Regards
#deb cdrom:[Ubuntu 10.04.2 LTS _Lucid Lynx_ - Release i386 (20110211.1)]/ lucid main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://dz.archive.ubuntu.com/ubuntu/ lucid main restricted
deb-src http://dz.archive.ubuntu.com/ubuntu/ lucid main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://dz.archive.ubuntu.com/ubuntu/ lucid-updates main restricted
deb-src http://dz.archive.ubuntu.com/ubuntu/ lucid-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://dz.archive.ubuntu.com/ubuntu/ lucid universe
deb-src http://dz.archive.ubuntu.com/ubuntu/ lucid universe
deb http://dz.archive.ubuntu.com/ubuntu/ lucid-updates universe
deb-src http://dz.archive.ubuntu.com/ubuntu/ lucid-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://dz.archive.ubuntu.com/ubuntu/ lucid multiverse
deb-src http://dz.archive.ubuntu.com/ubuntu/ lucid multiverse
deb http://dz.archive.ubuntu.com/ubuntu/ lucid-updates multiverse
deb-src http://dz.archive.ubuntu.com/ubuntu/ lucid-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://dz.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse
# deb-src http://dz.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu lucid partner
# deb-src http://archive.canonical.com/ubuntu lucid partner

deb http://security.ubuntu.com/ubuntu lucid-security main restricted
deb-src http://security.ubuntu.com/ubuntu lucid-security main restricted
deb http://security.ubuntu.com/ubuntu lucid-security universe
deb-src http://security.ubuntu.com/ubuntu lucid-security universe
deb http://security.ubuntu.com/ubuntu lucid-security multiverse
deb-src http://security.ubuntu.com/ubuntu lucid-security multiverse
deb http://www.openfoam.com/download/ubuntu lsb_release -cs main
deb http://www.openfoam.com/download/ubuntu lsb_release -cs main
deb http://www.openfoam.com/download/ubuntu lsb_release -cs
deb fttp://www.openfoam.com/download/ubuntu main
deb http://www.openfoam.com/dpwnload/ubuntu lsb-release -cs main
deb http://www.openfoam.com/download/ubuntu lucid main

wyldckat July 16, 2011 16:08

Greetings abbes and welcome to the forum!

I'm not certain, but I don't believe that Algeria has been blocked from sourceforge.net. This just seems a problem of incorrect copy-paste of the commands ;)

Near the end of the file you posted, the following lines in bold should be removed:
Code:

deb http://security.ubuntu.com/ubuntu lucid-security main restricted
deb-src http://security.ubuntu.com/ubuntu lucid-security main restricted
deb http://security.ubuntu.com/ubuntu lucid-security universe
deb-src http://security.ubuntu.com/ubuntu lucid-security universe
deb http://security.ubuntu.com/ubuntu lucid-security multiverse
deb-src http://security.ubuntu.com/ubuntu lucid-security multiverse
deb http://www.openfoam.com/download/ubuntu lsb_release -cs main
deb http://www.openfoam.com/download/ubuntu lsb_release -cs main
deb http://www.openfoam.com/download/ubuntu lsb_release -cs
deb fttp://www.openfoam.com/download/ubuntu main
deb http://www.openfoam.com/dpwnload/ubuntu lsb-release -cs main
           
deb http://www.openfoam.com/download/ubuntu lucid main

To edit the file with root powers, run:
Code:

gksu gedit /etc/apt/sources.list
The gksu command is the Gnome version of sudo for GUIs.

Now proceed from point number 2 from the installation instructions and you'll be using OpenFOAM in a few minutes :)

Best regards,
Bruno

abbes July 17, 2011 03:52

HI Bruno,
thanks a lot for your fast reply.
now, step 2 looks ok, but step 3 gives the following answer !!

azzi@azzi-laptop:~$ sudo apt-get install openfoam200
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet openfoam200
azzi@azzi-laptop:~$

thanks for your help, I really want to test openfoam.
best regards
Abbes

wyldckat July 17, 2011 07:00

Hi Abbes,

Well this is really odd... OK, what does this output:
Code:

tail /etc/apt/sources.list
If I'm not mistaken, it should output in your case the following lines:
Code:

# deb http://archive.canonical.com/ubuntu lucid partner
# deb-src http://archive.canonical.com/ubuntu lucid partner
 
deb http://security.ubuntu.com/ubuntu lucid-security main restricted
deb-src http://security.ubuntu.com/ubuntu lucid-security main restricted
deb http://security.ubuntu.com/ubuntu lucid-security universe
deb-src http://security.ubuntu.com/ubuntu lucid-security universe
deb http://security.ubuntu.com/ubuntu lucid-security multiverse
deb-src http://security.ubuntu.com/ubuntu lucid-security multiverse
deb http://www.openfoam.com/download/ubuntu lucid main

If the last line is missing or not equal, or if something else is in the way, then fix it! Then run "sudo apt-get update" again.

Best regards,
Bruno

abbes July 18, 2011 19:16

Hi Bruno,
the last line was missing. now it works, thank a lot :)
regards
Abbes


All times are GMT -4. The time now is 13:11.