CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Problem on installing Openfoam on 64bit sgi station (http://www.cfd-online.com/Forums/openfoam-installation/93209-problem-installing-openfoam-64bit-sgi-station.html)

gregjunqua October 7, 2011 22:54

Problem on installing Openfoam on 64bit sgi station
 
1 Attachment(s)
Hi there
I am trying to install open foam2.0.1 on 64 bit SGI workstation

My first bug i had was
Makefile:54 /../../............./Openfoam-2.0.1/wmake/rules/linuxIA64I64/general: Mo such file or directory
Makefile:55 /../../............./Openfoam-2.0.1/wmake/rules/linuxIA64I64/c++: Mo such file or directory
make: *** No rule to make target

So i decide to create the linuxIA64I64/ directory and put inside linuxIA64Gcc directory.

this permit me to go further but not to complete the installation

and now i got :

make[1]: Leaving directory `/lun/home/gregngreg51/OpenFOAM/OpenFOAM-2.0.1/applications/solvers/stressAnalysis'
make: Target `application' not remade because of errors.

here is the make.log of the installation

if somebody face this problem please help me!

wyldckat October 9, 2011 07:10

Greetings gregjunqua,

By what I can see, the gcc version you are trying to use is Gcc 3.3.3, based on a path shown in the attached file:
Code:

/usr/lib/gcc-lib/ia64-suse-linux/3.3.3
I think the minimum acceptable version is Gcc 4.3.3. You have a few options:
  • Contact your system's administrator and ask for at least Gcc 4.3.3, although Gcc 4.5.x or 4.6.x (where x>=0) would give you better OpenFOAM binaries.
  • Try building one of these gcc versions yourself! Instructions are in the "README.org" or "README.html" files in the "ThirdParty-2.0.1" folder.
  • Contact your SGI provider or use the contact form at www.openfoam.com for dedicated support for your platform, since they now provide dedicated support for SGI machines!
Best regards,
Bruno

gregjunqua October 9, 2011 08:55

Thank you Bruno I will contact the admin for that.

gregjunqua October 11, 2011 04:18

Hi there it's me again ...
The engineer don't want to update the Gcc how is (3.3.3) to the new one.
And tell me that i should do with Icc

But i don't know how to do that. i found some example but it for old OpenFOAM version like 1.7.1 ....
I hope somebody could help me

wyldckat October 12, 2011 16:28

Hi gregjunqua,

Which Icc version do you have installed?
Code:

icc -v
I believe that OpenFOAM 2.0 currently only supports Icc 12.x, but I could be wrong.

To start the environment with the right settings for using Icc, instead of just using in your "~/.bashrc":
Code:

source $HOME/OpenFOAM/OpenFOAM-2.0.1/etc/bashrc
Simply add the respective option for Icc:
Code:

source $HOME/OpenFOAM/OpenFOAM-2.0.1/etc/bashrc WM_COMPILER=Icc
You can check what other options are there inside OpenFOAM's bashrc file!

If that doesn't work, there is always the file "README.org" in the folder "ThirdParty-2.0.1" that has some instructions to build Gcc 4.4 or 4.5!

Best regards and good luck!
Bruno


All times are GMT -4. The time now is 09:50.