CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

OpenFOAM-2.0.x on Ubuntu 11.10

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree11Likes

Reply
 
LinkBack Thread Tools Display Modes
Old   December 19, 2011, 05:23
Thumbs up
  #41
New Member
 
Join Date: Jun 2010
Posts: 7
Rep Power: 7
rosswell is on a distinguished road
Hallo again!

First of all, thank you very much to everyone who happily replied to my question!

I've read the post from musahossein last week, and decided to try that out. I've fresh installed Ubuntu 11.04, successfully installed OpenFOAM on it, and then upgraded to Ubuntu 11.10. Unfortunately, I was able to run OpenFoam or ParaView after that. Everytime I tried to open ParaView, it closed right away.
After some attempts, including unsuccessful upgrade of some drivers and packages from the new version of Ubuntu, a windows popped-up saying I should update my nVidia driver. After doing that, it seemed everything was fine, but I was not able to start ParaView again. That was probably because I had again messed up something in the way.

Then I've returned to the forum and saw the kind reply from Chavagnatze, which I decided to follow.
So, I installed OpenFoam again, rewriting everything that was already installed, and now it seems its working; I successfully started ParaView, as shown in the first tutorial from OpenFoam.

So, I guess it's safe to say:
(1) Upgrading from an earlier supported version of Ubuntu after installing OF on it should work smoothly (if you don't mess with other parts of the installation during the process, like I did) - thanks musahossein ;
(2) Following the instruction from Chavagnatze should also work on Ubuntu 11.10, as it worked for me after I messed up option (1).

Toorop, luckily I didn't had the same issues you had, but thank you anyway for your reply.
I'll actually not have time until new year to work more on it and check for sure if everything is really working properly, but I would like to thank you guys already, as part of the Christmas spirit that is taking place!

So, have a nice Christmas and happy new year to you all.

See you next year!

rosswell is offline   Reply With Quote

Old   December 21, 2011, 07:23
Default FATAL ERROR: Paraview reader module libraries do not exist
  #42
New Member
 
Francesco Borgosano
Join Date: Dec 2011
Location: Heidelberg
Posts: 17
Rep Power: 5
Ancioi is on a distinguished road
Quote:
Originally Posted by Chavagnatze View Post
Follow these steps with either 11.04 or 11.10:

Press: CTRL+ATL+T to open a terminal.

1. Enter the following line:

sudo sh -c "echo deb http://www.openfoam.com/download/ubuntu natty main > /etc/apt/sources.list.d/openfoam.list"

It will ask for your password. Type your password exactly as it is and press enter. It doesn't show what you are entering so don't be alarmed.

2. Next, enter this line:

sudo apt-get update

3. Enter this line next:

sudo apt-get install openfoam201

It will tell you how much disk space it will use and make references to the package security. Press the "Y" key and then press enter.

OpenFoam 2.0.1 will be installed. This process will take some time.

4. Next enter:

sudo apt-get install paraviewopenfoam3101

Press the "Y" key again and then press enter. This will install Paraview 3.10.1 which allows you to visualize your solutions, meshes, etc. This process may also require a large amount of time.

5. Next you must edit your bashrc file. To open it enter:

gedit ~/.bashrc

Scroll all the way to the bottom of the file and enter source /opt/openfoam201/etc/bashrc in a new line and save the file and exit Gedit.

6. Close the current terminal you have been using for all of the previous steps and press CTRL+ALT+T again to open another terminal. Enter:

icoFoam -help

An in-terminal help prompt for the OpenFoam icoFoam Solver should appear. OpenFoam is now running.

Follow the GETTING STARTED Section at the bottom of this page to copy the tutorial files to your home directory and get started with the tutorials.


Hello everyone,

I have no experience with openFOAM and Linux, but for my PhD project I need to run a numerical simulation so I'm moving my first steps in this field.

I have Ubuntu 11.10 on my machine and I'm trying to install openFoam 2.0.1. I have been fighting for ten days, finally yesterday I found this forum... I followed step by step the instructions of Chavagnatze, but when I try to get start with the tutorial I got this error:

"FATAL ERROR: Paraview reader module libraries do not exist

Please build the reader module before continuing:
cd $FOAM_UTILITIES/postProcessing/graphics/PV3Readers
./Allwclean
./Allwmake"

I followed these instructions but the error is still there.

Could you help me?
Thanks in advance
Ancioi is offline   Reply With Quote

Old   December 22, 2011, 14:21
Default Errata corrige
  #43
New Member
 
Francesco Borgosano
Join Date: Dec 2011
Location: Heidelberg
Posts: 17
Rep Power: 5
Ancioi is on a distinguished road
Hello everyone,

I got the error because at first I forgot step 3... then I tried again and it works!

I want to apologize,
Ancioi is offline   Reply With Quote

Old   January 19, 2012, 00:17
Default
  #44
New Member
 
Chavagnatze's Avatar
 
Kyle Morse
Join Date: Apr 2011
Location: Georgia Southern University
Posts: 6
Rep Power: 6
Chavagnatze is on a distinguished road
Quote:
Originally Posted by Ancioi View Post
Hello everyone,

I got the error because at first I forgot step 3... then I tried again and it works!

I want to apologize,
OpenFoam 2.1.0 for Ubuntu 11.10 has been relesed. If the steps on their download page are followed, a newer version of Paraview will be installed.

http://www.openfoam.org/download/ubuntu.php
Chavagnatze is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenFOAM vs Ubuntu 10.10 64 bit vkrastev OpenFOAM Installation 12 April 23, 2011 10:14
Installing OpenFOAM 1.6 on Ubuntu 10.4 sda OpenFOAM Installation 5 May 27, 2010 20:19
How to Install OpenFOAM on 64 Ubuntu 9.04 hansel OpenFOAM Installation 62 March 19, 2010 15:43
OpenFOAM on non-English Ubuntu distribution fabian_roesler OpenFOAM 3 January 11, 2010 08:16
Adventure of fisrst openfoam installation on Ubuntu 710 jussi OpenFOAM Installation 0 April 24, 2008 14:25


All times are GMT -4. The time now is 20:05.