CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

parallel running - error while loading shared libraries:

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   December 8, 2011, 11:02
Default parallel running - error while loading shared libraries:
  #1
New Member
 
Jiri Simonek
Join Date: Jun 2011
Posts: 3
Rep Power: 6
seami is on a distinguished road
Hello,
I've have successfully installed OF20x from source pack.
Everything works as a single process, e.g. if I run any application or solver it works.
But the problem is in parallel. When I'm trying to run:
Code:
mpirun -np 2 simpleFoam -parallel
or any other application, that could be run in parallel. I obtain following error:
Code:
simpleFoam: error while loading shared libraries: libincompressibleTurbulenceModel.so: cannot open shared object file: No such file or directory
--------------------------------------------------------------------------
mpirun noticed that the job aborted, but has no info as to the process
that caused that situation.
--------------------------------------------------------------------------
(when I run other application in parallel I obtain similar output with different library that cannot be loaded)

Does anybody have any idea where could be a problem.

Thanks.
seami is offline   Reply With Quote

Old   December 9, 2011, 05:39
Default problem SOLVED
  #2
New Member
 
Jiri Simonek
Join Date: Jun 2011
Posts: 3
Rep Power: 6
seami is on a distinguished road
I was checking file permission, but I haven't found anything wrong ...
anyway I recompiled OF once again in different directory and now it works fine. So I could be caused by wrong file permissions ...

Strange things happen ;-)
seami is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
RSH problem for parallel running in CFX Nicola CFX 5 June 18, 2012 18:31
parallel running openFoam-1.5-dev lulo OpenFOAM 3 October 3, 2011 11:42
Running in parallel error Madeleine P. Vincent OpenFOAM Running, Solving & CFD 0 May 7, 2011 08:44
Running dieselFoam in parallel. Palminchi OpenFOAM 0 February 17, 2010 05:00
User fortran error when running CFX-10 in parallel CFDworker CFX 2 October 26, 2007 16:01


All times are GMT -4. The time now is 22:05.