CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Error gcc compiler (http://www.cfd-online.com/Forums/openfoam-installation/95353-error-gcc-compiler.html)

Goutam December 14, 2011 10:58

Error gcc compiler
 
Error:

Checking main OpenFOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home/thermo/gsaha/OpenFOAM yes yes
$WM_PROJECT_USER_DIR /home/thermo/gsaha/OpenFOAM/gsaha-2.0.1 no no
$WM_THIRD_PARTY_DIR ...ermo/gsaha/OpenFOAM/ThirdParty-2.0.1 yes yes
-------------------------------------------------------------------------------

Checking the OpenFOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR ...thermo/gsaha/OpenFOAM/OpenFOAM-2.0.1 yes yes yes

$FOAM_APPBIN ....0.1/platforms/linux64Gcc44SPOpt/bin yes yes yes
$FOAM_SITE_APPBIN ....0.1/platforms/linux64Gcc44SPOpt/bin no no
$FOAM_USER_APPBIN ....0.1/platforms/linux64Gcc44SPOpt/bin no no
$WM_DIR .../gsaha/OpenFOAM/OpenFOAM-2.0.1/wmake yes yes yes
-------------------------------------------------------------------------------

Checking the OpenFOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ....0.1/platforms/linux64Gcc44SPOpt/lib yes yes yes
$FOAM_SITE_LIBBIN ....0.1/platforms/linux64Gcc44SPOpt/lib no no
$FOAM_USER_LIBBIN ....0.1/platforms/linux64Gcc44SPOpt/lib no no
$MPI_ARCH_PATH ...platforms/linux64Gcc44/openmpi-1.5.3 yes yes yes
-------------------------------------------------------------------------------

Third party software
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
flex /usr/bin/flex
ERROR: gcc version is too old for this release of OpenFOAM
User version : 4.1.2
Minimum required: 4.3.2


"I have installed gcc 4.4.4 in Centos 5 Linux". How I will solve this problem?

wyldckat December 15, 2011 17:48

Answered here: http://www.cfd-online.com/Forums/ope...tml#post336010


All times are GMT -4. The time now is 19:52.