CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   paraView reader module build problem (http://www.cfd-online.com/Forums/openfoam-installation/96858-paraview-reader-module-build-problem.html)

fusij February 2, 2012 21:29

paraView reader module build problem
 
Hello all.

I just installed OF-2.1.0 on Ubuntu 11.10 following these instructions: http://www.openfoam.org/download/ubuntu.php

Everything runs smoothly except paraView. When I try to run it the following error arises:
Code:

FATAL ERROR: ParaView reader module libraries do not exist

Please build the reader module before continuing:
cd $FOAM_UTILITIES/postProcessing/graphics/PV3Readers
./Allwclean
./Allwmake

I tried to follow wyldckat instructions from earlier thread:
http://www.cfd-online.com/Forums/ope...se-11-4-a.html

But it did not work.

I did not have any prior installation of OpenFOAM.

Any guidelines or tips?

wyldckat February 3, 2012 04:47

Greetings fusij,

With Ubuntu, it's a whole other ball game. Did you install ParaView as indicated:
Quote:

Code:

sudo apt-get install paraviewopenfoam3120

!?

Best regards,
Bruno

fusij February 3, 2012 06:02

Yes, I did that. I went over all the steps twice to be sure that I had everything in order.

Maybe I should clean everything and try it again? What is the best way for me to do that? Is there generally, a positive experience from installing the 2.1.0 deb pack for Ubuntu while following the earlier mentioned steps?

wyldckat: Any ideas? Maybe setup paraview independently?

wyldckat February 3, 2012 06:11

Mmm... strange. OK, can you see the ParaView folder that is located at "/opt" ? Probably has the same name as that package.

And start a new terminal, just to be certain.

fusij February 3, 2012 17:40

Yes I see that folder /opt/paraviewopenfoam3120/. It has three folders (bin, lib, share).

wyldckat February 3, 2012 18:34

OK, what architecture of Ubuntu do you have installed? i686 or x86_64? You can check by running:
Code:

uname -m

fusij February 3, 2012 19:18

Code:

vigfus@Pundi:/opt$ uname -m
x86_64

Maybe I should compile the source pack?

$WM_THIRD_PARTY_DIR doesn't exist. I thought it was neccessary?

wyldckat February 4, 2012 11:10

Hi fusij,

I wanted to know which exact version of Ubuntu you were using so I could try to replicate the same installation steps and check if things are working as expected. It all went well.
Therefore, a few more possibilities arise:
  1. It's possible that you have more than one OpenFOAM version installed and did not take into account the need for at least commenting the older lines in "~/.bashrc". If this is the case, then comment or remove the old lines that refer to the older versions of OpenFOAM and start a new terminal. Then try again running paraFoam in the case folder you were running before.
    If this works, and if you want more than one version of OpenFOAM, see my blog post: Advanced tips for working with the OpenFOAM shell environment
  2. There could be a glitch related to a file system problem that occurred during installation or afterwards, such as accidental deletion of files. To confirm this, check the following steps:
    1. Run the following command in the terminal:
      Code:

      echo $PV_PLUGIN_PATH
      It should output the following path:
      Code:

      /opt/openfoam210/platforms/linux64GccDPOpt/lib/paraview-3.12
    2. Also check the contents of the path shown above, even if the command showed you nothing:
      Code:

      ls -l /opt/openfoam210/platforms/linux64GccDPOpt/lib/paraview-3.12
      It should show you two files starting with "libPV3".
    3. If those two files do exist, then add the following line to the file "~/.bashrc":
      Code:

      export PV_PLUGIN_PATH=/opt/openfoam210/platforms/linux64GccDPOpt/lib/paraview-3.12
      Start a new terminal and now it should work!
Best regards,
Bruno

fusij February 4, 2012 21:31

It works now but with two new issues. First terminal shows this when I run paraFoam
Code:

$ paraFoam
created temporary 'cavity.OpenFOAM'
Read float past end of buffer
Read float past end of buffer
Read float past end of buffer
Read float past end of buffer

Secondly a window pops up and tells me that a reader can not be found for openFOAM/vigfus-2.1.0/run/tutorials/incompressible/icoFoam/cavity/cavity.OpenFOAM and tells me to choose one. I get a list of different type of files and I choose OpenFOAM and then ParaView starts smoothly and works fine.

Do you have ideas for these ones wyldckat? Thanks a lot for your efforts, they are well appreciated!

wyldckat February 5, 2012 06:08

Hi fusij,

You could have detailed which steps you had to take! Now I don't know enough to deduce what exactly is going on :(

Anyway, the first error message is related to a "locale" problem. Basically, when the system is in English, the decimal separator is the dot symbol '.', but many other languages use the comma ','. That output occurs because the second mode was detected and hindered execution. To fix this, you can try running the following command before paraFoam:
Code:

export LC_ALL=C
paraFoam

As for the second error, you can try running with the option '-builtin':
Code:

paraFoam -builtin
This will select the internal reader, instead of using OpenFOAM's official reader.

By the way, which ParaView is the command line picking up?
Code:

which paraview
Best regards,
Bruno

fusij February 5, 2012 22:23

Sorry for not clearing out which steps helped me out in your earlier post.

Step 3 made everything work:
Code:

export PV_PLUGIN_PATH=/opt/openfoam210/platforms/linux64GccDPOpt/lib/paraview-3.12
The first two steps showed me what you expected them to show, so they worked out fine.

Now for my two new issues:
Code:

export LC_ALL=C
does not help me with the "Read float past end of buffer" warning.

But by using
Code:

paraFoam -builtin
That warning does not arise and the reader problem disappears also. So that option seems to solve my problems but I am curious why I have to use it, why the default is not working?

And the paraView the command line picks up is:
Code:

$ which paraview
/opt/paraviewopenfoam3120/bin/paraview

$ which paraFoam
/opt/openfoam210/bin/paraFoam


wyldckat February 6, 2012 18:48

Hi fusij,

It's strange, very strange the errors you are getting :( And without knowing more about the specific Ubuntu installation you've made, I'm unable to figure out what exactly is going wrong there :(

You might want to review the post you mentioned at the beginning - http://www.cfd-online.com/Forums/ope...tml#post342512




Other than this, all I can figure out is that maybe, just maybe, you are having one of those strange bugs that Ubuntu 11.10 has been having on several issues. Two that I know of are:
  • Several USB-wireless cards aren't properly controlled with kernel 3.0.x on Ubuntu 11.10.
  • Laptops tend to run out of battery in less than 45 min, due to another option preset in the kernel.
Best regards,
Bruno

fusij February 6, 2012 19:10

Thanks a lot for the help and time spent on these issues. What you do for people with installation complications is very respectable.

ParaView works now and that matter most.

Best regards,
Vigfús Arnar

skyemoor March 5, 2012 23:52

I've had the same problem, even after running a separate install noted above.

Quote:

Originally Posted by wyldckat (Post 342728)
Hi fusij,
    1. Run the following command in the terminal:
      Code:

      echo $PV_PLUGIN_PATH
      It should output the following path:
      Code:

      /opt/openfoam210/platforms/linux64GccDPOpt/lib/paraview-3.12

I did, but nothing is returned.

I do have Paraview 3.10 installed, and there is nothing in the .bashrc from before related to openfoam or paraview.

wyldckat March 6, 2012 15:01

Greetings Will and welcome to the forum!

I'm having a hard time trying to figure out the problem you are describing :(
Please provide more information, so I can try and reproduce the same steps you've taken.

Best regards,
Bruno

sukye May 2, 2012 14:30

I met the same problem as fusij with installed centFOAM.

There are bin and lib folders in $HOME/centFOAM/paraview-3.10.1 directory, but no paraview in /opt.

Would you, Bruno or Linnemann, help me?

wyldckat May 2, 2012 16:48

Hi sukye,

fusij had two problems... so which one are you having?
And why didn't you ask on the other thread you had, since your question is still related to CentFOAM? ;)

Best regards,
Bruno

sukye May 2, 2012 16:52

The one fusij posted on February 2, ie the original poster of this thread.

Since the problem is identical to fusij's, I think we may not blame centFOAM :)

Quote:

Originally Posted by wyldckat (Post 358955)
Hi sukye,

fusij had two problems... so which one are you having?
And why didn't you ask on the other thread you had, since your question is still related to CentFOAM? ;)

Best regards,
Bruno


wyldckat May 2, 2012 17:02

OK, not much information to go on with, specially since I've never used CentFOAM... but my guess is that you ran:
Code:

python centFOAM.py --paraview
only after you typed OF21.

Therefore, try running OF21 again to update the working environment.

sukye May 4, 2012 11:11

Hi Bruno,

I have put OF21 in the .bashrc so it will be loaded upon login.

paraview works well, but paraFoam does not.

Then I added *requirePV=0* in bin/paraFoam as suggested in
http://www.cfd-online.com/Forums/ope...tml#post342512

Code:

> paraFoam -builtin
created temporary 'cavity.foam'
$WM_PROJECT_DIR/bin/paraFoam: line 261: paraview: command not found



All times are GMT -4. The time now is 21:54.