CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   OpenFOAM installation problem (http://www.cfd-online.com/Forums/openfoam-installation/97134-openfoam-installation-problem.html)

eos_711 February 9, 2012 11:53

OpenFOAM installation problem
 
Hello all,

I am trying to install OpenFOAM 2.1.0 (Fedora RPM) on a cluster with CentOS (redhat linux).I have an error message which says:
Fehler: Fehlgeschlagende Abhängigkeiten:
libc.so.6(GLIBC_2.14)(64bit) wird benötigt von OpenFOAM-2.1.0-1.x86_64
libmpi.so.1()(64bit) wird benötigt von OpenFOAM-2.1.0-1.x86_64
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) wird benötigt von OpenFOAM-2.1.0-1.x86_64
libstdc++.so.6(GLIBCXX_3.4.15)(64bit) wird benötigt von OpenFOAM-2.1.0-1.x86_64
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) wird benötigt von OpenFOAM-2.1.0-1.x86_64
rpmlib(FileDigests) <= 4.6.0-1 wird benötigt von OpenFOAM-2.1.0-1.x86_64
rpmlib(PayloadIsXz) <= 5.2-1 wird benötigt von OpenFOAM-2.1.0-1.x86_64
libQtCore.so.4()(64bit) wird benötigt von OpenFOAM-ParaView-3.12.0-1.x86_64
libQtGui.so.4()(64bit) wird benötigt von OpenFOAM-ParaView-3.12.0-1.x86_64
libQtHelp.so.4()(64bit) wird benötigt von OpenFOAM-ParaView-3.12.0-1.x86_64
libQtNetwork.so.4()(64bit) wird benötigt von OpenFOAM-ParaView-3.12.0-1.x86_64
libQtSql.so.4()(64bit) wird benötigt von OpenFOAM-ParaView-3.12.0-1.x86_64
libQtWebKit.so.4()(64bit) wird benötigt von OpenFOAM-ParaView-3.12.0-1.x86_64
libQtXml.so.4()(64bit) wird benötigt von OpenFOAM-ParaView-3.12.0-1.x86_64
libQtXmlPatterns.so.4()(64bit) wird benötigt von OpenFOAM-ParaView-3.12.0-1.x86_64
libc.so.6(GLIBC_2.14)(64bit) wird benötigt von OpenFOAM-ParaView-3.12.0-1.x86_64
libc.so.6(GLIBC_2.7)(64bit) wird benötigt von OpenFOAM-ParaView-3.12.0-1.x86_64
libstdc++.so.6(GLIBCXX_3.4.10)(64bit) wird benötigt von OpenFOAM-ParaView-3.12.0-1.x86_64
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) wird benötigt von OpenFOAM-ParaView-3.12.0-1.x86_64
libstdc++.so.6(GLIBCXX_3.4.15)(64bit) wird benötigt von OpenFOAM-ParaView-3.12.0-1.x86_64
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) wird benötigt von OpenFOAM-ParaView-3.12.0-1.x86_64
rpmlib(FileDigests) <= 4.6.0-1 wird benötigt von OpenFOAM-ParaView-3.12.0-1.x86_64
rpmlib(PayloadIsXz) <= 5.2-1 wird benötigt von OpenFOAM-ParaView-3.12.0-1.x86_64
libc.so.6(GLIBC_2.14)(64bit) wird benötigt von OpenFOAM-scotch-5.1.12-1.x86_64
libc.so.6(GLIBC_2.7)(64bit) wird benötigt von OpenFOAM-scotch-5.1.12-1.x86_64
rpmlib(FileDigests) <= 4.6.0-1 wird benötigt von OpenFOAM-scotch-5.1.12-1.x86_64
rpmlib(PayloadIsXz) <= 5.2-1 wird benötigt von OpenFOAM-scotch-5.1.12-1.x86_64

The problem seems to be that it cant find a specific version of libstc++ package (i have a newer version presently installed) the same holds for openmpi version as well.
(libstd++:4.1.2.-44.el5.x86_64 installed)
(openmpi:1.2.7-6el5.x86_64 installed)

What is the best solution around this problem? I am sceptical about updating/downgrading these versions as it will conflict with other programs already running on the cluster. (I need OpenFOAM only for 1 user).

ThnX in advance for the help!!

wyldckat February 9, 2012 12:50

Greetings eos_711 and welcome to the forum!

If you are using CentOS, then use CentFOAM instead: http://sourceforge.net/apps/mediawik...itle=Main_Page

Best regards,
Bruno

eos_711 February 10, 2012 05:51

Thank you for d welcome Bruno Santos!

But my question is actually if it is possible to have different versions of openmpi and libstdc++ package as unfortunately as written in my previous post.. I have older versions already installed on the cluster and cannot update these packages.. Can i modify the script or the make file of the OpenFOAM installation to explicitly use an alternate version installed separately for a single user.

Thank you for your help.

wyldckat February 10, 2012 16:35

Hi eos_711,

You can have multiple versions of Open-MPI and "libstd++" installed on any machine, but forcefully installing an RPM package that was designed for one specific Linux distribution will probably not work as expected...

Even if you forcefully install the OpenFOAM RPM package for Fedora on your CentOS machine, even if the files are installed, it doesn't mean that it will then work as intended!
But if you really want to try this, it seems that the option "--force" when running rpm should work:
Code:

rpm -i --force package.rpm
I found out about this by running (well, I googled it):
Code:

man rpm
Best regards,
Bruno


All times are GMT -4. The time now is 13:55.