CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

--showme errors

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree5Likes
  • 2 Post By rnebot
  • 3 Post By iperetta

Reply
 
LinkBack Thread Tools Display Modes
Old   February 20, 2012, 21:51
Default --showme errors
  #1
New Member
 
Robert McDougal
Join Date: Feb 2012
Posts: 5
Rep Power: 5
ramcdougal is on a distinguished road
I installed OpenFOAM on my 64-bit Ubuntu 11.10 system on campus today with no difficulty by following the instructions at

http://www.openfoam.org/download/ubuntu.php

When I tried the same thing tonight at home (also 64-bit Ubuntu 11.10), the following happens
Code:
$ source /opt/openfoam210/etc/bashrc
gcc: error: unrecognized option ‘--showme:compile’
gcc: error: unrecognized option ‘--showme:link’
I'm not the only one who has had this problem. One bug report links it to openmpi:
http://www.openfoam.com/mantisbt/view.php?id=369
but I'm not sure what they're doing with modules and their solution doesn't work verbatim in Ubuntu. I do have openmpi installed at home, but I'm not sure what the situation is on campus.

There was an earlier forum post presumed to involve Ubuntu, but no solution
source bashrc problem

I'm not sure where to start looking for a difference between the two machines. Any advice? Thanks!
ramcdougal is offline   Reply With Quote

Old   February 21, 2012, 05:35
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,511
Blog Entries: 34
Rep Power: 86
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Robert and welcome to the forum!

Mmm... indeed, this is odd, but at least you've provided a lot more information than the other forum user

OK, try running the following commands:
Code:
which mpirun
mpirun --version
The first one should show you where mpirun is located and the second one should show which version you've got installed.
If neither show any information, then it might not be working due to either one of several reasons:
  • Open-MPI didn't install properly, due to some strange reason. It's known to have a glitch during installation, since normal people don't have Infiniband on their computers, but it still comes with support for it pre-packaged...
  • Another reason for a bad installation is if the "alternatives" system failed to add an alternative for Open-MPI. I'm not sure what's the solution here, but I'd guess that reinstalling Open-MPI wouldn't hurt.
  • Yet another is for said "alternatives" system not having updated until you reboot.
And don't forget to have your system fully up-to-date, just in case...

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   February 21, 2012, 11:25
Default
  #3
New Member
 
Robert McDougal
Join Date: Feb 2012
Posts: 5
Rep Power: 5
ramcdougal is on a distinguished road
Thanks Bruno, but there is no obvious difference in mpi setup. They are both setup through Ubuntu's repositories; I don't do anything unusual with MPI. Any other ideas?

At home:
Code:
robert@desktop-2010:~$ which mpirun
/usr/bin/mpirun
robert@desktop-2010:~$ mpirun --version
mpirun (Open MPI) 1.4.3

Report bugs to http://www.open-mpi.org/community/help/
At the office:
Code:
ramcdougal@ramcdougal-VirtualBox:~$ which mpirun
/usr/bin/mpirun
ramcdougal@ramcdougal-VirtualBox:~$ mpirun --version
mpirun (Open MPI) 1.4.3

Report bugs to http://www.open-mpi.org/community/help/
You'll notice that at the office I run in a virtual machine, so I suppose that could make some subtle differences in active kernel drivers.

I have a much longer $PATH at home. Are there any known conflicts? For example, does Enthought provide a conflicting MPI?

As an aside: Why does it need to call gcc every time I open a terminal?
ramcdougal is offline   Reply With Quote

Old   February 21, 2012, 11:54
Default
  #4
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,511
Blog Entries: 34
Rep Power: 86
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Robert,

The code that is giving you that error message is this one (the two lines in the middle):
Code:
# Set compilation flags here instead of in wmake/rules/../mplibSYSTEMOPENMPI
    export PINC="`mpicc --showme:compile`"
    export PLIBS="`mpicc --showme:link`"
    libDir=`echo "$PLIBS" | sed -e 's/.*-L\([^ ]*\).*/\1/'`
Source: "etc/config/settings.sh"
Therefore, perhaps it is Enthought that is disturbing OpenFOAM's thought process

For further debugging:
Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   February 22, 2012, 09:25
Default
  #5
New Member
 
Robert McDougal
Join Date: Feb 2012
Posts: 5
Rep Power: 5
ramcdougal is on a distinguished road
Both machines report
Code:
robert@desktop-2010:~$ which mpicc
/usr/bin/mpicc
robert@desktop-2010:~$ mpicc --version
gcc (Ubuntu/Linaro 4.6.1-9ubuntu3) 4.6.1
Just to be safe, I reinstalled every package with mpi in it's name; that didn't fix things.

I commented out all of the non-standard lines at the end of my ~/.bashrc, added the OpenFOAM source line, and I still got the same problem as before. I think this means Enthought is innocent, but once again I'm out of ideas.

And, for the record, this is a problem I'm having with
Code:
robert@desktop-2010:~$ uname -a
Linux desktop-2010 3.0.0-16-generic #28-Ubuntu SMP Fri Jan 27 17:44:39 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
ramcdougal is offline   Reply With Quote

Old   February 22, 2012, 10:10
Default
  #6
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,511
Blog Entries: 34
Rep Power: 86
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Robert,

I forgot to mention that looks can be deceiving:
Code:
ls -l `which mpicc`
If this shows that it is linking to another file, then check what that file is and if itself is yet another link!

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   February 24, 2012, 05:52
Default
  #7
Senior Member
 
Bernhard Linseisen
Join Date: May 2010
Location: Magdeburg/Geneva
Posts: 178
Blog Entries: 1
Rep Power: 7
Linse is on a distinguished road
Just for the case there are any doubts about the problem being due to mpi:
Did you check in the OpenFOAM-2.1.x/etc/config/settings.sh (or the one corresponding to your shell) if the correct C++-compiler is set there?

I just had serious build problems because I had not set the gcc46 manually...
Linse is offline   Reply With Quote

Old   July 18, 2012, 15:56
Default
  #8
New Member
 
Rafael J. Nebot Medina
Join Date: Jul 2012
Posts: 1
Rep Power: 0
rnebot is on a distinguished road
Hi,

I am a newbie and had the same problem. I have Ubuntu 12.04 and OpenFoam 2.1.1

The post from wyldckat about looking "mpicc -v" output gave me the clue. I had installed both "mpich2" and "openmpi" and the former was the one controlling "mpicc". Uninstalled "mpich2" and now it works.

Hope it helps
wyldckat and dark lancer like this.
rnebot is offline   Reply With Quote

Old   September 22, 2012, 11:28
Default Solving for MPICH2
  #9
New Member
 
Igor Peretta
Join Date: Sep 2012
Posts: 3
Rep Power: 4
iperetta is on a distinguished road
Greetings,

I know it's an old post, but the problem is still there... I'm working with OpenFoam 2.1.1 and Ubuntu Precise Pangolin (12.04LTS) and have the same errors with "gcc --showme:compile" and "gcc --showme:link". I'm a fan of MPICH2, so I don't have Open-MPI installed.

Searching a little in the internet, I've found out that "--showme:compile" and "--showme:link" are Open-MPI options only. To change that to work with MPICH2, I've had to edit "/opt/openfoam211/etc/config/settings.sh" file and exchange "mpicc --showme:compile" and "mpicc --showme:link" for "mpicc -compile-info" and "mpicc -link-info".

Hope this information is useful for somebody else.

Best wishes!
iperetta is offline   Reply With Quote

Old   September 22, 2012, 16:07
Default
  #10
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,511
Blog Entries: 34
Rep Power: 86
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Igor and welcome to the forum!

Many thanks for sharing this information about using the system's MPICH2! It would indeed be worth while sharing this at the bug tracker as well: http://www.openfoam.org/bugs/

But I still have got one question: did you use the Debian package installation of OpenFOAM for Ubuntu, or did you build from source?

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   September 22, 2012, 17:37
Default
  #11
New Member
 
Igor Peretta
Join Date: Sep 2012
Posts: 3
Rep Power: 4
iperetta is on a distinguished road
Hi, wyldckat (Bruno)

By the way, I'm using 64-bit Ubuntu...

I get it from apt-get, I suppose it is from an official Ubuntu repository... See what you get with this:

Code:
sudo apt-get install openfoam211 paraviewopenfoam3120
I'm also working with swap4Foam (groovyBC library) and this one I got to build from code...

I've already tried to post in http://www.openfoam.org/bugs/, but the site doesn't let me post there (it seems that they're looking for bugs, not solutions ).

Well... Keep it going! Hugs!
iperetta is offline   Reply With Quote

Old   September 23, 2012, 11:10
Default
  #12
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,511
Blog Entries: 34
Rep Power: 86
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Igor,

Wait... you're using the system's MPICH2 with the pre-built installation of OpenFOAM that was built with Open-MPI?
How does it not crash when running in parallel?

Or did you at least re-build the Pstream library for using MPICH2?

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   September 24, 2012, 11:25
Default
  #13
New Member
 
Igor Peretta
Join Date: Sep 2012
Posts: 3
Rep Power: 4
iperetta is on a distinguished road
Quote:
Originally Posted by wyldckat View Post
Wait... you're using the system's MPICH2 with the pre-built installation of OpenFOAM that was built with Open-MPI?
How does it not crash when running in parallel?
Sorry, Bruno... I didn't mean to confuse you... The error I mentioned showed up when I was running terminals... Please, identify to me a source (or example from tutorials) that I could run with MPI to ensure what's going on here. Actually, I'm a sort of newbie and I'm not running MPI applications right now...

As far as I though, "apt-get install" gets the source and build it for your machine. Correct me if I'm wrong, please. I don't know what comes with MPI build options...
iperetta is offline   Reply With Quote

Old   September 24, 2012, 11:51
Default
  #14
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,511
Blog Entries: 34
Rep Power: 86
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
In this case, apt-get will only install the packages, it doesn't build anything

As for a tutorial: go to the folder "multiphase/interFoam/laminar" in your own copy of the tutorials and run Allrun like this:
Code:
./Allrun
When it's finished, check in the folder "damBreakFine" and see what the file "log.interFoam" provides.
wyldckat is offline   Reply With Quote

Old   December 1, 2012, 12:53
Default
  #15
New Member
 
Matteo Ripepi
Join Date: Dec 2012
Location: Milano
Posts: 2
Rep Power: 0
mripepi is on a distinguished road
Hello everybody,

I had the same problem about the gcc '--showme:compile' and '--showme:link' errors, when installing OpenFoam 2.0.0 on my 64-bit Ubuntu 12.04 LTS system.
I solved it by adding in the etc/ folder a pref.sh file containing the following line:

Code:
export WM_MPLIB=OPENMPI
The pref.sh file will be automatically sourced by the OpenFOAM etc/bashrc, and it will replace the WM_MPLIB=SYSTEMOPENMPI setting.
Alternatively you can try with one of the following setting, depending on the MPI implementation you have on your system:

WM_MPLIB = SYSTEMOPENMPI | OPENMPI | MPICH | MPICH-GM | HPMPI | GAMMA | MPI | QSMPI


Hope this could help somebody else.


Regards,
Matteo
mripepi is offline   Reply With Quote

Reply

Tags
bashrc, gcc, mpi, openfoam, ubuntu

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to write k and epsilon before the abnormal end xiuying OpenFOAM Running, Solving & CFD 8 August 27, 2013 15:33
Building OpenFOAM1.7.0 from source ata OpenFOAM Installation 42 May 14, 2012 20:48
Upgraded from Karmic Koala 9.10 to Lucid Lynx10.04.3 bookie56 OpenFOAM Installation 8 August 13, 2011 04:03
IcoFoam parallel woes msrinath80 OpenFOAM Running, Solving & CFD 9 July 22, 2007 02:58
Could anybody help me see this error and give help liugx212 OpenFOAM Running, Solving & CFD 3 January 4, 2006 19:07


All times are GMT -4. The time now is 16:36.