CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Native Meshers: blockMesh (http://www.cfd-online.com/Forums/openfoam-meshing-blockmesh/)
-   -   Binary mode donbt work (http://www.cfd-online.com/Forums/openfoam-meshing-blockmesh/61852-binary-mode-donbt-work.html)

fabianpk September 14, 2005 03:53

I have a bit of a strange prob
 
I have a bit of a strange problem with OpenFOAM 1.2. When I have a mesh or a saved solution that's been saved in binary format, I can't use it for restarting the case or postprocessing with ParaFoam.
It doesn't matter if it's a mesh generated in gambit and converted, or if it's generated with blockMesh. It only works if I use the ascii format.

I get this message:

--> FOAM FATAL IO ERROR : Expected a ')' while reading binaryBlock, found on line 29 an error

file: ../refnozzleLES.ver12.schemetest/0.00204928/nuSgs at line 29.

From function Istream::readEnd(const char*)
in file db/IOstreams/IOstreams/Istream.C at line 111.




What have I done wrong?

/Fabian

mattijs September 14, 2005 03:58

Just out of interest, are you
 
Just out of interest, are you running with compression and if so what happens if you switch off compression?

hjasak September 14, 2005 03:59

Hmm, I've been using binary wi
 
Hmm, I've been using binary without problems a few days ago; however, compressed binary did not work. Did you use compression of the files (i.e. .gz extension on nuSgs)?

Hrv

fabianpk September 14, 2005 04:03

Yes, I always do. However, now
 
Yes, I always do. However, now I just noticed that it works if I turn off compression. Does Foam 1.2 use a new version of gzip?

/Fabian

mattijs September 20, 2005 10:27

Hi Fabian, can you post thi
 
Hi Fabian,

can you post this as a bug?

maka May 21, 2006 11:17

Can anyone post the fix of thi
 
Can anyone post the fix of this bug. I'm still using V 1.2. Thanks.

Kind regards,
Maka


All times are GMT -4. The time now is 23:26.