CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Native Meshers: blockMesh

Binary mode donbt work

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   September 14, 2005, 03:53
Default I have a bit of a strange prob
  #1
Member
 
Fabian Peng Karrholm
Join Date: Mar 2009
Posts: 61
Rep Power: 8
fabianpk is on a distinguished road
I have a bit of a strange problem with OpenFOAM 1.2. When I have a mesh or a saved solution that's been saved in binary format, I can't use it for restarting the case or postprocessing with ParaFoam.
It doesn't matter if it's a mesh generated in gambit and converted, or if it's generated with blockMesh. It only works if I use the ascii format.

I get this message:

--> FOAM FATAL IO ERROR : Expected a ')' while reading binaryBlock, found on line 29 an error

file: ../refnozzleLES.ver12.schemetest/0.00204928/nuSgs at line 29.

From function Istream::readEnd(const char*)
in file db/IOstreams/IOstreams/Istream.C at line 111.




What have I done wrong?

/Fabian
fabianpk is offline   Reply With Quote

Old   September 14, 2005, 03:58
Default Just out of interest, are you
  #2
Super Moderator
 
Mattijs Janssens
Join Date: Mar 2009
Posts: 1,416
Rep Power: 16
mattijs is on a distinguished road
Just out of interest, are you running with compression and if so what happens if you switch off compression?
mattijs is offline   Reply With Quote

Old   September 14, 2005, 03:59
Default Hmm, I've been using binary wi
  #3
Senior Member
 
Hrvoje Jasak
Join Date: Mar 2009
Location: London, England
Posts: 1,763
Rep Power: 21
hjasak will become famous soon enough
Hmm, I've been using binary without problems a few days ago; however, compressed binary did not work. Did you use compression of the files (i.e. .gz extension on nuSgs)?

Hrv
__________________
Hrvoje Jasak
Providing commercial FOAM/OpenFOAM and CFD Consulting: http://wikki.co.uk
hjasak is offline   Reply With Quote

Old   September 14, 2005, 04:03
Default Yes, I always do. However, now
  #4
Member
 
Fabian Peng Karrholm
Join Date: Mar 2009
Posts: 61
Rep Power: 8
fabianpk is on a distinguished road
Yes, I always do. However, now I just noticed that it works if I turn off compression. Does Foam 1.2 use a new version of gzip?

/Fabian
fabianpk is offline   Reply With Quote

Old   September 20, 2005, 10:27
Default Hi Fabian, can you post thi
  #5
Super Moderator
 
Mattijs Janssens
Join Date: Mar 2009
Posts: 1,416
Rep Power: 16
mattijs is on a distinguished road
Hi Fabian,

can you post this as a bug?
mattijs is offline   Reply With Quote

Old   May 21, 2006, 11:17
Default Can anyone post the fix of thi
  #6
Senior Member
 
Maka Mohu
Join Date: Mar 2009
Posts: 305
Rep Power: 9
maka is on a distinguished road
Can anyone post the fix of this bug. I'm still using V 1.2. Thanks.

Kind regards,
Maka
maka is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
I donbt understand antopnieta OpenFOAM Running, Solving & CFD 1 January 15, 2008 15:44
ReadCHEMKINIII donbt work mavimo OpenFOAM Bugs 1 August 23, 2007 11:49
I donbt want to use wall funtions How can I do it pablo OpenFOAM Running, Solving & CFD 3 July 29, 2006 17:48
FoamX donbt show some cases derath OpenFOAM Pre-Processing 1 April 28, 2006 13:16
Donbt save bak adorean OpenFOAM 0 March 10, 2005 05:52


All times are GMT -4. The time now is 04:26.