CFD Online Logo CFD Online URL
Home > Forums > OpenFOAM Native Meshers: blockMesh


Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree2Likes
  • 1 Post By ramhari
  • 1 Post By bernarde

LinkBack Thread Tools Display Modes
Old   November 7, 2009, 12:50
Default nonAlignedEdge?
Senior Member
Pei-Ying Hsieh
Join Date: Mar 2009
Posts: 313
Rep Power: 10
phsieh2005 is on a distinguished road
Dear OpenFOAMers,

I generated a mesh of axisymetric tube using blockMesh. When checked using checkMesh, I got the following message:

***Number of edges not aligned with or perpendicular to non-empty directions: 280332
<<Writing 287066 points on non-aligned edges to set nonAlignedEdges

and checkMesh saved the noneAlignedEdges to polyMesh/sets.

Can someone explain what it means?

When plotting with paraFoam, the mesh looked fine though.

phsieh2005 is offline   Reply With Quote

Old   January 28, 2010, 15:58
Senior Member
Claus Meister
Join Date: Aug 2009
Location: Wiesbaden, Germany
Posts: 241
Rep Power: 10
idrama is on a distinguished road
Hey Fomer,

I got the same problem. Have you gotten a solution to solve this problem.

Kinda regards

idrama is offline   Reply With Quote

Old   October 5, 2010, 13:03
Lars Kiewidt
Join Date: Sep 2009
Location: Germany
Posts: 54
Rep Power: 9
LarsPT is on a distinguished road
It's quite an old questions but maybe someone has a look here when facing this problem.
I found something about it on the OpenFOAM Wiki website. Paragraph 9 is the important one.

LarsPT is offline   Reply With Quote

Old   November 20, 2010, 01:04
New Member
Join Date: Aug 2010
Location: Chennai
Posts: 27
Rep Power: 8
ramhari is on a distinguished road
I got those 'nonAligned' issues..but after defining my patches properly with b.cs it gets
ykanani likes this.
ramhari is offline   Reply With Quote

Old   February 14, 2011, 03:26
Bernard Esterhuyse
Join Date: Mar 2009
Location: Pretoria, South Africa
Posts: 50
Rep Power: 9
bernarde is on a distinguished road
I also got those issues, but after propertly naming all my patches it disappeared, like ramhari said.
ykanani likes this.
bernarde is offline   Reply With Quote

Old   August 25, 2016, 07:16
New Member
Yingchen Cao
Join Date: May 2015
Posts: 2
Rep Power: 0
Yingchen is on a distinguished road
This is probably too late for replying this question. But I hope it will help the others, who will have the same problem in the future. I had the same problem. And I solved the problem by renaming all the points labels.
Yingchen is online now   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 11:04.