CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Native Meshers: blockMesh (http://www.cfd-online.com/Forums/openfoam-meshing-blockmesh/)
-   -   Blockmesh for swimming cylinder (http://www.cfd-online.com/Forums/openfoam-meshing-blockmesh/95354-blockmesh-swimming-cylinder.html)

v000v December 14, 2011 11:25

Blockmesh for swimming cylinder
 
1 Attachment(s)
Hallo,

I'm new here and i'm new with OpenFoam. So i work at simulation of swimming cylinder in waves. I've started to wright blockMeshDict file.
As reference for mesh generation i have took an example from ProgrammersGuide.pdf (openFoam parent dir. -->) page 47 ff..
So i want to see what i' ve done in Paraview, but there is a problem with block mesh. After typing in Terminal "blockMesh" from my case dir. i've got error that looks like:

--> FOAM FATAL IO ERROR:
Failed wmake "dynamicCode/_d908cad1f0f5da63365b2a5dd0f6be17536ee27d/platforms/linux64GccDPOpt/lib/libcodeStream_d908cad1f0f5da63365b2a5dd0f6be17536e e27d.so"


file: /home/v000v/OpenFOAM/v000v-2.0.1/run/tutorials/multiphase/interDyMFoam/ras/FLNG/constant/polyMesh/blockMeshDict from line 17 to line 17.

From function functionEntries::codeStream::execute(..)
in file db/dictionary/functionEntries/codeStream/codeStream.C at line 210.

FOAM exiting

Can anybody offer a solution for my problem?

v000v December 15, 2011 04:51

1 Attachment(s)
Hallo again,
I've got a couple of problems under control, so I've change a little bit my blockMeshDict.
Now i've got another one. I think that the problem is in a mesh at the edge between cylindrical mesh and the rest. That the faces are not identical on the both sides of edge.
How can I assemble my mesh so that there are same face number on the both sides of the edge?

Should i calculate it by side and arrange my mesh there for, or is there some skripts or other tricks to get the mesh works?

Thanks!

v000v December 21, 2011 08:30

1 Attachment(s)
Hallo again,

I've got my mesh to view. I have a problem with a boundary conditions in the mesh. "Down" should be my symmetry plane, so I have define all faces in this plane. Terminal massage says that a couple of them have no neighbor cell.
If i write these faces as comment, then turns openFoam in Paraview these faces to default faces and this pretty ugly.

So can anybody take a look at my Mesh and explain me what the case is?

Thank you guys.

MartinB December 21, 2011 08:59

1 Attachment(s)
Hi,

there were four minor problems, their correction marked with "// <---".

Should work now.

Martin

Bernhard December 21, 2011 08:59

Probably your facelist for some patches is not complete. Boundary faces that are not assigned to a patch form a seperate patch. This is probably what happened here.

v000v December 21, 2011 09:22

Quote:

Originally Posted by MartinB (Post 336609)
Hi,

there were four minor problems, their correction marked with "// <---".

Should work now.

Martin

Thanks, work's fine!

P.S. too much points and blocks to hold overview. Thank you!


All times are GMT -4. The time now is 01:10.