CFD Online URL
[Sponsors]
Home > Forums > Open Source Meshers: Gmsh, Netgen, CGNS, ...

Netgen .stl file import - segmentation fault

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   May 19, 2013, 16:14
Post Netgen .stl file import - segmentation fault
  #1
Senior Member
 
Artur's Avatar
 
Artur
Join Date: May 2013
Location: Southampton, UK
Posts: 202
Rep Power: 5
Artur is on a distinguished road
I have been trying to import a simple .stl geometry (extruded airfoil section created using Inventor 2013) into NETGEN 5.0 and got a "segmentation fault" error. I repeated this for .step and .iges with the same result.

I ran the OpenFOAM surfaceCheck and it returned "1 unconnected part". I then used the surfaceConvert supplied with OpenFOAM to turn the geometry into another .stl file. The new file could then be successfully imported into NETGEN.

Although I found a way around the problem I didn't really fix it. I am new to NETGEN software and would really like to know why this problem occurred and how the surfaceConvert fixed the issue?

Thanks.
Artur is offline   Reply With Quote

Reply

Tags
netgen, stl

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error bulding swak4Foam sfigato OpenFOAM Installation 18 August 22, 2013 13:41
swak4foam building problem GGerber OpenFOAM 45 July 30, 2013 16:08
friction forces icoFoam ofslcm OpenFOAM 3 April 7, 2012 11:57
"parabolicVelocity" in OpenFoam 2.1.0 ? sawyer86 OpenFOAM Running, Solving & CFD 21 February 7, 2012 12:44
error while compiling the USER Sub routine CFD user CFX 3 November 25, 2002 16:16


All times are GMT -4. The time now is 23:37.