CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   Open Source Meshers: Gmsh, Netgen, CGNS, ... (http://www.cfd-online.com/Forums/openfoam-meshing-open/)
-   -   Salomé to OpenFOAM (http://www.cfd-online.com/Forums/openfoam-meshing-open/95310-salome-openfoam.html)

Verfblikje December 13, 2011 08:41

Salomé to OpenFOAM
 
Dear forummembers,

I am trying to run a 2D multi-element airfoil simulation in simpleFoam. Salome is used to build the mesh. I am able to export the mesh to unv and convert it to OpenFOAM using unvToFoam. However, ParaView does not allow me to see the mesh. Also running simpleFoam does not work. Nevertheless the airfoil2D tutorial works like a charm. I am able to run it, see the mesh, and see the results. I get the following output in the terminal:

Code:

/*---------------------------------------------------------------------------*\
| =========                |                                                |
| \\      /  F ield        | OpenFOAM: The Open Source CFD Toolbox          |
|  \\    /  O peration    | Version:  2.0.1                                |
|  \\  /    A nd          | Web:      www.OpenFOAM.com                      |
|    \\/    M anipulation  |                                                |
\*---------------------------------------------------------------------------*/
Build  : 2.0.1-cce6c678443c
Exec  : simpleFoam
Date  : Dec 13 2011
Time  : 12:38:03
Host  : cfdworkstation
PID    : 2343
Case  : /home/blackshape/OpenFOAM/blackshape-2.0.1/run/flap_investigation/flap_35deg_tet-mesh_2011-12-13
nProcs : 1
sigFpe : Enabling floating point exception trapping (FOAM_SIGFPE).
fileModificationChecking : Monitoring run-time modified files using timeStampMaster
allowSystemOperations : Disallowing user-supplied system call operations

// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
Create time

Create mesh for time = 0

Reading field p



--> FOAM FATAL IO ERROR:

    patch type 'patch' not constraint type 'empty'
    for patch wall_left of field p in file "/home/blackshape/OpenFOAM/blackshape-2.0.1/run/flap_investigation/flap_35deg_tet-mesh_2011-12-13/0/p"

file: /home/blackshape/OpenFOAM/blackshape-2.0.1/run/flap_investigation/flap_35deg_tet-mesh_2011-12-13/0/p::boundaryField::wall_left from line 55 to line 55.

    From function emptyFvPatchField<Type>::emptyFvPatchField
(
    const fvPatch& p,
    const Field<Type>& field,
    const dictionary& dict
)

    in file fields/fvPatchFields/constraint/empty/emptyFvPatchField.C at line 100.

FOAM exiting

FWIW I have defined most of the surface groups separately. Meaning I have 7 or so groups. Also I have a group defaultFace. I am not sure why. For as far as I know I have not omitted any surfaces when I defined the groups in Salomé. The geometry is exported from CATIA V5 as .stp . The complete domain is already defined.

Is there anything I can try?

Thanks in advance,

Nick

P.S. I am sorry if this is in the wrong forum.


All times are GMT -4. The time now is 15:58.