CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Other Meshers: ICEM, Star, Ansys, Pointwise, GridPro, Ansa, ... (http://www.cfd-online.com/Forums/openfoam-meshing-other/)
-   -   FluentMeshToFoam Cannot find a single face in the mesh which uses vertices (http://www.cfd-online.com/Forums/openfoam-meshing-other/61700-fluentmeshtofoam-cannot-find-single-face-mesh-uses-vertices.html)

francesco_b February 29, 2008 12:24

Hi All, sometimes when I b
 
Hi All,

sometimes when I build my mesh, using HyperMesh and then exporting it as a fluent mesh (file .cas) ) I receive this error message:

--> FOAM FATAL ERROR : Problem : cannot find a single face in the mesh which uses vertices 4(80040 80037 80039 80041)

From function findFace(const primitiveMesh&, const face&)
in file fluentMeshToFoam.L at line 855.

FOAM exiting


Can you tell me what to do? I checked the mesh and everything seems to be ok

Thanks in advance

Francesco

francesco_b February 29, 2008 12:45

I found the error I have bu
 
I found the error

I have built the mesh with Hypermesh 7, opened with the 8 and converted, if I build it in the 8 there is no error.

I hope this could be useful to someone else

Regards

Hasselhoff May 20, 2009 04:12

Hi everyone. I received the same error.
The Mesh was generated with gambit and cannot be converted to Foam. I included some virtual edges/ points in order to mesh the interfaces.
The Mesh seems to be ok.

Thank you,

Michael

milos October 1, 2009 08:10

Quote:

Originally Posted by francesco_b (Post 184338)
I found the error

I have built the mesh with Hypermesh 7, opened with the 8 and converted, if I build it in the 8 there is no error.

I hope this could be useful to someone else

Regards

Could you please explain in more details what is exactly 'Hypermesh 7' and what does it do in the first place. I'm having same serious trouble with 'lost vertices' on every mesh that I generate.

Thanks a million!


All times are GMT -4. The time now is 00:57.