CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Other Meshers: ICEM, Star, Ansys, Pointwise, GridPro, Ansa, ...

FluentMeshToFoam Cannot find a single face in the mesh which uses vertices

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   February 29, 2008, 12:24
Default Hi All, sometimes when I b
  #1
Member
 
Francesco Boschetto
Join Date: Mar 2009
Location: Italy
Posts: 56
Rep Power: 8
francesco_b is on a distinguished road
Hi All,

sometimes when I build my mesh, using HyperMesh and then exporting it as a fluent mesh (file .cas) ) I receive this error message:

--> FOAM FATAL ERROR : Problem : cannot find a single face in the mesh which uses vertices 4(80040 80037 80039 80041)

From function findFace(const primitiveMesh&, const face&)
in file fluentMeshToFoam.L at line 855.

FOAM exiting


Can you tell me what to do? I checked the mesh and everything seems to be ok

Thanks in advance

Francesco
francesco_b is offline   Reply With Quote

Old   February 29, 2008, 12:45
Default I found the error I have bu
  #2
Member
 
Francesco Boschetto
Join Date: Mar 2009
Location: Italy
Posts: 56
Rep Power: 8
francesco_b is on a distinguished road
I found the error

I have built the mesh with Hypermesh 7, opened with the 8 and converted, if I build it in the 8 there is no error.

I hope this could be useful to someone else

Regards
francesco_b is offline   Reply With Quote

Old   May 20, 2009, 04:12
Default
  #3
New Member
 
Join Date: May 2009
Posts: 14
Rep Power: 8
Hasselhoff is on a distinguished road
Hi everyone. I received the same error.
The Mesh was generated with gambit and cannot be converted to Foam. I included some virtual edges/ points in order to mesh the interfaces.
The Mesh seems to be ok.

Thank you,

Michael
Hasselhoff is offline   Reply With Quote

Old   October 1, 2009, 08:10
Default
  #4
New Member
 
Milos Stanic
Join Date: Mar 2009
Location: Novi Sad, Serbia
Posts: 29
Rep Power: 8
milos is on a distinguished road
Quote:
Originally Posted by francesco_b View Post
I found the error

I have built the mesh with Hypermesh 7, opened with the 8 and converted, if I build it in the 8 there is no error.

I hope this could be useful to someone else

Regards
Could you please explain in more details what is exactly 'Hypermesh 7' and what does it do in the first place. I'm having same serious trouble with 'lost vertices' on every mesh that I generate.

Thanks a million!
milos is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Converting a mesh with splitted cells using fluentMeshToFoam jlpelerin OpenFOAM Other Meshers: ICEM, Star, Ansys, Pointwise, GridPro, Ansa, ... 4 April 25, 2011 16:56
BlockMesh following fluentMeshToFoam doesnbt find blockMeshDict gmcgregor OpenFOAM Native Meshers: blockMesh 3 November 13, 2008 02:05
FluentMeshToFoam Error A model face is not matched Shape detection failed vvqf OpenFOAM Other Meshers: ICEM, Star, Ansys, Pointwise, GridPro, Ansa, ... 2 June 1, 2006 07:06
Single face with excessively high Heat Trans Coeff mat w FLUENT 3 April 10, 2006 12:38
single face with 2 bcs???? Shankar FLUENT 6 September 7, 2002 00:23


All times are GMT -4. The time now is 08:29.