CFD Online Logo CFD Online URL
Home > Forums > OpenFOAM Other Meshers: ICEM, Star, Ansys, Pointwise, GridPro, Ansa, ...

Bug in Harpoon OpenFoam export function

Register Blogs Members List Search Today's Posts Mark Forums Read

LinkBack Thread Tools Display Modes
Old   January 5, 2007, 15:46
Default Hello, I got hold of a tria
Senior Member
Philippose Rajan
Join Date: Mar 2009
Location: Germany
Posts: 530
Rep Power: 16
philippose will become famous soon enough
I got hold of a trial license of Harpoon in the beginning of December last year, which runs out in a week from now, but unfortunately, I havent been able to run any significant simulations using meshes created using the software yet.

Basically, I installed Harpoon 2.4c on Linux and Windows machines. In the Linux version, there seems to be a problem with the mesh export functionality (not just the OpenFOAM export).

Once a mesh has been created, when I export it directly into the openFOAM format, there is an error in the "faces" file. The number of faces declared by the number at the top of the list does not match with the actual number of faces written (the actual face list is shorter than the declared number). I tried the Fluent export, but there seems to be some problem with the data written out, which is again related to the number of faces.

I saw this only in the Linux version of Harpoon. The exports works out fine in the Windows version.

The other problem was within Harpoon itself. After a meshing operation, I need to create patches... so I separate the surface generated into multiple surfaces using the "separate by feature" option. The splitting works out fine, but when I try to recombine surfaces, the system crashes (in Linux and Windows).

I found that this can be solved by first splitting the geometry by feature before meshing, and then recombining the surfaces after meshing... but in this case, the system crashes while exporting the mesh.

Has anyone else had such problems? And if so, any workarounds I can try out?

Have a nice day!

philippose is offline   Reply With Quote

Old   June 28, 2007, 07:36
Default Yes i had the same problems wi
New Member
Join Date: Mar 2009
Posts: 20
Rep Power: 8
jackdaniels83 is on a distinguished road
Yes i had the same problems with the written data. I contacted the support and told them. They answered to install the newest version (2.5.(b)), i did so and it works fine now.

jackdaniels83 is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Did you try Harpoon? HSeldon Main CFD Forum 3 November 27, 2006 05:50
Questions for the bdivb function in OpenFOAM gkang OpenFOAM Running, Solving & CFD 3 May 13, 2006 11:11
Fluent export function Benjamin FLUENT 3 April 5, 2006 03:56
Harpoon CFD-Junior Main CFD Forum 0 June 23, 2005 07:40
Harpoon CFD-junior Main CFD Forum 0 May 4, 2005 09:21

All times are GMT -4. The time now is 14:57.