CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Native Meshers: snappyHexMesh and Others

Helyx-OS (GUI for SnappyHexMesh

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree37Likes

Reply
 
LinkBack Thread Tools Display Modes
Old   September 15, 2012, 09:51
Default
  #41
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,506
Blog Entries: 34
Rep Power: 86
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
@Stefano: Mmm... OK, this was spotted sometime ago, where it couldn't find "libmpi.so.0". Now it complains about "libmpi.so.1"

Try step #5:
Quote:
Originally Posted by http://sourceforge.net/p/helyx-os/wiki/DownloadAndInstallation/
If you receive an error loading VTK libraries, with the accompanying
Code:
libmpi.so.0: cannot open shared object file: No such file or directory
then this error can be fixed by
Code:
ln -s $MPI_ARCH_PATH/lib/libmpi.so $MPI_ARCH_PATH/lib/libmpi.so.0
and in some, the 64 bit distribution will require instead
Code:
ln -s $MPI_ARCH_PATH/lib64/libmpi.so $MPI_ARCH_PATH/lib64/libmpi.so.0
But instead of "libmpi.so.0", use "libmpi.so.1".

Best regards,
Bruno
wyldckat is online now   Reply With Quote

Old   September 15, 2012, 11:47
Default
  #42
New Member
 
stefano pieretti
Join Date: Aug 2012
Posts: 12
Rep Power: 5
stez is on a distinguished road
Ok now libraries works, but it still can't open STL files, always the same error.
So I tried to generate the mesh with the older version, import it in the newer and run a simulation (I was looking for a working "rotating wall" simulation).
It generates wrong boundary conditions, "omega" should be "constant" instead of "uniform", so it gives error.
Since the error show up after some seconds, I tried the trick to be faster than the solver to modify the "0/U" file before it could read that field, and then it works (with simpleFoam), but it is not a good way to get it work.
I tried the same trick with DES but then it gives other errors with some patch, that I can't understand.

I have looked into HelyxOS dictData folder to see if there was some dict containing the wrong "omega" definition and fix it, but I didn't find any
stez is offline   Reply With Quote

Old   September 16, 2012, 03:50
Default
  #43
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,506
Blog Entries: 34
Rep Power: 86
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Stefano,

Quote:
Originally Posted by stez View Post
Ok now libraries works, but it still can't open STL files, always the same error.
I went back to your other posts and I can't figure it out... what is the exact error message you're getting?

Because, AFAIK, most of the other problems you're having should be fixed in the current version! At least from what I briefly saw in the bug reports.

Best regards,
Bruno
wyldckat is online now   Reply With Quote

Old   September 16, 2012, 04:42
Default
  #44
New Member
 
stefano pieretti
Join Date: Aug 2012
Posts: 12
Rep Power: 5
stez is on a distinguished road
Hi Bruno,

I've attached screenshots of the errors.
One is related to STL import.
The second to "omega" definition.
The last two are related to the DES error i said in previous post.

About the bug of moving wall, the old report was about the text field in the GUI (scalar field when a vector one was required), AFAIK.

Thank you for the support.
Attached Images
File Type: jpg Schermata del 2012-09-16 10:26:38.jpg (70.6 KB, 83 views)
File Type: jpg Schermata del 2012-09-16 10:32:12.jpg (43.6 KB, 62 views)
File Type: jpg Schermata del 2012-09-16 10:36:40.jpg (44.1 KB, 64 views)
File Type: jpg Schermata del 2012-09-16 10:36:43.jpg (49.2 KB, 61 views)
stez is offline   Reply With Quote

Old   September 16, 2012, 06:29
Default
  #45
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,506
Blog Entries: 34
Rep Power: 86
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Stefano,

OK, for each image:
  1. The bad character seems to either be a space, tab or line break. Therefore, look for:
    • spaces in names or trailing spaces in names.
    • tab characters going around anywhere in the code.
    • Bad line breaks can occur if you created the STL file in Windows/Mac or modified it in Windows/Mac or even if you copied the names from a Windows/Mac program, where the bad line break came along for the copy-paste ride.
  2. In the "omega" line, "uniform" should either be removed or replaced with "constant", as discussed here: http://www.openfoam.org/mantisbt/view.php?id=444
    A fix for this is to... I can't figure it out
    It should be possible to fix in HelyxOS' "dictData/" folder, but I can't figure out how this BC is coming to existence...
  3. and 4. - that boundary condition simply doesn't exist on OpenFOAM 2.1! Or at least I can't find it...
Best regards,
Bruno
wyldckat is online now   Reply With Quote

Old   September 16, 2012, 09:03
Default
  #46
New Member
 
stefano pieretti
Join Date: Aug 2012
Posts: 12
Rep Power: 5
stez is on a distinguished road
I'll check STL later. About image 3-4, the patch ffmaxy is the outlet of a small "wind tunnel", if this info could be useful.
stez is offline   Reply With Quote

Old   September 16, 2012, 10:47
Default
  #47
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,506
Blog Entries: 34
Rep Power: 86
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
About 3 and 4: what I meant was that the boundary condition "nutTurbulentIntensityLengthScaleInlet" does not exist in OpenFOAM 2.1.1/x and by I've looked at, neither does in 1.6-ext.
wyldckat is online now   Reply With Quote

Old   September 19, 2012, 22:36
Default
  #48
Member
 
plucas's Avatar
 
Anonymous
Join Date: Dec 2011
Location: Everywhere
Posts: 75
Rep Power: 5
plucas is on a distinguished road
Hello Bruno,

I am getting an error when trying to mesh my .stl file. I have meshed it fine using just snappyHexMesh, but I am always looking at trying new software. I got HELYX-OS running, but I haven't got passed the meshing stage. Any help would be awesome! The picture of the error is shown in the picture below.

Thanks,
Paul

plucas is offline   Reply With Quote

Old   September 20, 2012, 10:58
Default rotatingWallVelocity Definition
  #49
Senior Member
 
chegdan's Avatar
 
Daniel P. Combest
Join Date: Mar 2009
Location: St. Louis, USA
Posts: 546
Rep Power: 18
chegdan will become famous soon enough
@Stez and @wyldkat
1) The issue with the rotatingWallVelocity has been added as a bug on sourceforge.
2) the nutTurbulentIntensityLengthScaleInlet issue has been listed as a bug to be fixed. To get around this, fixedValue can be used to define nuTilda instead. Sourceforge Tickets

@Paul Can you give more information how you received this error? Maybe provide the .stl or an example?
__________________
Dan

Find me on twitter @dancombest and LinkedIn

Last edited by chegdan; September 20, 2012 at 11:23. Reason: more info
chegdan is offline   Reply With Quote

Old   September 20, 2012, 20:53
Default
  #50
Member
 
plucas's Avatar
 
Anonymous
Join Date: Dec 2011
Location: Everywhere
Posts: 75
Rep Power: 5
plucas is on a distinguished road
Quote:
Originally Posted by chegdan View Post
@Paul Can you give more information how you received this error? Maybe provide the .stl or an example?
I just got helyxOS working after fixing the vtk libraries. I setup the preprocessing like they showed on the youtube video using basic mesh to see if I could get it working. The blockMesh setup is shown in the picture below.



The surface refinement is shown below.



The mesh screen is now shown below.



After I hit mesh, the error pops up.

The .stl is too large to upload.
plucas is offline   Reply With Quote

Old   September 24, 2012, 05:21
Default
  #51
New Member
 
Thomas Schumacher
Join Date: Mar 2009
Posts: 2
Rep Power: 0
thomas_schumacher is on a distinguished road
Hi,
not sure it is related to that, but try to place your material point further up. At the moment it sits directly on the lower surface of your blockMesh. Maybe this creates problems. Use z=2m for example.

Thomas
plucas likes this.
thomas_schumacher is offline   Reply With Quote

Old   September 24, 2012, 06:21
Default
  #52
Member
 
plucas's Avatar
 
Anonymous
Join Date: Dec 2011
Location: Everywhere
Posts: 75
Rep Power: 5
plucas is on a distinguished road
Quote:
Originally Posted by thomas_schumacher View Post
Hi,
not sure it is related to that, but try to place your material point further up. At the moment it sits directly on the lower surface of your blockMesh. Maybe this creates problems. Use z=2m for example.

Thomas
Thanks, I will give that a try when I get home from work.
plucas is offline   Reply With Quote

Old   September 25, 2012, 09:08
Default
  #53
Member
 
plucas's Avatar
 
Anonymous
Join Date: Dec 2011
Location: Everywhere
Posts: 75
Rep Power: 5
plucas is on a distinguished road
Quote:
Originally Posted by thomas_schumacher View Post
Hi,
not sure it is related to that, but try to place your material point further up. At the moment it sits directly on the lower surface of your blockMesh. Maybe this creates problems. Use z=2m for example.

Thomas
I tried this last night and I got the same error. Any other suggestions?
plucas is offline   Reply With Quote

Old   September 28, 2012, 08:37
Default
  #54
Senior Member
 
Vincent RIVOLA
Join Date: Mar 2009
Location: France
Posts: 277
Rep Power: 9
vinz is on a distinguished road
Hi everybody,

HelyxOs is working fine for me.
However I wanted to have a look at the software and I tried to import the sources into eclipse.
I've got some problems to run it from eclipse so I would like to know if some of them managed to do it?
vinz is offline   Reply With Quote

Old   September 28, 2012, 13:19
Default
  #55
New Member
 
stefano pieretti
Join Date: Aug 2012
Posts: 12
Rep Power: 5
stez is on a distinguished road
Hi
I think I've found another bug..
I'm working with .stl made with Blender. When I load them in HelyxOS the generated patch name in dict files is [filename]ExportedfromBlender-263(sub17). With this name nothing works (error sounds like it could not locate that patch name in some dict files), but if i delete the -263(sub17) part from the patch name in the "boundaries" file it works. Strange thing is that Openfoam works without problem with the complete name.. Is it related to HelyxOS?
stez is offline   Reply With Quote

Old   September 29, 2012, 09:47
Default
  #56
Senior Member
 
chegdan's Avatar
 
Daniel P. Combest
Join Date: Mar 2009
Location: St. Louis, USA
Posts: 546
Rep Power: 18
chegdan will become famous soon enough
Quote:
Originally Posted by stez View Post
Hi
I think I've found another bug..
I'm working with .stl made with Blender. When I load them in HelyxOS the generated patch name in dict files is [filename]ExportedfromBlender-263(sub17). With this name nothing works (error sounds like it could not locate that patch name in some dict files), but if i delete the -263(sub17) part from the patch name in the "boundaries" file it works. Strange thing is that Openfoam works without problem with the complete name.. Is it related to HelyxOS?
Comment Edited : I am going through to try and reproduce this issue, but I am unable to do so. I have an STL file with the name, ExportedfromBlender-263(sub17).stl and everything is imported into HelyxOS fine and meshes as expected. Also, it really should be ok to have a file with a minus sign in it... Can you give some more details on how to reproduce this?

Right now its on the sourceforge ticket tracker but it needs some more detail. Otherwise, thanks for pointing this one out.
__________________
Dan

Find me on twitter @dancombest and LinkedIn

Last edited by chegdan; October 2, 2012 at 06:39. Reason: epiphany and edited for clarity and to be more constructive
chegdan is offline   Reply With Quote

Old   October 5, 2012, 14:52
Default
  #57
Member
 
hadi abdollahzadeh
Join Date: Aug 2012
Location: Iran-yasouj
Posts: 59
Rep Power: 5
dark lancer is on a distinguished road
hi
i have downloaded helyxos but its 64bit and I have not found for 32 bit because my linux is 32 bit and
When I launch helyx (./helyxOS.sh) I get the following message.
[hadi@hadi v1.0.0]$ ./helyxOS.sh
java -Xms128m -Xmx512m -jar ./lib/HelyxOS.jar
./helyxOS.sh: line 124: ./../jre/bin/java: cannot execute binary file
dark lancer is offline   Reply With Quote

Old   October 8, 2012, 06:07
Default
  #58
Senior Member
 
chegdan's Avatar
 
Daniel P. Combest
Join Date: Mar 2009
Location: St. Louis, USA
Posts: 546
Rep Power: 18
chegdan will become famous soon enough
Quote:
Originally Posted by dark lancer View Post
hi
i have downloaded helyxos but its 64bit and I have not found for 32 bit because my linux is 32 bit and
When I launch helyx (./helyxOS.sh) I get the following message.
[hadi@hadi v1.0.0]$ ./helyxOS.sh
java -Xms128m -Xmx512m -jar ./lib/HelyxOS.jar
./helyxOS.sh: line 124: ./../jre/bin/java: cannot execute binary file
HelyxOS is 64 bit, so you will have to recompile it for 32 bit to get it working for you.
__________________
Dan

Find me on twitter @dancombest and LinkedIn
chegdan is offline   Reply With Quote

Old   October 9, 2012, 07:33
Question
  #59
Member
 
hadi abdollahzadeh
Join Date: Aug 2012
Location: Iran-yasouj
Posts: 59
Rep Power: 5
dark lancer is on a distinguished road
Quote:
Originally Posted by chegdan View Post
HelyxOS is 64 bit, so you will have to recompile it for 32 bit to get it working for you.
How can I recompile it to 32 bit?
dark lancer is offline   Reply With Quote

Old   October 10, 2012, 04:39
Default
  #60
New Member
 
Paolo Geremia
Join Date: Aug 2012
Posts: 11
Rep Power: 5
pgeremia is on a distinguished road
@plucas: currently there is a bug affecting the automatic block mesh option whereas everything should run fine if you use the user defined option. However, if you have set block mesh to automatic type, just save the case, re-open the case and set the block mesh type to user-defined option which should be automatically filled for you by Helyx-OS. Can you double-check please?

@dark lancer: there are no installation/compilations instructions available for 32bit as we currently don't support Helyx-OS on 32bit. However, there are some examples (e.g. Helyx-OS (GUI for SnappyHexMesh) of successfull installations on 32bit systems. The main idea is to use the system VTK libraries as well as the system vtk.jar file to replace the 64bit ones available in Helyx-OS before you compile Helyx-OS, but this depends on the OS you have and thus there is no general guidelines I can provide.
pgeremia is offline   Reply With Quote

Reply

Tags
cases setup, preprocessor, snappyhexmesh

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Helyx-OS Open Source GUI for OpenFOAM eugene OpenFOAM Announcements from Other Sources 14 July 13, 2015 10:39
TUI Commands from GUI? Carlos FLUENT 6 May 22, 2013 18:05
User Defined GUI Frederik FLUENT 0 June 23, 2006 16:12
Command Line vs. GUI Menus Go FLUENT 0 June 8, 2005 16:05
GUI window settings cmv CD-adapco 0 February 7, 2005 07:22


All times are GMT -4. The time now is 17:55.