CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Native Meshers: snappyHexMesh and Others (http://www.cfd-online.com/Forums/openfoam-meshing-snappyhexmesh/)
-   -   ignored parts of geometry during refinement (http://www.cfd-online.com/Forums/openfoam-meshing-snappyhexmesh/107123-ignored-parts-geometry-during-refinement.html)

Eloise September 18, 2012 08:37

ignored parts of geometry during refinement
 
1 Attachment(s)
Hello,

A part of my geometry is composed of poles, for which I impose a given refinement level. Most of the poles are refined as expected, but some of them are ignored in the refinement stage. They end up with very large resolution (see attached image).
Do you know how I can avoid this?

Remarks:
- The maximum amount of cells is not reached during castellation step.
- minRefinementCells was set to 0 without any impact.
- all the poles are part of the same STL input file and should therefore be treated the same way.

Thanks for your help,
Elo´se

Eloise September 20, 2012 09:26

no idea?
I must say it is not really critical in my mesh, but I'm curious to find out its reason :)

Tobi September 25, 2012 06:21

Quote:

Originally Posted by Eloise (Post 382758)
no idea?
I must say it is not really critical in my mesh, but I'm curious to find out its reason :)

Hey ...
maybe your sHM stop refining couse of reaching "maxGloballCells". So if your mesh reaches that limit, sHM stop direct without refining other zone.

Set that value higher - maybe that is the solution for your problem.

Eloise September 25, 2012 07:15

Hi Tobi,
The maxGlobalCells is not the problem, I've already checked that point.
Thanks anyway :)

kalle September 25, 2012 07:39

Hi,

did you specify surface refinement or feature line refinement?

K

Eloise September 26, 2012 10:23

Hi Karl,

Surface refinement is the same for all the geometry as it comes from a single STL file.
But the feature edges refinement did the trick. All geometry is refined, and mesh quality was slightly improved. However, I haven't used the "snap to feature edges" option as this results in the following error message from sHM "Did not succesfully snap mesh. Giving up."

Thanks,
Elo´se

kalle September 28, 2012 02:45

I see... I was asking since there is a bug which causes snappy to ignore some refining specified on feature lines:

http://www.openfoam.org/mantisbt/view.php?id=552

Since you only specified surface refinement, you should not be affected by that.

I'd guess the error message you get is because snappy could not snap to the surface while maintaining good mesh quality... playing around with settings may help:

http://openfoamwiki.net/index.php/SnappyHexMesh

Good luck,
K

Eloise September 28, 2012 03:36

Hi Karl,

I am not especially looking for snapping at those feature edges so I will leave it as it is. If I had to snap, I should first increase the refinement level, but then my mesh would get very large. I have to avoid that.

I am also aware of this bug in 2.0 as I have this issue in another location in my geometry. I'm trying to upgrade to 2.1 but it is not as easy as it looks like... I hope I will soon be a part of the "2.1 foamers community" :D

Elo´se


All times are GMT -4. The time now is 17:09.