CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Native Meshers: snappyHexMesh and Others (http://www.cfd-online.com/Forums/openfoam-meshing-snappyhexmesh/)
-   -   Baffle from Blender .stl won't mesh with SHM (http://www.cfd-online.com/Forums/openfoam-meshing-snappyhexmesh/108014-baffle-blender-stl-wont-mesh-shm.html)

timbojones October 12, 2012 01:59

Baffle from Blender .stl won't mesh with SHM
 
Hello All,

I have created a pipe geometry with a zero-thickness baffle at the centerline for a portion of the pipe. I also export the pipe wall, inlet, and outlet as well as the battle to a .stl file. When I try to create the feature edge mesh, I'm told that it only works for closed geometry. If I go ahead and run SHM, I'm told that my .stl is not searchable and I get no mesh.

I think my problem has to do with the fact that the opposite sides of the baffle don't point into the domain. Has anyone encountered this problem and know of a fix? Any help would be very much appreciated.

Regards,
Timbojones

wyldckat October 13, 2012 05:14

Greetings Timbojones,

AFAIK, you have define in "snappyHexMeshDict" to mesh using multiple zones. Because the baffle you're trying to create using an STL implies that the mesh will have two independent sections!

After the mesh is complete, you can use createBaffles, if I'm not mistaken.

Best regards,
Bruno

timbojones October 17, 2012 23:57

A very nice procedure for setting up SHM for this case can be found here.

http://www.cfd-online.com/Forums/ope...pyhexmesh.html

I've tried it for my case and it works well for defining a basic mesh. My next difficulty comes when I want to add layers to the baffle. Simply adding layers for the refinement surface prior to running createBaffles will not introduce the near-baffle layering in the mesh. Running SHM with layering only after creating the battle won't do the job either. What am I still missing here? I really appreciate all the help I've gotten from the forum.

Thanks to all.

Joanna Huang January 9, 2013 11:48

Quote:

Originally Posted by timbojones (Post 386224)
Hello All,

I have created a pipe geometry with a zero-thickness baffle at the centerline for a portion of the pipe. I also export the pipe wall, inlet, and outlet as well as the battle to a .stl file. When I try to create the feature edge mesh, I'm told that it only works for closed geometry. If I go ahead and run SHM, I'm told that my .stl is not searchable and I get no mesh.

I think my problem has to do with the fact that the opposite sides of the baffle don't point into the domain. Has anyone encountered this problem and know of a fix? Any help would be very much appreciated.

Regards,
Timbojones

Hello, can you please tell me how to exprot the boundary specification into a . stl file, what kind of software are you using, thank you so much for that


All times are GMT -4. The time now is 21:27.