CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Native Meshers: snappyHexMesh and Others (http://www.cfd-online.com/Forums/openfoam-meshing-snappyhexmesh/)
-   -   surfaceFeatureExtract surface.stl (http://www.cfd-online.com/Forums/openfoam-meshing-snappyhexmesh/122581-surfacefeatureextract-surface-stl.html)

gooya_kabir August 22, 2013 11:09

surfaceFeatureExtract surface.stl
 
Hi friends

I'm trying to make .emesh file from my .stl file for snappyHesh. but when I apply the command: srfaceFeatureExtract,this happens:
FOAM FATAL ERROR:
Cannnot read "surface.stl"

From function triSurface::read(const fileName&, const word&, const bool)
in file triSurface/triSurface.C at line 369.
can you give a comment about it?

Many thanks

nimasam August 22, 2013 16:43

Dear Reza

you might saved your STL file in binary format :), so i guess if you save it in ASCII format, then error would be solved

gooya_kabir August 22, 2013 17:43

many thanks
 
would you help me how to change .stl to binary one?
I tried autocad, but it didnt work

nimasam August 23, 2013 11:13

Open your STL file in paraview and save in in STL format ASCII one ;)

gooya_kabir August 26, 2013 04:02

same error
 
Hi Sam,

Thank you for your help, I saved the file in Ascii format and run it again, but the same error appeared:
Rezas-MacBook-Pro:chalk reza$ surfaceFeatureExtract -includedAngle 150 pores.stl features
/*---------------------------------------------------------------------------*\
| ========= | |
| \\ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \\ / O peration | Version: 2.1.1 |
| \\ / A nd | Web: www.OpenFOAM.org |
| \\/ M anipulation | |
\*---------------------------------------------------------------------------*/
Build : 2.1.1-221db2718bbb
Exec : surfaceFeatureExtract -includedAngle 150 pores.stl features
Date : Aug 26 2013
Time : 09:57:48
Host : "Rezas-MacBook-Pro.local"
PID : 483
Case : /Volumes/OpenFOAM-v2.1.1/OpenFOAM-2.1.1/tutorials/mesh/snappyHexMesh/chalk
nProcs : 1
sigFpe : Enabling floating point exception trapping (FOAM_SIGFPE).
fileModificationChecking : Monitoring run-time modified files using timeStampMaster
allowSystemOperations : Disallowing user-supplied system call operations

// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
Create time

Feature line extraction is only valid on closed manifold surfaces.
Surface : "pores.stl"
Output feature set : "features"



--> FOAM FATAL ERROR:
Cannnot read "pores.stl"

From function triSurface::read(const fileName&, const word&, const bool)
in file triSurface/triSurface.C at line 369.

FOAM exiting



What do you think????

thanks

nimasam August 26, 2013 10:01

i have no idea, you may want to post your test case here, then OpenFOAM users can help you

gooya_kabir August 31, 2013 17:13

same thing
 
1 Attachment(s)
Hi friends,

As I told my problem, I could not use surfacefeature extract and above message come to my terminal after run. I tried with many cases and I got the same result!!! I uploaded one of the stl files. If you can see that what's the problem, it would be a great help for me.

Thank you in advance

nimasam September 1, 2013 02:17

1 Attachment(s)
did you edit your surfaceFeatureExtractDict at all?
However, it works for me ;) , i used OF-2.2.0, and i add working test case with your stl file

to use following test case:

1- open zip file
2- run script

Code:

./preAllrun

gooya_kabir September 24, 2013 05:28

Thanks
 
Many thanks for your help. As you helped me I could solve the problem. In my case, OF could not find the directory but it showed an error about not being able to read the file. I change the path and it work.
Now I generate the mesh, but since the surface structure is complicated, I do not know how to define the boundary (Wall type) on the surface. Is there any feature which help me to define the boundary on the surface?

Regards

Rophys February 15, 2016 11:54

surfaceFeatureExtract not working in OpenFOAM-v3.0+
 
Hi all,

I am trying to use the surfaceFeatureExtract in the motorBike (OpenFOAM-v3.0+) tutorial case; however it is not working. It always says "command not found".

Do you know if the surfaceFeatureExtract still in use in OpenFOAM-v3.0+ ? How to solve this problem ?

Thanks.

maryCFD April 6, 2016 12:15

surfaceFeatureExtract with OpenFOAM-v3.0+
 
Hi Rophys,

I can assure you that surfaceFeatureExtract still works in OpenFOAM-v3.0+.
But I don't know what is wrong with it in your case. Can you post more details ? Are you sure of your installation ?

Mary

Rophys April 6, 2016 12:39

Hi Mary,

Thanks for that. I already solved the problem =)

Cheers,

Rodrigo

Ruzic April 24, 2016 15:14

Hi,

I have also the same problem with command surfaceFeatureExtract, and got message command not found, on OpenFOAM-v3.0+.

What to do?

Thanks

JulienS June 3, 2016 05:11

Hi all,

I also have the problem with "command not find". My installation looks correct, solvers work fine apart of that.
Rophys, how did you solve the problem?

Best regards

Julien

msuaeronautics June 7, 2016 11:01

I am having this same issue with 3.0+. Considering rolling back to a previous version, but if it is assured to work then I am not sure how to fix the problem.

zxzx October 6, 2016 22:23

I have also the same problem with command surfaceFeatureExtract, and got message command not found, on OpenFOAM4.0.

Please tell me how to solve it.

Thanks

ZX

Ruzic October 9, 2016 02:47

I solved the issue by removing the installation and installed it again. Now works.

zxzx October 9, 2016 23:22

Thanks, I did it too. Now it works


All times are GMT -4. The time now is 17:18.