CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Native Meshers: snappyHexMesh and Others (http://www.cfd-online.com/Forums/openfoam-meshing-snappyhexmesh/)
-   -   Missing elements near surface with snappyHexMesh (http://www.cfd-online.com/Forums/openfoam-meshing-snappyhexmesh/80154-missing-elements-near-surface-snappyhexmesh.html)

jmf September 16, 2010 17:27

Missing elements near surface with snappyHexMesh
 
1 Attachment(s)
Hello everybody

I'm struggling to solve mesh quality problems on the surface of my model : small holes due to missing elements near the model surface.

These holes always occur near transition between patches with different levels

I attached
- a clipped view of flaw in volume
- a view of the surface (from inside the volume) with 3 flaws
- the snappyHexMeshDict

Is the smoothness of the mesh at the surface normal ? I think that it is poor...

I run OF1.7.1 on 64 bit Linux, compiled from sources

Any tip would be appreciated


Regards

J-Michel

jmf September 18, 2010 06:18

Missing cells near surface with snappyHexMesh
 
2 Attachment(s)
Hello

I go on investigating

This problem only occurs when surface is tilted compared with backgroung hex mesh. I tried 10 and 20 degrees slope. (image attached at 20 degrees)

With surface parallel to background mesh, snappy mesh is smooth (image attached)

The problem is the same with prebuild OF1.6 32 bits

Best wishes

jean-Michel

ziad September 22, 2010 23:07

Hi Jean-Michel,

Is your geometry smooth enough at these locations? Maybe you could increase the tessellation at these locations in the stl file. It could be a defect in the geometry file.

Otherwise it seems to be a snapping problem. How about increasing nSmoothPatch?

Try running checkMesh -latestTime to see if these elements are not contorted.

Ziad

jmf September 27, 2010 18:48

Missing cells near surface with snappyHexMesh
 
Hi Ziad

Thanks for your answer

I tried increasing nSmoothPatch without result. But then I tried systematic modifications of other Snappy parameters, and finally I found that maxConcave = 90 (instead of 30) solved my problem

Best wishes

Jean-Michel

ziad September 27, 2010 18:55

Quote:

Originally Posted by jmf (Post 276844)
Hi Ziad

Thanks for your answer

I tried increasing nSmoothPatch without result. But then I tried systematic modifications of other Snappy parameters, and finally I found that maxConcave = 90 (instead of 30) solved my problem

Best wishes

Jean-Michel


Thanks for posting the solution Jean-Michel. It's funny but the maxConcave parameter seems to be quite influent on the mesh. I managed to get a mesh without the ragged/jagged edges by reducing maxConcave to 1.0 and it's good to know that it can also fix this type of problems.

Cheers,
Ziad

Stylianos August 27, 2013 09:25

Thanks for the help guys


All times are GMT -4. The time now is 21:03.