CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Native Meshers: snappyHexMesh and Others (http://www.cfd-online.com/Forums/openfoam-meshing-snappyhexmesh/)
-   -   Layer addition problem near symmetry planes (http://www.cfd-online.com/Forums/openfoam-meshing-snappyhexmesh/91597-layer-addition-problem-near-symmetry-planes.html)

bigbang August 16, 2011 10:25

Layer addition problem near symmetry planes
 
4 Attachment(s)
It seems the more layer addition iterations I specify, the more it eats away at the boundary layer...

Please see attached pics and snappyHexMeshDict file.

Thanks.

bigbang August 16, 2011 10:49

1 Attachment(s)
Again, I answer my own questions...

I changed:

addLayersControls
{
nGrow 0; //(previously was 1)
}

So nGrow seemed to have been forcing the boundary layer further and further away at each iteration.

I still have the problem of a crease along the symmetry plane. See attached picture. From the forum, I gather this is a common problem...

Friederike December 1, 2011 06:26

Solution?
 
Hey bigbang,
I have the same problem did you find a solution?

Regards,
Friederike

bigbang December 1, 2011 07:04

Sorry Friederike, I never solved this one.

The solution is to buy more hardware and solve the whole field :o

But there may be some promise if you look into the new edge handling feature in openfoam 2.x (part of snappyHexMesh).

bouclette December 3, 2011 13:47

Hi there,

Try changing your "symmetry" boundary to "empty" in order to get the BL all the way. This workaround does work sometimes but make sure it doesn't messes up the BL somewhere else. :)

Regards,

B.

bigbang December 5, 2011 11:06

Quote:

Originally Posted by bouclette (Post 334557)
Hi there,

Try changing your "symmetry" boundary to "empty" in order to get the BL all the way. This workaround does work sometimes but make sure it doesn't messes up the BL somewhere else. :)

Regards,

B.

In my experience this doesn't work, but I have seen this solution before on the forum. Good luck.

Friederike December 8, 2011 07:35

2 Attachment(s)
Hey,
thanks for the answers. I changed the symmetry boundary condition to empty and it worked so far, that close to the boundary the layer looked good. Unfortunately the boundary layer does not strech around the whole geometry. It starts and stops and I don't know why. I attached picutures ...
Any experience with that, anyone?


All times are GMT -4. The time now is 15:32.