CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Native Meshers: snappyHexMesh and Others

sHM problem

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   September 26, 2011, 09:37
Default sHM problem
  #1
Senior Member
 
stephane sanchi
Join Date: Mar 2009
Posts: 300
Rep Power: 9
openfoam_user is on a distinguished road
Hi,

I have a problem using sHM.

I have a pipe with inside 3 blades. The 3 blades are identical.

Cells inside the first blade are not deleted !

WHY ?

Attached is a picture showing the problem.

Has someone already encountered such a problem ?

Regards,

Stephane.
Attached Images
File Type: jpg image.jpg (101.8 KB, 54 views)
openfoam_user is offline   Reply With Quote

Old   September 26, 2011, 10:47
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,511
Blog Entries: 34
Rep Power: 86
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Stephane,

Probably there is a small hole in the filled blade. Google:
Code:
openfoam "admesh"
It should show you a few solutions for plugging the hole(s).

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   September 30, 2011, 02:01
Default
  #3
Senior Member
 
stephane sanchi
Join Date: Mar 2009
Posts: 300
Rep Power: 9
openfoam_user is on a distinguished road
Hi Bruno,

Find attached 3 other pictures.

The first one is a global view of the right corners. Second and third are zoomed pictures. This time each corner has 7 blades. The blades are identical in each corner. So there is no problem (holes) with the blade geometry.

As you can see, sometimes cells are not deleted inside the blades.

Picture 2 (top right corner) : cells inside 2 blades are not deleted !

Bottom corner has no problem (picture 3).

This is very strange. I can't find any explanation. Need help ...

Regards,

Stephane.
Attached Images
File Type: jpg pict1.jpg (70.7 KB, 22 views)
File Type: jpg pict2.jpg (99.9 KB, 24 views)
File Type: jpg pict3.jpg (99.3 KB, 23 views)
openfoam_user is offline   Reply With Quote

Old   October 1, 2011, 12:16
Default
  #4
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,511
Blog Entries: 34
Rep Power: 86
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Stephane,

Mmm... if the surface for each of those two blades are really water tight, then it might be a numerical problem. Are you able to isolate the each one of those damaged blades into separate STL files? Then check the following two details on those two independent blades:
  1. Really confirm if they are water tight. Check with both admesh and Blender. Also check in Blender if the triangle normals all point in the same direction, inside or outside.
  2. OpenFOAM 2.0 brings a lot of new nice utilities for surface handling and verifying. Such example is:
    Code:
    surfaceMeshInfo surface.stl
    This should give you some statistics about the STL geometry. If there are any veeeeery small triangles, they might not be properly seen by snappyHexMesh during mesh generation and therefore be considered to be holes.
Worst case scenario: I believe it would be the case where one or more points in those STL geometries fall directly in the same exact place of a vertex of mesh cells created during the 1st stage of castellated mesh generation and refinement in snappyHexMesh. For this, a trick would be to increase or decrease the resolution for the base mesh that is generated with blockMesh! Or even moving the corners of the base mesh, even if just a little bit.

Best regards and good luck!
Bruno
wyldckat is offline   Reply With Quote

Old   October 3, 2011, 10:33
Default
  #5
Senior Member
 
stephane sanchi
Join Date: Mar 2009
Posts: 300
Rep Power: 9
openfoam_user is on a distinguished road
Hi Bruno,

I think what is happening is your worst case scenario.

I have moved the domain (blockMeshDict) a little bit in the x-direction. And now cells are deleted into the blades. But the problem occurs for other blades. Till now I haven't succeed in finding the right location for the flow domain.

And my final geometry has more than 10 blades in each of the 4 corners !!!

Stephane.
openfoam_user is offline   Reply With Quote

Old   October 3, 2011, 10:50
Default
  #6
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,511
Blog Entries: 34
Rep Power: 86
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Stephane,

I've just remembered that this problem might be overcome by adjusting the tolerances. Check the following file in OpenFOAM's folder:
Code:
applications/utilities/mesh/generation/snappyHexMesh/snappyHexMeshDict
There are 3 variables that might help there:
  • Near the end of the file:
    Code:
    mergeTolerance 1e-6;
  • Lines 41-42:
    Code:
            //tolerance   1E-5;   // optional:non-default tolerance on intersections
            //maxTreeDepth 10;    // optional:depth of octree. Decrease only in case
Along with these, it's also worth a try is the write tolerance set in "system/controlDict".

And I assume you aren't using the "Single Precision" build of OpenFOAM! If so, use the default "Double Precision"!

Good luck!
Bruno
wyldckat is offline   Reply With Quote

Old   October 5, 2011, 04:34
Default
  #7
Senior Member
 
stephane sanchi
Join Date: Mar 2009
Posts: 300
Rep Power: 9
openfoam_user is on a distinguished road
Hi Bruno,

Adding or changing the tolerance values has no effect for me.

Now I have 3 corners with 7 blades each that have a nice mesh. I have just add 1 cell in each direction by modifying the blockMeshDict file. But the problem remains for the 4th corner. 2 blades have cells inside !

I try to change the number of cells in direction and/or moving a little bit the location of the background mesh. I need luck. Unfortunately that's not the right solution.

Regards,

Stephane.
openfoam_user is offline   Reply With Quote

Old   October 5, 2011, 09:41
Default
  #8
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,511
Blog Entries: 34
Rep Power: 86
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Stephane,

OK, then first mesh only the castellatedMesh stage. Check which cube-like cells are the ones at fault.
The key detail is whether there are cell vertexes that fall on top of the surface being meshed.

The other possibility is to change the way the base mesh is being created. For example, divide the domain into 4 or 9 blocks, where each corner block is generated using a gradually graded mesh. This would make it harder for the cell vertexes to fall into the surfaces.
For this, you can also use refineMesh with a refineMeshDict (plus cell sets to help select the corners), for refining only in the respective corners, instead of dividing the mesh into 9 parts directly in blockMeshDict.

I've now remembered about a similar issue I found out when running snappyHexMesh in single precision, in the end of last year; check this note by Mattijs: http://www.openfoam.com/mantisbt/view.php?id=116#c198
Hopefully those tricks he talks about will help you get a good solution!

Last but not least, I would also try meshing the domain with only the blades. This might help verify if this is a global problem or if it's only related to enclosed domains!

Good luck!
Bruno
wyldckat is offline   Reply With Quote

Old   October 7, 2011, 05:01
Default
  #9
Senior Member
 
stephane sanchi
Join Date: Mar 2009
Posts: 300
Rep Power: 9
openfoam_user is on a distinguished road
Hi Bruno,

I succeed in generating the grid. Only by changing the location of the background mesh. With LUCK ! Not the best way to solve the problem but for this time it is OK.

Thanks.

Stephane.
openfoam_user is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
UDF compiling problem Wouter Fluent UDF and Scheme Programming 6 June 6, 2012 04:43
SHM add layers problem doubtsincfd OpenFOAM 0 June 6, 2011 12:01
natural convection problem for a CHT problem Se-Hee CFX 2 June 10, 2007 06:29
Adiabatic and Rotating wall (Convection problem) ParodDav CFX 5 April 29, 2007 19:13
Is this problem well posed? Thomas P. Abraham Main CFD Forum 5 September 8, 1999 14:52


All times are GMT -4. The time now is 06:11.