CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Native Meshers: snappyHexMesh and Others (http://www.cfd-online.com/Forums/openfoam-meshing-snappyhexmesh/)
-   -   snap to edge of flat surface embedded by flat surface (http://www.cfd-online.com/Forums/openfoam-meshing-snappyhexmesh/95783-snap-edge-flat-surface-embedded-flat-surface.html)

PeterX30 January 2, 2012 20:21

snap to edge of flat surface embedded by flat surface
 
3 Attachment(s)
I'm new to OpenFoam and recently started to try out sHM and I'm impressed by the capabilities of this tool.
However I got stuck with the following issues.

I generated three stl-files with Salome, containing surfaces which together form up
a closed volume. Furthermore I created feature edge files "*.eMesh" with the command: surfaceFeatureExtract -includedAngle 150 */constant/triSurface/*.stl *
2 of this surface regions are located in one plane. One surface region defines an inlet
and the other a wall

The stl-files files as well as the eMesh files are succesfully read.

Mesh refinement works as expected from definition in the sHMdict file, but snapping only works to the external geometry edges but not at the border edge between the two surfaces in one plane.

Furthermore I thought the eMesh file is the key to avoid the edge jagging as described in several other threads, but this is not the case here.
Finally it seems the layer generation is not working.

I guess I made some stupid beginners mistakes ...

Any idea? Thank's for your help and comments!

David* March 8, 2012 08:24

I've got the same problem. AFAIK it should work without the eMesh-file, but with it you should get better edges. Guess its a very simple mistake, maybe we have to change some angle in the settings? Does somebody know the solution?

Thanks,
David

lovecraft22 March 15, 2012 12:24

You have this in you snappyHexMesh file:

Code:

//- Highly experimental and wip: number of feature edge snapping
    //  iterations. Leave out altogether to disable.
    //  Of limited use in this case since faceZone faces not handled.
    //  nFeatureSnapIter 5;

I'd try something like this:


Code:

    nFeatureSnapIter 10;
so uncomment it out and set it to 10. That's a key parameter for the feature edges so it shoud not be commented out.

David* March 30, 2012 10:25

In my case, nFeatureSnapiter was activated, but it had no effect on the border between the opening and the rest of the body. As I said in #2, normally the "snapping" should work even without the additional edge snapping. I guess, snappyHexMesh simply doesn't work on internal borders.


All times are GMT -4. The time now is 21:49.