CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Native Meshers: snappyHexMesh and Others

Difference in number of cells between Paraview and Log files

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   January 9, 2012, 07:21
Default Difference in number of cells between Paraview and Log files
  #1
New Member
 
Unnikrishnan Mohankumar
Join Date: Apr 2011
Posts: 29
Rep Power: 6
unnikrsn is on a distinguished road
Dear Foamers,

I have small problem with the number of cells in the log file and the Object Inspector in Paraview

In Log.File for SnappyHexMesh
Layer mesh : cells : 2,484,394

Object Inspector - Paraview
Number of Cells : 7,463,450

I assume that the Log file for SnappyHexMesh is correct..
but why is there a difference in cells in Paraview

Thanks
Unnikrishnan
Attached Images
File Type: jpeg LayerMeshCells_Log_File.jpeg (19.9 KB, 10 views)
File Type: jpeg Number-Cells_Object_Inspector.jpeg (28.8 KB, 13 views)
unnikrsn is offline   Reply With Quote

Old   January 10, 2012, 05:11
Default
  #2
Member
 
norman1981's Avatar
 
Norman Del Puppo
Join Date: Mar 2009
Location: Hinwil, CH
Posts: 57
Rep Power: 8
norman1981 is on a distinguished road
Hi Unnikrishnan,

check if you have enabled the "Decompose polyhedra" checkbox in the Object Inspector panel (see the Properties tab).

Regards

Norman
norman1981 is offline   Reply With Quote

Old   January 10, 2012, 07:45
Default Difference in number of cells between Paraview and Log files
  #3
New Member
 
Unnikrishnan Mohankumar
Join Date: Apr 2011
Posts: 29
Rep Power: 6
unnikrsn is on a distinguished road
Thanks Norman,

But i am using Paraview 3.6.1. and my paraview doesn't show an option to enable "Decompose polyhedra" checkbox in the Object Inspector panel (Properties tab).

what version are you using.
Does it have something to do with DecomposePolyhedra
OpenFOAMReader for Paraview.

Thanks
Unnikrishnan
unnikrsn is offline   Reply With Quote

Old   January 10, 2012, 07:53
Default
  #4
Member
 
norman1981's Avatar
 
Norman Del Puppo
Join Date: Mar 2009
Location: Hinwil, CH
Posts: 57
Rep Power: 8
norman1981 is on a distinguished road
Yeah you're right, I might be wrong but this checkbox was included starting from Paraview 3.10. I am using Paraview 3.12.0-RC2. Download an up to date paraview version, then create an empty file (.foam extension) in your case directory (in example: touch case.foam). Run paraview and load that file, it should work fine :-)

Regards

Norman
norman1981 is offline   Reply With Quote

Old   January 10, 2012, 08:38
Default
  #5
New Member
 
Unnikrishnan Mohankumar
Join Date: Apr 2011
Posts: 29
Rep Power: 6
unnikrsn is on a distinguished road
Thanks Norman,

Thanks for the reply.

I am still using paraview 3.6.1...
I will be asking my university staff to update the Paraview to 3.12.

I was not able to update it on my own as regular user ( not Root User ).
I tried it with Cmake from Paraview build and install.. But it dint work...
http://paraview.org/Wiki/ParaView:Build_And_Install#Build_Your_Own_CMake
If you have some link for Regular user.. do share it...

Thanks & Regards
Unnikrishnan
Attached Images
File Type: jpg Object_Inspector.jpg (26.0 KB, 12 views)
unnikrsn is offline   Reply With Quote

Old   January 10, 2012, 08:46
Default
  #6
Member
 
norman1981's Avatar
 
Norman Del Puppo
Join Date: Mar 2009
Location: Hinwil, CH
Posts: 57
Rep Power: 8
norman1981 is on a distinguished road
Well, why don't you try a pre-compiled version? You can download the one you need here: http://www.paraview.org/paraview/res.../software.html .
Then unpack the package in your home. Run the package paraview executable. In this way you won't need your system admin anymore :-)

Norman
norman1981 is offline   Reply With Quote

Old   January 10, 2012, 10:52
Default
  #7
New Member
 
Unnikrishnan Mohankumar
Join Date: Apr 2011
Posts: 29
Rep Power: 6
unnikrsn is on a distinguished road
Hi Norman,

I have installed paraview 3.12 with the help of my Lab IT-Incharge...

With the Paraview3.12 the problem seems to be solved.
Now it display the correct results.

Thanks for the help...

Thanks & Regards
Unnikrishnan.
unnikrsn is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 14:50.