CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Mesh Utilities

PatchTool name server problem

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 9, 2005, 03:26
Default patchTool won't start properly
  #1
Senior Member
 
Håkan Nilsson
Join Date: Mar 2009
Location: Gothenburg, Sweden
Posts: 193
Rep Power: 8
hani is on a distinguished road
patchTool won't start properly. Can anyone please help me interpret the following error message, which I get immediatlely when starting patchTool? I use OpenFOAM 1.2.

Caught FoamXError exception in patchToolServer::main(int argc, char **argv) :
FoamXError "Caught CORBA::COMM_FAILURE exception in connect : Unable to contact name server."
In function "FoamX::NameServer::connect(CORBA:: ORB_ptr pOrb)"
in file "NameServer.C" at line 190

The full output when I try to run patchTool is attached below:

term44:run/pitzDaily> patchTool .. pitzDaily
runPatchToolServer : pid:
Using jar /users/tfd/hani/OpenFOAM/OpenFOAM-1.2/applications/utilities/mesh/manipulation/p atchTool/lib/j3d-org.jar
Using jar /users/tfd/hani/OpenFOAM/OpenFOAM-1.2/applications/utilities/mesh/manipulation/p atchTool/lib/PatchTool.jar
+ /users/tfd/hani/OpenFOAM/linux/j2sdk1.4.2_05/bin/java -cp .:/users/tfd/hani/OpenFOAM/OpenFOAM-1.2/applications/utilities/mesh/manipulation /patchTool/lib/j3d-org.jar:/users/tfd/hani/OpenFOAM/OpenFOAM-1.2/applications/ut ilities/mesh/manipulation/patchTool/lib/PatchTool.jar -DFoamX.SystemPath=/users/tfd/hani/OpenFOAM/OpenFOAM-1.2 -DFoamX.SystemConfigPath=/users/tfd/hani/OpenFOAM/OpenFOAM-1.2/.OpenFOAM-1.2/app s/FoamX -DFoamX.UserConfigPath=/users/tfd/hani/OpenFOAM/OpenFOAM-1.2/.OpenFOAM-1.2/apps/ FoamX -DFoamX.PatchToolPath=/users/tfd/hani/OpenFOAM/OpenFOAM-1.2/applications/utiliti es/mesh/manipulation/patchTool PatchTool/PatchTool -ORBDefaultInitRef corbaloc:iiop:1.0:term44.tfd.chalmers.se:1235
Using server reference /users/tfd/hani/OpenFOAM/OpenFOAM-1.2/.OpenFOAM-1.2/apps/FoamX/ns2.ref
Starting Foam PatchToolServer with inet:term44.tfd.chalmers.se:1235 ...
/*---------------------------------------------------------------------------*\
| ========= | |
| \ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \ / O peration | Version: 1.2 |
| \ / A nd | Web: http://www.openfoam.org |
| \/ M anipulation | |
\*---------------------------------------------------------------------------*/

Exec : PatchToolServer .. pitzDaily
Date : Nov 09 2005
Time : 08:14:44
Host : term44.tfd.chalmers.se
PID : 18580
Root : ..
Case : pitzDaily
Nprocs : 1
Caught FoamXError exception in patchToolServer::main(int argc, char **argv) :
FoamXError "Caught CORBA::COMM_FAILURE exception in connect : Unable to contact name server."
In function "FoamX::NameServer::connect(CORBA:: ORB_ptr pOrb)"
in file "NameServer.C" at line 190
Finishing patchToolServer::main(int argc, char **argv)
runPatchToolServer : cleanup
+ cleanup
+ trap 0 2 3 15
+ '[' 18561 ']'
+ kill 18561
/users/tfd/hani/OpenFOAM/OpenFOAM-1.2/bin/patchTool: line 1: kill: (18561) - No such process

I have used patchTool before, but I don't remember which version I used and if it only was on my laptop which I don't have with me today.

Håkan.
hani is offline   Reply With Quote

Old   November 9, 2005, 05:48
Default Usually something is still han
  #2
Super Moderator
 
Mattijs Janssens
Join Date: Mar 2009
Posts: 1,416
Rep Power: 16
mattijs is on a distinguished road
Usually something is still hanging or there is no network installed.

Start up the server processes separately by running runPatchToolServer.

Check whether the nsd and the patchToolServer are running. Check that the ns2.ref gets rewritten.
mattijs is offline   Reply With Quote

Old   November 9, 2005, 06:11
Default Thanks for your reply. I tr
  #3
Senior Member
 
Håkan Nilsson
Join Date: Mar 2009
Location: Gothenburg, Sweden
Posts: 193
Rep Power: 8
hani is on a distinguished road
Thanks for your reply.

I tried running runPatchToolServer, but I got the same message. There are no processes with 'nsd' or 'patchToolServer' in their names. runPatchToolServer did a runPatchToolServer : cleanup. If you refer to OpenFOAM/OpenFOAM-1.2/.OpenFOAM-1.2/apps/FoamX/ns2.ref it was last written to in September.

It looks to me as FoamX uses a similar way of starting and that works fine.

I need to use patchTool to rearrange my patches for cyclic computations. Is there any other way to do this if we can't get patchTool working?

Håkan.
hani is offline   Reply With Quote

Old   November 9, 2005, 06:29
Default Aha! I tried renaming the f
  #4
Senior Member
 
Håkan Nilsson
Join Date: Mar 2009
Location: Gothenburg, Sweden
Posts: 193
Rep Power: 8
hani is on a distinguished road
Aha!

I tried renaming the file OpenFOAM/OpenFOAM-1.2/.OpenFOAM-1.2/apps/FoamX/ns2.ref to something else and then it was possible to start patchTool.

Did I do something wrong, or should OpenFOAM have removed the file automatically? It would be good to know for the future.

Håkan.
hani is offline   Reply With Quote

Old   November 26, 2005, 12:47
Default Something similar happened to
  #5
Senior Member
 
dmoroian's Avatar
 
Dragos
Join Date: Mar 2009
Posts: 647
Rep Power: 11
dmoroian is on a distinguished road
Something similar happened to me too. The solution was to uncompress again the installation binaries.

Dragos
dmoroian is offline   Reply With Quote

Old   July 4, 2006, 06:51
Default I'm having trouble with the pa
  #6
Member
 
David Segersson
Join Date: Mar 2009
Posts: 39
Rep Power: 8
segersson is on a distinguished road
I'm having trouble with the patchTool name-server. After using the tool several times with success, it suddenly stopped working. When running patchTool I recieve the message:

Name service reference file not found in '/local_disk/dsegerss/OpenFOAM/OpenFOAM-1.3-prod/.OpenFOAM-1.3/apps/FoamX/ns2.re f'.
Cannot find rootContext in name service.
PatchToolServer object could not be contacted.

When I instead run runPathToolServer I get the message:
[dsegerss@lxserv58 slbProject]$ runPatchToolServer . extrTest &
[dsegerss@lxserv58 slbProject]$ Starting NameServer (nsd) with inet:lxserv58:1235 ...
uncaught MICO exception: IDL:omg.org/CORBA/INITIALIZE:1.0 (0, not-completed)
/local_disk/dsegerss/OpenFOAM/OpenFOAM-1.3-prod/bin/runPatchToolServer: line 142: 25937 Aborted (core dumped) nsd
-ORBIIOPAddr $myIOP --ior $FOAMX_CONFIG/ns2.ref </dev/null

I'm dependent on a working patchTool, so I would be glad if anyone could help me figure out what´s suddenly gone wrong with my setup.

Regards
David
segersson is offline   Reply With Quote

Old   July 4, 2006, 12:37
Default Maybe something in the network
  #7
Super Moderator
 
Mattijs Janssens
Join Date: Mar 2009
Posts: 1,416
Rep Power: 16
mattijs is on a distinguished road
Maybe something in the network setup changed?

Check for lxserv58 in /etc/hosts.
mattijs is offline   Reply With Quote

Old   July 5, 2006, 01:08
Default Hi again, lxserv58 is not in
  #8
Member
 
David Segersson
Join Date: Mar 2009
Posts: 39
Rep Power: 8
segersson is on a distinguished road
Hi again,
lxserv58 is not in the /etc/hosts file. I do not think that is the cause though, since I do not have write permission to this file I can not have changed it. Also FoamX, which seems to use a similar name server, is working without any problem.
Any other ideas?
I've tried to recompile patchTool and also unpacked everything from scratch...

Regards
David
segersson is offline   Reply With Quote

Old   July 5, 2006, 02:08
Default Hi again, lxserv58 is not in
  #9
Member
 
David Segersson
Join Date: Mar 2009
Posts: 39
Rep Power: 8
segersson is on a distinguished road
Hi again,
lxserv58 is not in the /etc/hosts file. I do not think that is the cause though, since I do not have write permission to this file I can not have changed it. Also FoamX, which seems to use a similar name server, is working without any problem.
Any other ideas?
I've tried to recompile patchTool and also unpacked everything from scratch...

Regards
David
segersson is offline   Reply With Quote

Old   October 12, 2006, 01:55
Default I have now solved the problem.
  #10
Member
 
David Segersson
Join Date: Mar 2009
Posts: 39
Rep Power: 8
segersson is on a distinguished road
I have now solved the problem. It was all due to my lack of deeper Linux knowledge...

Since there might be more ´Linux novices with this problem, here is the solution:

What had happened was that I had managed to leave an old PatchTool process running in the background. This old process was then blocking the port needed for a new instance of PatchTool to start. This was pointed out by a message from PatchTool saying: ...ORBDefaultInitRef corbaloc:iiop:1.0:lxserv58:1235

What I did was to check for the pid of the process blocking by doing:

netstat -t -l | grep 1235
(Lists what is listened to)

lsof | grep 1235
(Lists all files in question)

I could then conclude that I had a old process listening to that port, at the same time as a new one was trying to occupy it. To solve the problem I killed the blocking processes!

Regards
David
segersson is offline   Reply With Quote

Old   November 7, 2006, 09:59
Default Hej, I have a same problem
  #11
mss
Guest
 
Posts: n/a
Hej,

I have a same problem:
----------------------------------------------
Starting NameServer with inet:alex:1234 ...
uncaught MICO exception: IDL:omg.org/CORBA/INITIALIZE:1.0 (0, not-completed)
/home/Administrator/OpenFOAM/OpenFOAM-1.3/bin/runFoamXHB: line 127: 2767 Aborted nsd -ORBIIOPAddr $myIOP --ior $FOAMX_CONFIG/ns.ref </dev/null
---------------------------------------------------
Could you give datails how to solve this?
thanks,
Rita
  Reply With Quote

Old   August 3, 2007, 03:47
Default Hi, I have problems launchi
  #12
Member
 
Lasse Boehling
Join Date: Mar 2009
Posts: 35
Rep Power: 8
lasb is on a distinguished road
Hi,

I have problems launching patchTool.

Mattijs wrote november 9, 2005: Start up the server processes separately by running runPatchToolServer.

That is exactly my problem. When I run patchToolServer I get this errormessage:

Using server reference /home/lasb/OpenFOAM/OpenFOAM-1.4/.OpenFOAM-1.4/apps/FoamX/ns2.ref
Starting Foam PatchToolServer with inet:pc-05559-wxp.risoe.dk:1235 ...
/*---------------------------------------------------------------------------*\
| ========= | |
| \ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \ / O peration | Version: 1.4 |
| \ / A nd | Web: http://www.openfoam.org |
| \/ M anipulation | |
\*---------------------------------------------------------------------------*/

Exec : PatchToolServer OpenFOAM/lasb-1.4/run/tutorials/simpleFoam/ pitzDaily
Date : Aug 03 2007
Time : 09:38:04
Host : pc-05559-wxp.risoe.dk
PID : 2647
Root : OpenFOAM/lasb-1.4/run/tutorials/simpleFoam/
Case : pitzDaily
Nprocs : 1
Caught FoamXError exception in patchToolServer::main(int argc, char **argv) :
FoamXError "Caught CORBA::COMM_FAILURE exception in connect : Unable to contact name server."
In function "FoamX::NameServer::connect(CORBA:RB_ptr pOrb)"
in file "NameServer.C" at line 190
Finishing patchToolServer::main(int argc, char **argv)
/home/lasb/OpenFOAM/OpenFOAM-1.4/bin/runPatchToolServer: line 145: 2647 Segmentation fault PatchToolServer -ORBNamingAddr $myIOP $caseRoot $caseName
runPatchToolServer : cleanup

So it is unable to cantact nameserver. I already tried what David Segerssons did without luck.

Does anyone know what to do about it?

Regards,
Lasse
lasb is offline   Reply With Quote

Old   June 3, 2008, 13:46
Default Hi, When I run patchTool, t
  #13
Member
 
mohd mojab
Join Date: Mar 2009
Posts: 31
Rep Power: 8
mou_mi is on a distinguished road
Hi,

When I run patchTool, the graphic window appear but after I click on connect button, this error come in my terminal :

Reading name service reference from '/usr/local/OpenFOAM/OpenFOAM-1.4.1/.OpenFOAM-1.4.1/apps/FoamX/ns2.ref'.
Name service reference file not found in '/usr/local/OpenFOAM/OpenFOAM-1.4.1/.OpenFOAM-1.4.1/apps/FoamX/ns2.ref'.
Cannot find rootContext in name service.
PatchToolServer object could not be contacted.

After I check the directory, I do not have ns2.ref file. Could anyone upload this file here?

Thank you
Mou
mou_mi is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenFOAM141 FoamX and paraView problem on cluster server seigi OpenFOAM Installation 1 January 28, 2008 16:44
Error using patchTool jackdaniels83 OpenFOAM Mesh Utilities 6 July 3, 2007 04:58
Launching patchTool tibbstine OpenFOAM Mesh Utilities 6 May 23, 2007 05:38
Can't get server:No server lines in license file xhliu1 CD-adapco 2 September 27, 2006 01:39
Problem in License Server kumar FLUENT 4 November 24, 2002 01:49


All times are GMT -4. The time now is 09:49.