CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Mesh Utilities (http://www.cfd-online.com/Forums/openfoam-meshing-utilities/)
-   -   Launching patchTool (http://www.cfd-online.com/Forums/openfoam-meshing-utilities/61570-launching-patchtool.html)

tibbstine May 22, 2007 07:09

Hi, I am having trouble lau
 
Hi,

I am having trouble launching patchTool. I am a new user of OpenFOAM, and am not particularly competant with linux so it is likley that the problem is quite simple.

On trying to launch patchTool I get the following infomration in the shell window:

james-1.4/run> patchTool . device-steady/
runPatchToolServer : pid:8263
Using running runPatchToolServer (pid 8263) ...
Using jar /home/james/OpenFOAM/OpenFOAM-1.4/applications/utilities/mesh/manipulation/patch Tool/lib/j3d-org.jar
Using jar /home/james/OpenFOAM/OpenFOAM-1.4/applications/utilities/mesh/manipulation/patch Tool/lib/PatchTool.jar
+ /usr/bin/java -cp .:/home/james/OpenFOAM/OpenFOAM-1.4/applications/utilities/mesh/manipulation/pat chTool/lib/j3d-org.jar:/home/james/OpenFOAM/OpenFOAM-1.4/applications/utilities/ mesh/manipulation/patchTool/lib/PatchTool.jar -DFoamX.SystemPath=/home/james/OpenFOAM/OpenFOAM-1.4 -DFoamX.SystemConfigPath=/home/james/OpenFOAM/OpenFOAM-1.4/.OpenFOAM-1.4/apps/Fo amX -DFoamX.UserConfigPath=/home/james/OpenFOAM/OpenFOAM-1.4/.OpenFOAM-1.4/apps/Foam X -DFoamX.PatchToolPath=/home/james/OpenFOAM/OpenFOAM-1.4/applications/utilities/m esh/manipulation/patchTool PatchTool/PatchTool -ORBDefaultInitRef corbaloc:iiop:1.0:linux:1235
Exception in thread "main" java.lang.NoClassDefFoundError: javax/media/j3d/Node
+ cleanup
+ trap 0 2 3 15
+ '[' '' ']'
james-1.4/run>


Any ideas on what I have done wrong?

Thanks

James

dmoroian May 22, 2007 07:36

Probably this is because you h
 
Probably this is because you have an extra "/" in the case name. You should type:
patchTool ./ device-steady

tibbstine May 22, 2007 08:29

Hi Dragos, Same problem. I
 
Hi Dragos,

Same problem. I have tried quite a few different variations on the cmd line, all give the same error which I think comes down to this line:

Exception in thread "main" java.lang.NoClassDefFoundError: javax/media/j3d/Node

Do you know what that means?

dmoroian May 22, 2007 11:09

Hm, no idea! But is seems ther
 
Hm, no idea! But is seems there is something wrong with the java installation. Is FoamX running correctly?

Dragos

tibbstine May 22, 2007 11:25

Yeah it sounds possible, howev
 
Yeah it sounds possible, however both FoamX and paraFoam work perfectly.

Pehaps there is another way to achieve what I am trying to do. I have a single patch (a pressure inlet) which is in reality 3 separte inlets, each oriented in a different direction and not touching.

I would like to change this to a velocity inlet, however since the definition of the inlet velocity is cartesian and not magnitude normal to the boundary, I need to split this single patch into three separate patches.

Without patchTool is there another way to do this?

7islands May 22, 2007 20:08

Hi, Just a guess but maybe it
 
Hi,
Just a guess but maybe it's because the Java3D library (https://java3d.dev.java.net/binary-builds.html) is missing from your Java installation. Try installing the library following the installation instructions in the README on the page.

Takuya

tibbstine May 23, 2007 05:38

I think I have now fixed my ja
 
I think I have now fixed my java install. The pathchtool GUI launches, now I just have to work out how to use it.

Thanks for your help.


All times are GMT -4. The time now is 15:36.