CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Mesh Utilities

Launching patchTool

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   May 22, 2007, 07:09
Default Hi, I am having trouble lau
  #1
New Member
 
James Tibbatts
Join Date: Mar 2009
Posts: 4
Rep Power: 8
tibbstine is on a distinguished road
Hi,

I am having trouble launching patchTool. I am a new user of OpenFOAM, and am not particularly competant with linux so it is likley that the problem is quite simple.

On trying to launch patchTool I get the following infomration in the shell window:

james-1.4/run> patchTool . device-steady/
runPatchToolServer : pid:8263
Using running runPatchToolServer (pid 8263) ...
Using jar /home/james/OpenFOAM/OpenFOAM-1.4/applications/utilities/mesh/manipulation/patch Tool/lib/j3d-org.jar
Using jar /home/james/OpenFOAM/OpenFOAM-1.4/applications/utilities/mesh/manipulation/patch Tool/lib/PatchTool.jar
+ /usr/bin/java -cp .:/home/james/OpenFOAM/OpenFOAM-1.4/applications/utilities/mesh/manipulation/pat chTool/lib/j3d-org.jar:/home/james/OpenFOAM/OpenFOAM-1.4/applications/utilities/ mesh/manipulation/patchTool/lib/PatchTool.jar -DFoamX.SystemPath=/home/james/OpenFOAM/OpenFOAM-1.4 -DFoamX.SystemConfigPath=/home/james/OpenFOAM/OpenFOAM-1.4/.OpenFOAM-1.4/apps/Fo amX -DFoamX.UserConfigPath=/home/james/OpenFOAM/OpenFOAM-1.4/.OpenFOAM-1.4/apps/Foam X -DFoamX.PatchToolPath=/home/james/OpenFOAM/OpenFOAM-1.4/applications/utilities/m esh/manipulation/patchTool PatchTool/PatchTool -ORBDefaultInitRef corbaloc:iiop:1.0:linux:1235
Exception in thread "main" java.lang.NoClassDefFoundError: javax/media/j3d/Node
+ cleanup
+ trap 0 2 3 15
+ '[' '' ']'
james-1.4/run>


Any ideas on what I have done wrong?

Thanks

James
tibbstine is offline   Reply With Quote

Old   May 22, 2007, 07:36
Default Probably this is because you h
  #2
Senior Member
 
dmoroian's Avatar
 
Dragos
Join Date: Mar 2009
Posts: 647
Rep Power: 11
dmoroian is on a distinguished road
Probably this is because you have an extra "/" in the case name. You should type:
patchTool ./ device-steady
dmoroian is offline   Reply With Quote

Old   May 22, 2007, 08:29
Default Hi Dragos, Same problem. I
  #3
New Member
 
James Tibbatts
Join Date: Mar 2009
Posts: 4
Rep Power: 8
tibbstine is on a distinguished road
Hi Dragos,

Same problem. I have tried quite a few different variations on the cmd line, all give the same error which I think comes down to this line:

Exception in thread "main" java.lang.NoClassDefFoundError: javax/media/j3d/Node

Do you know what that means?
tibbstine is offline   Reply With Quote

Old   May 22, 2007, 11:09
Default Hm, no idea! But is seems ther
  #4
Senior Member
 
dmoroian's Avatar
 
Dragos
Join Date: Mar 2009
Posts: 647
Rep Power: 11
dmoroian is on a distinguished road
Hm, no idea! But is seems there is something wrong with the java installation. Is FoamX running correctly?

Dragos
dmoroian is offline   Reply With Quote

Old   May 22, 2007, 11:25
Default Yeah it sounds possible, howev
  #5
New Member
 
James Tibbatts
Join Date: Mar 2009
Posts: 4
Rep Power: 8
tibbstine is on a distinguished road
Yeah it sounds possible, however both FoamX and paraFoam work perfectly.

Pehaps there is another way to achieve what I am trying to do. I have a single patch (a pressure inlet) which is in reality 3 separte inlets, each oriented in a different direction and not touching.

I would like to change this to a velocity inlet, however since the definition of the inlet velocity is cartesian and not magnitude normal to the boundary, I need to split this single patch into three separate patches.

Without patchTool is there another way to do this?
tibbstine is offline   Reply With Quote

Old   May 22, 2007, 20:08
Default Hi, Just a guess but maybe it
  #6
Super Moderator
 
Takuya OSHIMA
Join Date: Mar 2009
Location: Niigata City, Japan
Posts: 518
Blog Entries: 1
Rep Power: 11
7islands is on a distinguished road
Hi,
Just a guess but maybe it's because the Java3D library (https://java3d.dev.java.net/binary-builds.html) is missing from your Java installation. Try installing the library following the installation instructions in the README on the page.

Takuya
7islands is offline   Reply With Quote

Old   May 23, 2007, 05:38
Default I think I have now fixed my ja
  #7
New Member
 
James Tibbatts
Join Date: Mar 2009
Posts: 4
Rep Power: 8
tibbstine is on a distinguished road
I think I have now fixed my java install. The pathchtool GUI launches, now I just have to work out how to use it.

Thanks for your help.
tibbstine is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Launching FSI through command prompt? Omer CFX 0 August 20, 2008 05:40
PatchTool for OpenFOAM 15 mou_mi OpenFOAM Running, Solving & CFD 0 July 28, 2008 15:53
Error using patchTool jackdaniels83 OpenFOAM Mesh Utilities 6 July 3, 2007 04:58
not launching Fluent without licenses in PBS? Marius FLUENT 0 July 25, 2006 09:13
Launching of Torpedo using Dynamic Mesh sam FLUENT 1 December 14, 2004 14:57


All times are GMT -4. The time now is 05:48.