CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Mesh Utilities

snappyhexmesh: addLayersControls and paraview

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   March 25, 2009, 10:48
Default snappyhexmesh: addLayersControls and paraview
  #1
New Member
 
Antonio Attili
Join Date: Mar 2009
Location: Rome, Italy
Posts: 21
Rep Power: 8
wizard1301 is on a distinguished road
Hi
I'm trying to add layers on a surface with snappyhexmesh;
I haven't well understood the meaning of all the parameters of the addLayersControls dict and most important I'm not able to see the layers with paraview.
Can someone help me?

Thanks
Antonio
wizard1301 is offline   Reply With Quote

Old   March 25, 2009, 11:16
Default
  #2
New Member
 
Pal Schmitt
Join Date: Mar 2009
Posts: 28
Rep Power: 8
waterboy is on a distinguished road
Hi,
Whats the problem?
1.)If You know what the height of the first layer should be You can easily estimate what refinement level brings You close. 1 Refinement halfes the basisc edge legth. If You then decide how many layers you want and the increase in thickness named expansionRatio You can calculate how thick the latest layer is compared to the outside mesh. I usually calculate these values starting with some y+ estimations and play around with number of layers and expansionFactor.
2.) I believe it is best to export the addedCells set to VTK to use with paraView. Like this You can see it over Your original geometry stl and see if it covers the area You wanted...Of course this works in paraFoam too, just select sets, but at my computer at work it doesn't run:-(


Have fun,
Pal
waterboy is offline   Reply With Quote

Old   March 25, 2009, 11:26
Default
  #3
New Member
 
Antonio Attili
Join Date: Mar 2009
Location: Rome, Italy
Posts: 21
Rep Power: 8
wizard1301 is on a distinguished road
Thank you for your fast reply Pal;
about paraview, I noticed that if I view the whole mesh and the added cells at the same time in paraview (obviously for both the datasets from the same time directory) they are not consistent; the whole mesh extend till the stl suface and the added cells are ON the whole mesh

Antonio
wizard1301 is offline   Reply With Quote

Old   March 25, 2009, 11:34
Default
  #4
New Member
 
Pal Schmitt
Join Date: Mar 2009
Posts: 28
Rep Power: 8
waterboy is on a distinguished road
Antonio,
i am not sure I understood what You meant to say. The addedlayer is part of the mesh, the original mesh is shrunk to provide the space for the layer. Is that what You mean?
Maybe You can send a picture with the mesh and the addedcells in another color,
(please no red/green combination)
Pal
waterboy is offline   Reply With Quote

Old   March 25, 2009, 11:46
Default
  #5
New Member
 
Antonio Attili
Join Date: Mar 2009
Location: Rome, Italy
Posts: 21
Rep Power: 8
wizard1301 is on a distinguished road
The image of the grid.
It seems that the grid is not shrunk. The mesh in the picture is a visualization of the VTK obatined running foamToVTK on the final directory obtained with snappyhexmesh
Attached Images
File Type: png snap.png (11.7 KB, 87 views)
wizard1301 is offline   Reply With Quote

Old   March 26, 2009, 04:09
Default
  #6
New Member
 
Pal Schmitt
Join Date: Mar 2009
Posts: 28
Rep Power: 8
waterboy is on a distinguished road
Hi Antonio,
Sorry for leaving yesterday without notice, I was occupied by my own simulation....
The image looks strange but it may be because of the vsualization in paraview. Can You make a picture of the addedLayers in 3D and the rest of the mesh as a slice. Or even better the original STL with the cover of addedlayers in a different color?
Hope this helps,
Pal
waterboy is offline   Reply With Quote

Old   March 26, 2009, 05:57
Default
  #7
New Member
 
Antonio Attili
Join Date: Mar 2009
Location: Rome, Italy
Posts: 21
Rep Power: 8
wizard1301 is on a distinguished road
Hi Pal
thank you very much for your help; I found where I was wrong, there were a problem with some settings for the version of paraview used. For a reason that I don't understand the slice is not at the desired position. This morning I tried with a different version of paraview and everythings works well (Yesterday I was working with a version of paraview that I've customized, probably I've introduced some bug...). Sorry for the all time.

thanks

Antonio
wizard1301 is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 21:32.