CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Mesh Utilities

refineMesh from a cellSet issue

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   September 28, 2010, 13:14
Default refineMesh from a cellSet issue
  #1
Member
 
Join Date: May 2009
Posts: 51
Rep Power: 8
gfilip is on a distinguished road
Hello everyone,

I am trying to carry out a local refinement of a cylinderToCell cellSet inside a 3D hex mesh. I have tried both global and patchLocal coordinate system with just the tan1 and tan2 directions. With the global setting, I obtain severely non-orthogonal cells in 4 specific regions (2 on the leading edge, and 2 on the trailing edge of an airfoil). With the local setting, similar region of the mesh is affected, but the refinement does not complete and is terminated with an error: (almost) zero vector as direction for cell 0.
The patch specified in the patchLocalCoeffs is the surface of the foil. I've attached screenshots of both cases to illustrate the problem.

If I refine with all three directions (tan1 tan2 and normal), I don't come across this problem.

Any ideas?
Attached Images
File Type: jpg meshGlobal.jpg (95.3 KB, 54 views)
File Type: jpg meshGlobal_closeup.jpg (98.0 KB, 42 views)
File Type: jpg meshLocal.jpg (96.4 KB, 36 views)
File Type: jpg meshLocal_closeup.jpg (84.5 KB, 30 views)

Last edited by gfilip; September 28, 2010 at 13:40.
gfilip is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
BlockMesh cellSet refineMesh mattijs OpenFOAM Mesh Utilities 34 August 19, 2014 04:54
refineMesh -parallel crashes (in cavity tutorial) andras OpenFOAM Mesh Utilities 0 August 8, 2010 14:52
Bug in mesh tools: cellSet, refineMesh, ...? alexm OpenFOAM Bugs 0 August 10, 2009 12:46
Memory issue - Suse 10 - Opterons Andy R FLUENT 1 June 23, 2008 14:44
Cannot refineMesh with useHexTopology true ver141 naoki OpenFOAM Bugs 5 June 11, 2008 04:07


All times are GMT -4. The time now is 17:12.