CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Meshing & Mesh Conversion

[OpenFoam] Nothing in Paraview!

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   May 23, 2012, 06:25
Default [OpenFoam] Nothing in Paraview!
  #1
New Member
 
Stevie
Join Date: May 2012
Posts: 6
Rep Power: 5
A340 is on a distinguished road
Hey everyone,

i'm just in the middle of building a new case through combining a few case directories (i.e.majority of simpleFoam/airfoil2d and abit of snappyhexmesh/motorBike) and after performing all adjustments (updating file name)and meshing (blockMesh + snappyhexmesh) with no error, nothing seems to be appearing in Paraview. The mesh parts have the basic patches + 1 new model patch and that is all. In the Paraview, only a retangular box has appeared.

Please help me out! I have googled all over for hours and found nothing

Thanks guys
A340 is offline   Reply With Quote

Old   May 23, 2012, 06:58
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Stevie and welcome to the forum!

Have you checked if the mesh even exists?
Code:
checkMesh
Additionally, have you done any of the tutorials to confirm if you have a working installation?

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   May 23, 2012, 07:04
Default
  #3
New Member
 
Stevie
Join Date: May 2012
Posts: 6
Rep Power: 5
A340 is on a distinguished road
yea i've done the icoFoam cavity and snappyhexmesh/motorBike exercises and they both worked. And yes I did do the "checkmesh" between running blockMesh and snappyhexmesh. but nothing seems to be coming up on Paraview
A340 is offline   Reply With Quote

Old   May 23, 2012, 07:17
Default
  #4
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
What about checkMesh after snappy?
wyldckat is offline   Reply With Quote

Old   May 23, 2012, 07:31
Default
  #5
New Member
 
Stevie
Join Date: May 2012
Posts: 6
Rep Power: 5
A340 is on a distinguished road
yea tried that as well. Earlier snappy was giving me an error saying - does not seem to have 8 points of equal or lower level cellPoints...etc. After changing refinement level from (5 6) to (2 5) sort of got rid of that error. And now everything is fine but nothing is coming up on Paraview. what is generally the cause when a certain mesh isn't appearing on Paraview? The blockMesh seems to be there, but not the snappy. Do you think maybe its the properties of the snappy file i have to change?
A340 is offline   Reply With Quote

Old   May 23, 2012, 07:34
Default
  #6
Senior Member
 
Join Date: Mar 2011
Posts: 174
Rep Power: 6
anon_a is on a distinguished road
Just to be sure: Have you moved in the last time step in paraFoam?
Or did you use -overwrite?

EDIT: Also, which representation style is active? When I load a mesh with many cells, the "Outline" is activated by default instead of "Surface".

EDIT2: If none of these is the solution, could you upload a screenshot of your paraview screen containing the rectangle? It must also contain the visualization details on the left, off course.
anon_a is offline   Reply With Quote

Old   May 23, 2012, 07:41
Default
  #7
New Member
 
Stevie
Join Date: May 2012
Posts: 6
Rep Power: 5
A340 is on a distinguished road
yep i clicked the forward time step to the last time step. And yea tried changing the outline, wireframe, surface and everything. Nothing seems to be appearing
A340 is offline   Reply With Quote

Old   May 23, 2012, 07:59
Default
  #8
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
  1. Which OpenFOAM are you suing?
  2. Which ParaView version are you using?
  3. And are they 32 or 64bit?
  4. How many cells/points does your mesh have?
  5. Try running paraFoam like this:
    Code:
    paraFoam -builtin
wyldckat is offline   Reply With Quote

Old   May 23, 2012, 08:05
Default
  #9
New Member
 
Stevie
Join Date: May 2012
Posts: 6
Rep Power: 5
A340 is on a distinguished road
OpenFoam 2.1.0
Paraview 3.12.0
64 bit
Not sure how to check the number of cell/points
A340 is offline   Reply With Quote

Old   May 23, 2012, 08:48
Default
  #10
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Quote:
Originally Posted by A340 View Post
OpenFoam 2.1.0
Paraview 3.12.0
64 bit
Not sure how to check the number of cell/points
checkMesh reports that info
wyldckat is offline   Reply With Quote

Old   May 23, 2012, 08:57
Default
  #11
New Member
 
Stevie
Join Date: May 2012
Posts: 6
Rep Power: 5
A340 is on a distinguished road
I don't know whats gone wrong, the checkmesh is giving me an error. (see attachment). This is after running snappyhexmesh
Attached Images
File Type: jpg checkmesh_error.jpg (96.4 KB, 28 views)
A340 is offline   Reply With Quote

Old   May 23, 2012, 11:20
Default
  #12
Senior Member
 
lore
Join Date: Mar 2010
Location: Italy
Posts: 463
Rep Power: 9
lovecraft22 is on a distinguished road
Send a message via Skype™ to lovecraft22
You should probably post the error, not a screenshot of it… I cannot read anything…
lovecraft22 is offline   Reply With Quote

Old   May 23, 2012, 15:24
Default
  #13
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Quote:
Originally Posted by lovecraft22 View Post
You should probably post the error, not a screenshot of it… I cannot read anything…
Indeed... I could make out some of the issues, but there is insufficient information. I believe that 1.5 million cells are reported by snappyHexMesh at the last step, which should put aside a problem with insufficient memory.

Quote:
Originally Posted by A340 View Post
I don't know whats gone wrong, the checkmesh is giving me an error. (see attachment). This is after running snappyhexmesh
Apparently there is at least one problem. Like lovecraft22 said, please post the whole output by checkMesh:
Code:
checkMesh > log.checkMesh
tar -cjf log.checkMesh.tar.gz log.checkMesh
The last command line is only if the log file is too big... in which case, attach the file "log.checkMesh.tar.gz".

As for the error message, it looks like something is going wrong in the folder paths, since it tried to create the folder "1/sets" without success. Are you by any chance running snappyHexMesh in parallel?

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   June 9, 2012, 07:09
Default
  #14
Member
 
Join Date: Nov 2010
Posts: 50
Rep Power: 6
Doug68 is on a distinguished road
I've managed to do this a few times in a few different ways, I'd check the following:

1. Open the mesh in Paraview then open the stl file to make sure the stl file is the correct scale and in the correct position to fit in your blockmesh range.

2. Have a look at the section in the snappyhexmesh log file similar to below:

Read mesh in = 1.716 s

Overall mesh bounding box : (0 -4 0) (20 4 4)
Relative tolerance : 1e-006
Absolute matching distance : 2.19089e-005

Reading refinement surfaces.
Read refinement surfaces in = 10.677 s

if the time numbers are zero or close to it then the stl file has not been found.
Doug68 is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Paraview nice animation PyGloo ParaView 4 June 7, 2012 12:34
Newbie: Install ParaView 3.81 on OF-1.6-ext/OpenSuse 11.2? lentschi OpenFOAM Installation 1 March 9, 2011 03:32
Paraview not found fusij OpenFOAM Installation 2 January 1, 2011 21:44
Distributed ParaView and PV3FoamReader micalil OpenFOAM Paraview & paraFoam 4 July 1, 2010 05:09
paraFoam reader for OpenFOAM 1.6 smart OpenFOAM Installation 13 November 16, 2009 22:41


All times are GMT -4. The time now is 02:30.