CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Meshing & Mesh Conversion

No layers added on the inclined tube

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   August 30, 2012, 12:53
Default No layers added on the inclined tube
  #1
New Member
 
Vincenzo Santoro
Join Date: Apr 2012
Location: Politecnico di Torino
Posts: 16
Rep Power: 4
vinezio is on a distinguished road
Hi All,
I'm using OpenFOAM 2.0.0 and i would to create a model with SnappyHexMesh. In the following picture is explained my problem. Why it happen that? How can I do to add the layers on the bent tube? I need help!!

Regards,
vinezio
Attached Images
File Type: jpg object.jpg (10.0 KB, 18 views)
File Type: jpg section.jpg (25.0 KB, 32 views)
Attached Files
File Type: txt snappyHexMeshDict.txt (12.1 KB, 4 views)

Last edited by vinezio; August 31, 2012 at 11:35.
vinezio is offline   Reply With Quote

Old   September 27, 2012, 05:01
Default
  #2
Member
 
Simon Arne
Join Date: May 2012
Posts: 38
Rep Power: 4
simpomann is on a distinguished road
Hi,

I experience a similiar problem in a complex pipe network. So far, I could only properly add layers using a refinement box around the geometry and refine it on a high level. Some straight elements get layers without the refinement as well, but I run into problems where the pipe bends, just like you.
Setting the size to absolute (relativeSize false) was also my guess, but didn't solve it.

Did you find a solution?

Greetings,
Simon
simpomann is offline   Reply With Quote

Old   September 27, 2012, 14:02
Default Work it!!
  #3
New Member
 
Vincenzo Santoro
Join Date: Apr 2012
Location: Politecnico di Torino
Posts: 16
Rep Power: 4
vinezio is on a distinguished road
Hi Simon,

thanks for your suggestions and just 2 days ago i've found alternative solution. I've drastically reduced nSmoothPatch and nRelaxIter iteration and i've set in the mesh quality minVol at 1e-250. In this way i've reached 100% layers distribution but when I try to run with simpleFoam solver the solution not converge very well! I just open a new post for that -- Problem in sHM.
To help you, I post sHM's file. Let me know how it goes.

vinezio
Attached Files
File Type: txt snappyHexMeshDict.txt (7.5 KB, 4 views)
vinezio is offline   Reply With Quote

Old   September 28, 2012, 11:02
Default
  #4
Member
 
Simon Arne
Join Date: May 2012
Posts: 38
Rep Power: 4
simpomann is on a distinguished road
Hi vinezio,

I tried with your settings, but they don't lead to any improvement. Thanks for providing them! The funny thing is that the same case is meshing perfectly with OF 1.6 (tried today at work in university). So actually now I think about meshing at work and solving at home, what is kind of disappointing as my home version is 2.1.0 and should work better, especially concerning this issue. Or I will try the sHM-Dict from 1.6 under 2.1., but I am afraid it will ask me to include the new quality settings (and disabling all of them yesterday didn't lead me anywhere).

This is driving me crazy. I spend 12 hours trying to mesh it with OF 2.1.0 and no success, while it took me 20 minutes with OF 1.6 to find a suitable absolute layer size and no problems (with a 12mm pipe in a 100mm square blockmesh with bendings in 3 directions, diffusors and everything).

If I ever find out what is behind this I will post it here.
simpomann is offline   Reply With Quote

Old   October 26, 2012, 03:27
Default
  #5
Senior Member
 
Tobi's Avatar
 
Tobias Holzmann
Join Date: Oct 2010
Location: Augsburg (Bavaria, Germany) Leoben (Styria, Austria)
Posts: 845
Rep Power: 17
Tobi will become famous soon enough
Send a message via ICQ to Tobi Send a message via Skype™ to Tobi
Hi,

did you compare your quality settings of both sHMDicts ?
I think in your 1.6 your mesh quality parameters are lower than in OF2.1.x.
If you disable everything you ll get layers all over the geometry!
Tobi is offline   Reply With Quote

Old   October 26, 2012, 05:12
Default
  #6
Member
 
Simon Arne
Join Date: May 2012
Posts: 38
Rep Power: 4
simpomann is on a distinguished road
Hey,

Thanks you mention it, but my 2.1 SHM-Dictionary is actually my 1.6 SHM-Dictionary with the new settings added (and disabled).

I found some "work around" in the mean time by chosing a smaller blockMesh and decided that I can live with the additional cells.

Best regards,

Simon
simpomann is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Adding layers goes wrong with SnappyHexMesh Elise OpenFOAM Native Meshers: snappyHexMesh and Others 1 April 22, 2013 02:32
No layers in a small gap bobburnquist OpenFOAM Native Meshers: snappyHexMesh and Others 2 November 25, 2012 08:54
Layers don't fully surround surface EVBUCF OpenFOAM Native Meshers: snappyHexMesh and Others 14 August 20, 2012 04:31
How to set up a dynamic mesh for a piston moving through a tube of variable diameter? karkar OpenFOAM Meshing & Mesh Conversion 0 July 4, 2012 06:54
How many prism layers should be added in a pump simulation? Jasmine CFX 3 June 17, 2009 16:05


All times are GMT -4. The time now is 12:12.