CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Paraview & paraFoam

Problem switching from terminal to paraView

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By alexeym

Reply
 
LinkBack Thread Tools Display Modes
Old   July 17, 2012, 08:34
Default Problem switching from terminal to paraView
  #1
New Member
 
Maxime Thomas
Join Date: Jul 2012
Posts: 4
Rep Power: 4
Maxime Thomas is on a distinguished road
Hi everybody,

I'm new in this forum, I've registered today because I've been looking for different thread linked to my problem but I didn't find anything yet.

I'm working on Ubuntu 11.04 Natty, OpenFoam 1.7.1 and paraView 3.8.0.
I'm a begginer in CFD and in OpenFoam so I've tried to do the first tutorial called "Cavity" and I immediatly noticed that after doing "blockMesh" and paraFoam, an error message appeared:

"Application asked to unregister timer 0x6d00000d which is not registered in this thread. Fix application."
or other similar messages with the number after timer that changes.

This message appears each time I type paraFoam or I click on apply to display my block in the pipeline browser. Then I can use paraView normally, but the problem is that the terminal is blocked and I can't type icoFoam to run the program with new parameters. I am forced to close paraView, run icoFoam and open paraView again (which is quite annoying).

If somebody has any idea to help me it would be great. Please be tolerant with me I'm a poor French Windows user but I'll do my best to fix this!

Maxime
Maxime Thomas is offline   Reply With Quote

Old   July 17, 2012, 09:38
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 7,873
Blog Entries: 34
Rep Power: 78
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
Greetings Maxime and welcome to the forum!

If you kept reading, you would find this section: 2.1.5.5 Running the code as a background process

In other words, you can launch paraFoam as a background application by running with an ampersand in front:
Code:
paraFoam &
For a bit more information on this: http://hacktux.com/bash/ampersand


As for the warning given in ParaView... I think that one can be fixed if you upgrade or additionally install the latest OpenFOAM version: http://www.openfoam.org/download/ubuntu.php

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   July 18, 2012, 06:16
Default Thanks and other question about Khamsin
  #3
New Member
 
Maxime Thomas
Join Date: Jul 2012
Posts: 4
Rep Power: 4
Maxime Thomas is on a distinguished road
Hello,

Thank you Wyldckat, I approximately figured out my problems. You were right for the background application, now it works well with "paraFoam &", there's still something I don't get: is there a difference once I launched paraview if I type "paraFoam &" or "icoFoam &" because apparently it does the same thing but I'm not sure about the reason why.

Also it took me hours to install the latest version of OpenFoam but I finally completed it, even if I didn't manage to remove the former version 1.7.1 that was already installed. It's not a big deal, I just have the two versions installed.
The error message is still here, but it doesn't seem to prevent me from using ParaView correctly, it just appears sometimes, I close it and that's it.

I'm going to have several simulations to do for a design of a ventilation system with different geometries. Does anybody know if the Sketchup plugin called Khamsin is worth using? Because it seems to be quite complicated to be installed from Ubuntu as G Sketchup doesn't run under Linux...

Thanks again Wyldckat for this quick answer!

Maxime
Maxime Thomas is offline   Reply With Quote

Old   January 17, 2014, 00:51
Default
  #4
New Member
 
Steven
Join Date: Jan 2014
Posts: 14
Rep Power: 3
alientxtmsgs is on a distinguished road
Hi everyone,

Sorry for digging up this old thread, but I am having a similar issue as the original poster.

I've been going through the lid-driven cavity tutorial and noticed ever since the cavityFine portion where you run the icoFoam as a background process everything runs as a foreground process. i.e.,

icoFoam > log &
cat log

For example, before I could run "kate blockMeshDict", keep it open, and run other commands like "paraFoam". While paraFoam is open I could run other commands. Now it seems I have to close everything in order to get the command prompt to pop back up. Does anyone have a clue what has changed, or how to change it back?

Thanks in advance!
alientxtmsgs is offline   Reply With Quote

Old   January 26, 2014, 15:19
Default
  #5
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 7,873
Blog Entries: 34
Rep Power: 78
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
Greetings Steven,

Didn't you read my post #2?

The ampersand "&"! It's the ampersand that gives the ability to launch commands and make them run as background jobs.

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   January 26, 2014, 17:28
Default
  #6
New Member
 
Steven
Join Date: Jan 2014
Posts: 14
Rep Power: 3
alientxtmsgs is on a distinguished road
Hi Bruno,

I did read your post but I was more curious about what I had changed that requires me to now use the ampersand. I'm still not to sure what I did but I've learned to just work with it.

Thank you for your reply,
Steven
alientxtmsgs is offline   Reply With Quote

Old   January 30, 2014, 18:32
Default
  #7
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 7,873
Blog Entries: 34
Rep Power: 78
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
Hi Steven,

I forgot to be clear on one detail, regarding these two commands you mentioned in the other post:
Code:
icoFoam > log &
cat log
The first one does launch icoFoam as a background job, since it's using the ampersand. The second one is quick to finish, because it's only outputting the contents of the file "log" onto the screen. That is why you get command line control soon after you ran the two commands

By the way, if you're curious on learning more about the shell (command line), have a look here: http://linuxcommand.org/learning_the_shell.php

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   January 30, 2014, 22:08
Default
  #8
New Member
 
Steven
Join Date: Jan 2014
Posts: 14
Rep Power: 3
alientxtmsgs is on a distinguished road
Hi Bruno,

Thank you for the clarification, I am slowly learning these things . I am most definitely interested in learning more about the shell (fairly new to the whole Linux thing, but I enjoy it so much now I've completely wiped Windows off my computer), I will take a look, thank you!

Regards,
Steven
alientxtmsgs is offline   Reply With Quote

Old   October 2, 2014, 12:22
Default
  #9
New Member
 
Marta Drabek
Join Date: Oct 2014
Posts: 7
Rep Power: 2
martad is on a distinguished road
Quote:
Originally Posted by wyldckat View Post
In other words, you can launch paraFoam as a background application by running with an ampersand in front:
Code:
paraFoam &
For a bit more information on this: http://hacktux.com/bash/ampersand
I wonder, is there a way to send a process to run in the background when it's already running in the foreground, or do I need to quit ParaView and restart it in the background?

Thanks,
Marta
martad is offline   Reply With Quote

Old   October 3, 2014, 01:34
Default
  #10
Senior Member
 
Alexey Matveichev
Join Date: Aug 2011
Location: Nancy, France
Posts: 877
Rep Power: 16
alexeym will become famous soon enough
Hi,

Quote:
Originally Posted by martad View Post
I wonder, is there a way to send a process to run in the background when it's already running in the foreground, or do I need to quit ParaView and restart it in the background?

Thanks,
Marta
1. Press "Ctrl-Z" (this will suspend paraview)
2. Issue "bg" command (this will send paraview to background)
wyldckat likes this.
alexeym is offline   Reply With Quote

Old   October 4, 2014, 10:59
Default
  #11
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 7,873
Blog Entries: 34
Rep Power: 78
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
Greetings to all!

@Marta:
Quote:
Originally Posted by martad View Post
I wonder, is there a way to send a process to run in the background when it's already running in the foreground, or do I need to quit ParaView and restart it in the background?
To complement Alexey's answer, I have to say that this is explained here: http://linuxcommand.org/lts0080.php#in_the_background - along with several more neat tricks!
And how did I find this? Remember reading the following in post #7?
Quote:
Originally Posted by wyldckat View Post
By the way, if you're curious on learning more about the shell (command line), have a look here: http://linuxcommand.org/learning_the_shell.php
Remember: asking a question might take longer to get an answer than looking for the answer yourself

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
compile problem of paraview 3.8.0 conjucting with Qt4.7.3 abbott.hn OpenFOAM 2 August 23, 2011 05:25
problem with new OF170 paraview instalation anmartin OpenFOAM Installation 3 June 29, 2010 18:29
Yet another Paraview problem gascortado OpenFOAM 5 February 21, 2010 07:39
problem using paraview zobekenobe OpenFOAM 8 December 15, 2009 17:35
Problem with Colors in ParaView sven OpenFOAM Paraview & paraFoam 1 May 31, 2009 08:13


All times are GMT -4. The time now is 02:41.