CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Paraview & paraFoam

paraFoam with paraview 3.8.1

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   January 10, 2013, 22:38
Default paraFoam with paraview 3.8.1
  #1
Member
 
nsreddy
Join Date: Sep 2010
Posts: 33
Rep Power: 6
nsreddysrsit is on a distinguished road
hi,
I am unable to open paraFoam

I am getting the following error :
/opt/paraviewopenfoam381/lib/paraview-3.8/paraview: symbol lookup error: /usr/lib/libQtNetwork.so.4: undefined symbol: _ZN16QIODevicePrivate4peekEPcx
any Help

Regards
nsreddysrsit is offline   Reply With Quote

Old   January 13, 2013, 08:48
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,253
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings nsreddy,

We'll need some more information in order to help you:
  • Which OpenFOAM version do you have installed?
  • How did you install OpenFOAM?
    The error message you've got suggests that you installed from Deb or RPM packages, but it also suggests that you installed said packages in an unsupported system.
  • Which Linux Distribution are you using? Fedora, Ubuntu or openSUSE?
  • Which version of that Linux Distribution?
  • Which architecture of that Linux Distribution? 32bit or 64bit?
  • Do you have more than one OpenFOAM installation installed? If so, how are you keeping them apart?
Best regards,
Bruno
wyldckat is online now   Reply With Quote

Old   January 15, 2013, 00:38
Default
  #3
Member
 
nsreddy
Join Date: Sep 2010
Posts: 33
Rep Power: 6
nsreddysrsit is on a distinguished road
thanks for the reply,
I am using Ubuntu 10.10, paraFoam 3.82,Openfoam 1.71
I installed through Deb pack ,
When I install 3G Modem (Vision Tech) ,the error i am getting,
When I uninstall, ParaFoam working correctly.


Best regards,
N S reddy
nsreddysrsit is offline   Reply With Quote

Old   January 19, 2013, 16:29
Default
  #4
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,253
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Quote:
Originally Posted by nsreddysrsit View Post
thanks for the reply,
I am using Ubuntu 10.10, paraFoam 3.82,Openfoam 1.71
I installed through Deb pack ,
When I install 3G Modem (Vision Tech) ,the error i am getting,
When I uninstall, ParaFoam working correctly.


Best regards,
N S reddy
Hi N S reddy,

That's a somewhat strange error you're getting... looks like the modem you're installing is either modifying or affecting Ubuntu's version of Qt, which leads ParaView to not work properly.

There are at least two possible solutions:
  1. You can try and find how the modem software is affecting the Qt library. Run:
    Code:
    cd /opt/paraviewopenfoam381/lib/paraview-3.8
    ldd ./paraview
    If you can show us the output from this last command, we might be able to diagnose where the problem is and what might be a good solution.
  2. Or you can try and follow these instructions for replacing the ParaView version you've got installed: http://www.cfd-online.com/Forums/blo...-openfoam.html - these instructions will help you install the pre-built version of ParaView available at paraview.org, which already comes with its own Qt libraries.
Best regards,
Bruno
wyldckat is online now   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to get Python Shell into ParaView 3.8.1? blaise OpenFOAM Installation 3 July 24, 2012 04:58
OF 1.7.0 & paraView 3.8.1 (paraFoam) maysmech OpenFOAM 8 November 3, 2010 02:10
parafoam - paraview help function felik9 OpenFOAM Paraview & paraFoam 5 June 3, 2010 15:03
Segmentation fault with paraFoam and paraview 3.6.1 on Fedora 11 32 and 64 bit nanes OpenFOAM Paraview & paraFoam 2 September 11, 2009 09:12
Both paraview and paraFoam crash on Redhat Linux WS v4 64bit sek OpenFOAM Paraview & paraFoam 4 August 17, 2006 16:26


All times are GMT -4. The time now is 09:01.