CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Paraview & paraFoam

Floating Object Tutorial. No fluid shown when I click on "Play"

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree2Likes
  • 1 Post By wyldckat
  • 1 Post By wyldckat

Reply
 
LinkBack Thread Tools Display Modes
Old   September 30, 2013, 13:04
Default Floating Object Tutorial. No fluid shown when I click on "Play"
  #1
New Member
 
Ivy
Join Date: Sep 2013
Location: Singapore
Posts: 16
Rep Power: 3
Ivy Zhou is on a distinguished road
Hello,

I am learning Floating Object Tutorial.
I did
blockMesh
./Allrun
paraFoam &.
And then when I open Paraview and No fluid is shown. When I click on "Play" in paraview, only the rectangular object is moving up and down.

Any friend has any idea what I should do?

Thanks very much for any help

Ivy
Ivy Zhou is offline   Reply With Quote

Old   October 5, 2013, 07:44
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,511
Blog Entries: 34
Rep Power: 86
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Ivy,

Quoting myself from a year ago:
Quote:
Originally Posted by wyldckat View Post
You're not the first person with this issue

I googled:
Code:
"floatingObject" paraview
And got to my own answer from several months ago, seen in this thread: Proplem with OF tutorial vizualization
Best regards,
Bruno
Ivy Zhou likes this.
wyldckat is offline   Reply With Quote

Old   October 6, 2013, 05:47
Default
  #3
New Member
 
Ivy
Join Date: Sep 2013
Location: Singapore
Posts: 16
Rep Power: 3
Ivy Zhou is on a distinguished road
Hi, Bruno

Thanks for always answering my question

Hmm I guess I am really confused with this OpenFoam.. I still can just see the box and the floatingobject moving . Still no liquid show up

Whats weird now is, after several times trying, it started to fail.
When I type paraFoam,
I see the paraview and then the part "floating object meshing" in the properties disappeared. And when I click "Apply", the Paraview automatically exits. What is shown on Terminal is :

--> FOAM FATAL IO ERROR:
size 94848 is not equal to the given value of 96000

file: /home/yinghan/OpenFOAM/yinghan-2.2.1/run/tutorials/multiphase/interDyMFoam/ras/floatingObject/0/alpha1 from line 18 to line 94888.

From function Field<Type>::Field(const word& keyword, const dictionary&, const label)
in file lnInclude/Field.C at line 236.

FOAM exiting

Do you have any idea why this happens?

Thanks very much

Ivy
Ivy Zhou is offline   Reply With Quote

Old   October 6, 2013, 06:26
Default
  #4
New Member
 
Ivy
Join Date: Sep 2013
Location: Singapore
Posts: 16
Rep Power: 3
Ivy Zhou is on a distinguished road
Hi Bruno, Please ignore my previous reply

I delete everything and tried again. Then I can see the floating object.
Just the liquid is still missing

Attached is how it looks like~~
I ticked "IternalMesh" "FloatingObject-Patch" and "Alpha1"

Thanks sooo soo much ja

Ivy
Attached Images
File Type: jpg floating.jpg (66.1 KB, 10 views)
Ivy Zhou is offline   Reply With Quote

Old   October 6, 2013, 10:13
Default
  #5
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,511
Blog Entries: 34
Rep Power: 86
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Ivy,

OK, I guess this has reached the "Frequently Asked Question" stature, so I've added information on this here: http://openfoamwiki.net/index.php/FA...iphase_results

The page with the actual instructions is now here: http://openfoamwiki.net/index.php/Ho...iphase_results

Best regards,
Bruno
Ivy Zhou likes this.
wyldckat is offline   Reply With Quote

Old   October 6, 2013, 11:09
Default
  #6
New Member
 
Ivy
Join Date: Sep 2013
Location: Singapore
Posts: 16
Rep Power: 3
Ivy Zhou is on a distinguished road
Hi Bruno,

Thanks very much )) I started to get what it supposed to look like Thank very much~~ Hmm but why the fluid only shows up when I change from choosing "p" to "p-rgh" ? I googled that P-rgh means dynamic pressure.
Hmm sorry for all the kind of naive question ha ><

Thanks soo soo much~

Best Regards,
Ivy
Ivy Zhou is offline   Reply With Quote

Old   October 9, 2013, 03:02
Default
  #7
New Member
 
Ivy
Join Date: Sep 2013
Location: Singapore
Posts: 16
Rep Power: 3
Ivy Zhou is on a distinguished road
Hi, Bruno

I think I figured out. Now I realized that the questions asked below is quite not related to problem I encountered earlier haha.
Thanks very much again

Ivy

Quote:
Originally Posted by Ivy Zhou View Post
Hi Bruno,

Thanks very much )) I started to get what it supposed to look like Thank very much~~ Hmm but why the fluid only shows up when I change from choosing "p" to "p-rgh" ? I googled that P-rgh means dynamic pressure.
Hmm sorry for all the kind of naive question ha ><

Thanks soo soo much~

Best Regards,
Ivy
Ivy Zhou is offline   Reply With Quote

Reply

Tags
floating objects, tutorial

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to show the transient case? H.P.LIU Phoenics 7 July 13, 2010 04:31
How to apply negtive pressure to outlet bioman66 CFX 5 June 3, 2006 01:40
Terrible Mistake In Fluid Dynamics History Abhi Main CFD Forum 12 July 8, 2002 09:11
Gambit tutorial for Multiple Fluid Zones ? bete FLUENT 1 July 9, 2001 03:32


All times are GMT -4. The time now is 13:20.