CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Paraview & paraFoam (http://www.cfd-online.com/Forums/openfoam-paraview/)
-   -   failed to load vboxvideo (http://www.cfd-online.com/Forums/openfoam-paraview/124263-failed-load-vboxvideo.html)

gux290 October 1, 2013 03:24

failed to load vboxvideo
 
Hi everybody, I've just installed openfoam on the latest version of xubuntu using virtualBox (I have windows 7). I tried to run the "cavity" tutorial case and all seems to work well but when I launch paraFoam I can't visualize the results (except for the mesh) and I receive the following message in the terminal:

Opengl warning:Failed to connect to host. Make sure 3D acceleration is enabled for this VM.
libGL error: failed to load driver: vboxvideo
libGL error: try again with LIBGL_DEBUG=verbose for more details.

:confused:

I really have not experience with linux OSes so speak plainly please!

wyldckat October 6, 2013 11:27

Greetings Augusto and welcome to the forum!

My guess is that you didn't read carefully the section "Installing Guest Additions": http://www.openfoam.com/resources/windows.php#x4-13000

The official VirtualBox manual explains this here: http://www.virtualbox.org/manual/ch04.html

There is another set of instructions here as well: http://www.dedoimedo.com/computers/v...st-addons.html

Best regards,
Bruno

cfdopenfoam March 31, 2015 22:39

Opengl warning:Failed to connect to host.
 
Hi, Bruno.

i am facing the same error with the Guest Additions-4.3.6 installed on virtual box-4.3.6. everything seems to be ok except this OpenGL error. and i can share the ClipBoard between the windows 8.1 and ubuntu 12.04. i think the VboxGuestAdditions have been correctly installed. so is there anything i am missing?

any help will be great appreciated.


Quote:

Originally Posted by wyldckat (Post 455318)
Greetings Augusto and welcome to the forum!

My guess is that you didn't read carefully the section "Installing Guest Additions": http://www.openfoam.com/resources/windows.php#x4-13000

The official VirtualBox manual explains this here: http://www.virtualbox.org/manual/ch04.html

There is another set of instructions here as well: http://www.dedoimedo.com/computers/v...st-addons.html

Best regards,
Bruno


wyldckat April 3, 2015 12:15

Quote:

Originally Posted by cfdopenfoam (Post 539360)
so is there anything i am missing?

Quick question: can you please share the settings you're using in the set-up of your virtual machine? Namely the ones defined in VirtualBox.

cfdopenfoam April 3, 2015 22:19

Opengl warning:Failed to connect to host.
 
greeting to Bruno.

i am really sorry that i am new to linux and i have no idea about the settings i should share. the vboxguestaddtions is installed in /opt/VBoxGuestAdditions-4.3.6/ and i find two applications in the /bin sub-directory, VBoxClient and VBoxControl. i 'sudo' the two but i still can not find the setting details.

may i know how i could share the settings and address the problem?

thanks a lot.


Quote:

Originally Posted by wyldckat (Post 539860)
Quick question: can you please share the settings you're using in the set-up of your virtual machine? Namely the ones defined in VirtualBox.


wyldckat April 4, 2015 07:17

2 Attachment(s)
Quote:

Originally Posted by cfdopenfoam (Post 539886)
i am new to linux and i have no idea about the settings i should share.

I assume you have more experience in using Microsoft Windows, correct? Therefore, you should be able to understand how to get around the VirtualBox window interface, which is what I asking about :(. There's a manual for VirtualBox here: https://www.virtualbox.org/manual/ch01.html

As for the settings I'm referring to, here's an example:
  1. In the first attached image, is the presentation of the list of available virtual machines.
  2. If you select the virtual machine you need to configure and click on the big button that says "Settings", you can then configure the settings I was asking about.
  3. On the second image you can see the settings I want to see.

cfdopenfoam April 4, 2015 07:51

Opengl warning:Failed to connect to host.
 
Quote:

Originally Posted by wyldckat (Post 539921)
On the second image you can see the settings I want to see.

Hi, Bruno. thank you very much for the helpful steps you offered. i guess i know what you mean. at first, i do not enable 3D acceleration. then i got the OpenGL error as i have posted. however, after i enable 3D acceletation, i got another error which seems to be more complicated. as follows:

Code:

created temporary 'cavity.OpenFOAM'
OpenGL Warning: No pincher, please call crStateSetCurrentPointers() in your SPU
ERROR: In /home/yk/OpenFOAM/ThirdParty-2.3.0/ParaView-4.1.0/VTK/Rendering/OpenGL/vtkOpenGLDisplayListPainter.cxx, line 188
vtkOpenGLDisplayListPainter (0x1bb3a10): failed after RenderInternal 1 OpenGL errors detected
  0 : (1280) Invalid enum



ERROR: In /home/yk/OpenFOAM/ThirdParty-2.3.0/ParaView-4.1.0/VTK/Rendering/OpenGL/vtkOpenGLDisplayListPainter.cxx, line 188
vtkOpenGLDisplayListPainter (0x1bc1db0): failed after RenderInternal 1 OpenGL errors detected
  0 : (1280) Invalid enum



ERROR: In /home/yk/OpenFOAM/ThirdParty-2.3.0/ParaView-4.1.0/VTK/Rendering/OpenGL/vtkOpenGLDisplayListPainter.cxx, line 188
vtkOpenGLDisplayListPainter (0x1bc1db0): failed after RenderInternal 1 OpenGL errors detected
  0 : (1280) Invalid enum



ERROR: In /home/yk/OpenFOAM/ThirdParty-2.3.0/ParaView-4.1.0/VTK/Rendering/OpenGL/vtkOpenGLDisplayListPainter.cxx, line 188
vtkOpenGLDisplayListPainter (0x1bc1db0): failed after RenderInternal 1 OpenGL errors detected
  0 : (1280) Invalid enum



ERROR: In /home/yk/OpenFOAM/ThirdParty-2.3.0/ParaView-4.1.0/VTK/Rendering/OpenGL/vtkOpenGLDisplayListPainter.cxx, line 188
vtkOpenGLDisplayListPainter (0x1bc5230): failed after RenderInternal 1 OpenGL errors detected
  0 : (1280) Invalid enum



ERROR: In /home/yk/OpenFOAM/ThirdParty-2.3.0/ParaView-4.1.0/VTK/Rendering/OpenGL/vtkOpenGLDisplayListPainter.cxx, line 188
vtkOpenGLDisplayListPainter (0x1bc5230): failed after RenderInternal 1 OpenGL errors detected
  0 : (1280) Invalid enum



ERROR: In /home/yk/OpenFOAM/ThirdParty-2.3.0/ParaView-4.1.0/VTK/Rendering/OpenGL/vtkOpenGLDisplayListPainter.cxx, line 188
vtkOpenGLDisplayListPainter (0x1bc5230): failed after RenderInternal 1 OpenGL errors detected
  0 : (1280) Invalid enum



ERROR: In /home/yk/OpenFOAM/ThirdParty-2.3.0/ParaView-4.1.0/VTK/Rendering/OpenGL/vtkOpenGLDisplayListPainter.cxx, line 188
vtkOpenGLDisplayListPainter (0x1bcec00): failed after RenderInternal 1 OpenGL errors detected
  0 : (1280) Invalid enum



ERROR: In /home/yk/OpenFOAM/ThirdParty-2.3.0/ParaView-4.1.0/VTK/Rendering/OpenGL/vtkOpenGLDisplayListPainter.cxx, line 188
vtkOpenGLDisplayListPainter (0x1bd1e30): failed after RenderInternal 1 OpenGL errors detected
  0 : (1280) Invalid enum



ERROR: In /home/yk/OpenFOAM/ThirdParty-2.3.0/ParaView-4.1.0/VTK/Rendering/OpenGL/vtkOpenGLDisplayListPainter.cxx, line 188
vtkOpenGLDisplayListPainter (0x1bd5080): failed after RenderInternal 1 OpenGL errors detected
  0 : (1280) Invalid enum



OpenGL Warning: No pincher, please call crStateSetCurrentPointers() in your SPU

the viedo memory = 64M
the monitor count =1

any help?

wyldckat April 4, 2015 07:56

Quick answer: I think you'll have to rebuild ParaView from source code.

But before that, try installing the ParaView version from Ubuntu's repository:
Code:

sudo apt-get install paraview
Then start a new terminal, run:
Code:

paraview
and create a new "Source -> Sphere". Check if this still gives you an error or not.

cfdopenfoam April 4, 2015 08:05

Quote:

Originally Posted by wyldckat (Post 539930)

Code:

sudo apt-get install paraview
Code:

paraview

just after the 'paraview' was typed in, i got this error:

Code:

ERROR: In /home/yk/OpenFOAM/ThirdParty-2.3.0/ParaView-4.1.0/VTK/Rendering/OpenGL/vtkOpenGLDisplayListPainter.cxx, line 188
vtkOpenGLDisplayListPainter (0x2798bb0): failed after RenderInternal 1 OpenGL errors detected
  0 : (1280) Invalid enum



ERROR: In /home/yk/OpenFOAM/ThirdParty-2.3.0/ParaView-4.1.0/VTK/Rendering/OpenGL/vtkOpenGLDisplayListPainter.cxx, line 188
vtkOpenGLDisplayListPainter (0x27a6f50): failed after RenderInternal 1 OpenGL errors detected
  0 : (1280) Invalid enum



ERROR: In /home/yk/OpenFOAM/ThirdParty-2.3.0/ParaView-4.1.0/VTK/Rendering/OpenGL/vtkOpenGLDisplayListPainter.cxx, line 188
vtkOpenGLDisplayListPainter (0x27a6f50): failed after RenderInternal 1 OpenGL errors detected
  0 : (1280) Invalid enum



ERROR: In /home/yk/OpenFOAM/ThirdParty-2.3.0/ParaView-4.1.0/VTK/Rendering/OpenGL/vtkOpenGLDisplayListPainter.cxx, line 188
vtkOpenGLDisplayListPainter (0x27a6f50): failed after RenderInternal 1 OpenGL errors detected
  0 : (1280) Invalid enum



ERROR: In /home/yk/OpenFOAM/ThirdParty-2.3.0/ParaView-4.1.0/VTK/Rendering/OpenGL/vtkOpenGLDisplayListPainter.cxx, line 188
vtkOpenGLDisplayListPainter (0x27aa3d0): failed after RenderInternal 1 OpenGL errors detected
  0 : (1280) Invalid enum



ERROR: In /home/yk/OpenFOAM/ThirdParty-2.3.0/ParaView-4.1.0/VTK/Rendering/OpenGL/vtkOpenGLDisplayListPainter.cxx, line 188
vtkOpenGLDisplayListPainter (0x27aa3d0): failed after RenderInternal 1 OpenGL errors detected
  0 : (1280) Invalid enum



ERROR: In /home/yk/OpenFOAM/ThirdParty-2.3.0/ParaView-4.1.0/VTK/Rendering/OpenGL/vtkOpenGLDisplayListPainter.cxx, line 188
vtkOpenGLDisplayListPainter (0x27aa3d0): failed after RenderInternal 1 OpenGL errors detected
  0 : (1280) Invalid enum



ERROR: In /home/yk/OpenFOAM/ThirdParty-2.3.0/ParaView-4.1.0/VTK/Rendering/OpenGL/vtkOpenGLDisplayListPainter.cxx, line 188
vtkOpenGLDisplayListPainter (0x27b3db0): failed after RenderInternal 1 OpenGL errors detected
  0 : (1280) Invalid enum



ERROR: In /home/yk/OpenFOAM/ThirdParty-2.3.0/ParaView-4.1.0/VTK/Rendering/OpenGL/vtkOpenGLDisplayListPainter.cxx, line 188
vtkOpenGLDisplayListPainter (0x27b6fe0): failed after RenderInternal 1 OpenGL errors detected
  0 : (1280) Invalid enum



ERROR: In /home/yk/OpenFOAM/ThirdParty-2.3.0/ParaView-4.1.0/VTK/Rendering/OpenGL/vtkOpenGLDisplayListPainter.cxx, line 188
vtkOpenGLDisplayListPainter (0x27ba230): failed after RenderInternal 1 OpenGL errors detected
  0 : (1280) Invalid enum

any suggestion?

wyldckat April 4, 2015 08:17

OK, then try:
Code:

wmUNSET
paraview


cfdopenfoam April 4, 2015 08:22

Quote:

Originally Posted by wyldckat (Post 539934)
OK, then try:
Code:

wmUNSET
paraview


error as follows:

Code:

OpenGL Warning: No pincher, please call crStateSetCurrentPointers() in your SPU
OpenGL Warning: No pincher, please call crStateSetCurrentPointers() in your SPU

when i shut down paraview, i got this:

The crashed program seems to use third-party or local libraries:

/opt/VBoxGuestAdditions-4.3.6/lib/VBoxOGLpackspu.so
/opt/VBoxGuestAdditions-4.3.6/lib/VBoxOGLfeedbackspu.so
/opt/VBoxGuestAdditions-4.3.6/lib/VBoxOGLerrorspu.so
/opt/VBoxGuestAdditions-4.3.6/lib/VBoxOGLcrutil.so
/opt/VBoxGuestAdditions-4.3.6/lib/VBoxOGLpassthroughspu.so
/opt/VBoxGuestAdditions-4.3.6/lib/VBoxOGL.so

It is highly recommended to check if the problem persists without those first.

Do you want to continue the report process anyway?


btw, the wmUNSET clears the OpenFOAM shell environment. how could i get it recovered?

wyldckat April 4, 2015 08:29

Yeah, this is going to go nowhere :( OpenGL acceleration in VirtualBox is simply broken: https://forums.virtualbox.org/viewtopic.php?f=3&t=66626

If you also have problems without 3D acceleration turned on, then it's best that you do what many have done in the past:
  1. Run the cases inside the virtual machine.
  2. When the case is finished, copy the case to the real Windows machine.
  3. Create a empty file "case.foam" inside the case folder and then open that file in ParaView on Windows.
Either that, or uninstall VirtualBox and install VMPlayer. Full instructions available here: http://openfoamwiki.net/index.php/Ho..._VMware_Player

cfdopenfoam April 4, 2015 08:32

Quote:

Originally Posted by wyldckat (Post 539936)
Yeah, this is going to go nowhere :( OpenGL acceleration in VirtualBox is simply broken: https://forums.virtualbox.org/viewtopic.php?f=3&t=66626

If you also have problems without 3D acceleration turned on, then it's best that you do what many have done in the past:
  1. Run the cases inside the virtual machine.
  2. When the case is finished, copy the case to the real Windows machine.
  3. Create a empty file "case.foam" inside the case folder and then open that file in ParaView on Windows.
Either that, or uninstall VirtualBox and install VMPlayer. Full instructions available here: http://openfoamwiki.net/index.php/Ho..._VMware_Player

thanks very much for your valued time and help. i will have a try.
btw, the wmUNSET clears the OpenFOAM shell environment. how could i get it back?

i think the wmSET will get back. thanks a lot.


All times are GMT -4. The time now is 09:08.