CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Paraview & paraFoam

Failed to create symbolic link: flappingConsoleSmall and unable to use ParaView in it

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   December 5, 2013, 07:22
Default Failed to create symbolic link: flappingConsoleSmall and unable to use ParaView in it
  #1
Senior Member
 
ok
Join Date: Oct 2013
Posts: 257
Rep Power: 4
Maimouna is on a distinguished road
Dear Bruno,

thanks a lot, paraview is working now for some tested cases in both OF-2.2.2 and OF-1.6-ext.

But, I faced another problem when I tried running flappingConsoleSmall in
OpenFOAM/maimouna-1.6-ext/run/tutorials/stressAnalysis/icoFsiFoam/flappingConsoleSmall
I apply
./Allclean
./Allrun
for running, it takes around 16 hours for running. It run very well for fluid case , but unfortunately, it gives me this command for solid
ln: failed to create symbolic link `0/solid': File exists
and after paraFoam, it gives me these commands
ERROR: In /build/buildd/paraview-3.14.1/VTK/IO/vtkOpenFOAMReader.cxx, line 8464
vtkPOpenFOAMReader (0x3540160): /home/maimouna/OpenFOAM/maimouna-1.6-ext/run/tutorials/stressAnalysis/icoFsiFoam/flappingConsoleSmall/flappingConsoleSmall.foam contains no timestep data.


ERROR: In /build/buildd/paraview-3.14.1/VTK/Filtering/vtkExecutive.cxx, line 756
vtkPVCompositeDataPipeline (0x35411f0): Algorithm vtkPOpenFOAMReader(0x3540160) returned failure for request: vtkInformation (0x35427d0)
Debug: Off
Modified Time: 70860
Reference Count: 1
Registered Events: (none)
Request: REQUEST_INFORMATION
ALGORITHM_AFTER_FORWARD: 1
FORWARD_DIRECTION: 0

how can solve that? What's wrong with solid at flappingConsoleSmall.

Warm regards
Maimouna
Maimouna is offline   Reply With Quote

Old   December 6, 2013, 07:05
Default Failed to create symbolic link: flappingConsoleSmall
  #2
Senior Member
 
ok
Join Date: Oct 2013
Posts: 257
Rep Power: 4
Maimouna is on a distinguished road
Dear OpenFOAM users,

I'm working in OpenFOAM-1.6-ext in Ubuntu 12.04 (x86.64). I tried flappingConsoleSmall which is FSI case in icoFsiFoam solver (tutorials/ stressAnalysis/ icoFsiFoam/ flappingConsoleSmall), after running,
./Allclean
./Allrun

I got
ln: failed to create symbolic link `solid/constant': File exists
ln: failed to create symbolic link `solid/0': File exists

How can I solve this? Any idea?

Regards
Maimouna is offline   Reply With Quote

Old   December 7, 2013, 11:44
Default
  #3
Senior Member
 
ok
Join Date: Oct 2013
Posts: 257
Rep Power: 4
Maimouna is on a distinguished road
Dear Bruno,

how can I solve
ln: failed to create symbolic link `0/solid': File exists.

after running flappingConsoleSmall case?

Regards
Maimouna is offline   Reply With Quote

Old   December 8, 2013, 14:58
Default
  #4
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Maimouna,

I've moved the first and third post from the other thread you had to here, namely from this one: Unable to install OpenFOAM 1.6-ext

OK, these two:
Code:
ln: failed to create symbolic link `solid/constant': File exists
ln: failed to create symbolic link `solid/0': File exists
Aren't a problem. It just means that it is not able to create the link, because the link already exists from the first time the Allrun script was executed.

If you don't want to see this error, then add these two lines to the end of the Allclean script:
Code:
unlink fluid/0/solid
unlink fluid/constant/solid
As for the problem with ParaView/paraFoam: you must run paraFoam from within the "fluid" folder.

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   December 9, 2013, 07:08
Default
  #5
Senior Member
 
ok
Join Date: Oct 2013
Posts: 257
Rep Power: 4
Maimouna is on a distinguished road
Dear Bruno,

when apply paraFoam, ParaView window gives me this error:

ERROR: In /build/buildd/paraview-3.14.1/VTK/IO/vtkOpenFOAMReader.cxx, line 6875
vtkOpenFOAMReaderPrivate (0x2d670f0): boundaryField defaultFaces not found in object U at time = 0
.

What's the problem?

Regards
Maimouna is offline   Reply With Quote

Old   December 9, 2013, 19:07
Default
  #6
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Maimouna,
  1. Edit the file "fluid/0/U".
  2. Add this to before the last bracket "}" in the file:
    Code:
        defaultFaces
        {
            type            empty;
        }
  3. The last part of the file should now look something like this:
    Code:
        inlet
        {
            type            fixedValue;
            value           uniform (4 0 0);
        }
        frontAndBackPlanes
        {
            type            empty;
        } 
        defaultFaces
        {
            type            empty;
        }
    }
    
    
    // ************************************************************************* //
After saving the file, ParaView should no longer complain.


Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   December 10, 2013, 07:12
Default
  #7
Senior Member
 
ok
Join Date: Oct 2013
Posts: 257
Rep Power: 4
Maimouna is on a distinguished road
Dear Bruno,

many thanks for your help.

Warm regards
Maimouna
Maimouna is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to run paraview yoddha24 OpenFOAM Installation 4 May 6, 2013 00:10
OpenFOAM 1.6.x - CentOS 5.3 x86_64 linnemann OpenFOAM Installation 68 April 22, 2013 11:03
[ANSYS Meshing] Unable to create inflation layer (with picture) rene78 ANSYS Meshing & Geometry 4 March 14, 2013 17:09
[GAMBIT] Unable to create .msh file due high order elements on meshed face error Ty@flent ANSYS Meshing & Geometry 2 August 29, 2011 16:05
Need help with the error cfdproject OpenFOAM Other Meshers: ICEM, Star, Ansys, Pointwise, GridPro, Ansa, ... 0 April 14, 2009 15:45


All times are GMT -4. The time now is 05:16.