CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Paraview & paraFoam

ParaView-4.4.0 with older OpenFOAM-2.1.x

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 8, 2016, 04:06
Post ParaView-4.4.0 with older OpenFOAM-2.1.x
  #1
New Member
 
Mathi
Join Date: Dec 2014
Posts: 10
Rep Power: 3
fluidmobil is on a distinguished road
Hello all,

I installed OpenFOAM-3.0.1 successfully together with ParaView-4.4.0.

For comparing older results I had to install OpenFOAM-2.1.x additionally. That was successful too. But now I wanted to use ParaView-4.4.0 with this OpenFOAM-2.1.x too, but when I start paraFoam I get the message

Quote:
hartwich@EVT111:~/OpenFOAM/hartwich-2.1.x/run/cavity> paraFoam

FATAL ERROR: ParaView reader module libraries do not exist

Please build the reader module before continuing:
cd $FOAM_UTILITIES/postProcessing/graphics/PV3Readers
./Allwclean
./Allwmake
I already tried to start paraFoam with
Quote:
paraFoam -builtin
but this doesn't work.

I also tried to paste the line
Quote:
export PATH=$PATH:/opt/OpenFOAM/ThirdParty-3.0.1/platforms/linux64Gcc/ParaView-4.4.0/bin
to the
/opt/OpenFOAM/OpenFOAM-2.1.x/etc/bashrc

the result was the same.

How is it possible to use ParaView-4.4.0 with OpenFOAM-2.1.x?

Thanks for help
Mathias
fluidmobil is online now   Reply With Quote

Old   July 8, 2016, 04:30
Default
  #2
New Member
 
Mathi
Join Date: Dec 2014
Posts: 10
Rep Power: 3
fluidmobil is on a distinguished road
additional info:

after adding the line
Quote:
export PATH=/opt/OpenFOAM/ThirdParty-3.0.1/platforms/linux64Gcc/ParaView-4.4.0/bin:$PATH
to my $HOME/.bashrc file I could start paraview to visualize my case.

But paraFoam is still not working and gives the message
Quote:
FATAL ERROR: ParaView reader module libraries do not exist

Please build the reader module before continuing:
cd $FOAM_UTILITIES/postProcessing/graphics/PV3Readers
./Allwclean
./Allwmake
How can I get paraFoam running?
Thanks for help
fluidmobil is online now   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenFOAM v3.0+ ?? SBusch OpenFOAM 14 June 23, 2016 06:17
Openfoam for windows 16.02 [CFD support] -problem with paraview ditmeyer OpenFOAM Installation on Windows, Mac and other Unsupported Platforms 1 January 28, 2016 23:53
OpenFOAM v3.0.1 Training, London, Houston, Berlin, Jan-Mar 2016 cfd.direct OpenFOAM Announcements from Other Sources 0 January 5, 2016 04:18
Installing OpenFOAM and ParaView in VirtualBox(Ubuntu on Win8) chrisb2244 OpenFOAM Installation 2 August 21, 2013 13:24
OpenFOAM 1.4.1 with ParaView 3 marico OpenFOAM Installation 0 June 25, 2009 03:33


All times are GMT -4. The time now is 03:05.