CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Paraview & paraFoam

Problem with paraview and paraFoam

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
Old   February 26, 2009, 06:33
Default Dear OF users, My problem i
  #21
Senior Member
 
stephane sanchi
Join Date: Mar 2009
Posts: 305
Rep Power: 10
openfoam_user is on a distinguished road
Dear OF users,

My problem is always unsolved !!!!!!!!!

ERROR: In /shared/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWindow .cxx, line 398
vtkXOpenGLRenderWindow (0x13476b0): Could not find a decent visual

ERROR: In /shared/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWindow .cxx, line 398
vtkXOpenGLRenderWindow (0x13476b0): Could not find a decent visual

X Error: BadValue (integer parameter out of range for operation) 2
Extension: 144 (Uknown extension)
Minor opcode: 3 (Unknown request)
Resource id: 0x21
ERROR: In /shared/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWindow .cxx, line 623
vtkXOpenGLRenderWindow (0x13476b0): Cannot create GLX context. Aborting.

Nobody has had the same error message in the past ?

Thanks for helping me.

Regards,
Stephane
openfoam_user is offline   Reply With Quote

Old   March 6, 2009, 06:15
Default Hi, try to download the bin
  #22
New Member
 
Achim Frahm
Join Date: Mar 2009
Posts: 9
Rep Power: 9
achimfrahmmunterscom is on a distinguished road
Hi,

try to download the binaries for your system directly from kitware. So you are sure that your problems have nothing to do with wrong compilation and/or version. When i did it, i was sure that my grafic card was the reason!
http://www.paraview.org/paraview/res.../software.html
Achim
achimfrahmmunterscom is offline   Reply With Quote

Old   March 17, 2009, 04:53
Default I have same problem
  #23
New Member
 
Sergei D.
Join Date: Mar 2009
Posts: 4
Rep Power: 0
Se9a is on a distinguished road
Hello,

I have same problem

sega@sega:~/OpenFOAM/sega-1.5/run/tutorials/icoFoam/cavity> paraFoam
ERROR: In /home/sega/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 398
vtkXOpenGLRenderWindow (0x132c320): Could not find a decent visual



ERROR: In /home/sega/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 398
vtkXOpenGLRenderWindow (0x132c320): Could not find a decent visual



X Error: BadValue (integer parameter out of range for operation) 2
Extension: 144 (Uknown extension)
Minor opcode: 3 (Unknown request)
Resource id: 0x21
ERROR: In /home/sega/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 623
vtkXOpenGLRenderWindow (0x132c320): Cannot create GLX context. Aborting.

I use openSUSE 11.1, grafic card nVidia 6800 ultra or nVidia NVS 140M, nVidia drivers.
Se9a is offline   Reply With Quote

Old   March 17, 2009, 05:09
Default
  #24
Senior Member
 
stephane sanchi
Join Date: Mar 2009
Posts: 305
Rep Power: 10
openfoam_user is on a distinguished road
Hi Sergei,

you have the same problem as mine which is unfortunately still unsolved !

I also use openSUSE 11.1, graphic card nVidia and nVidia driver.

Keep me updated if you find how to solve this problem.

Regards,
Stephane.
openfoam_user is offline   Reply With Quote

Old   June 28, 2009, 07:31
Default
  #25
New Member
 
alex
Join Date: Jun 2009
Posts: 17
Rep Power: 9
oort is on a distinguished road
Hi!

I have the same problem.

Curiously paravfoam/paraview works after an fresh opensuse installation without updating the nvidia driver.

So the only thing I can tell you is: remove the nvidia driver.

If you do that you loose the driver features (3d aceleratuion, etc) but you can work...

It is a poor solution but it is the only way i can work

My system is a laptop with:

OpenSuse 11.1
OpenFoam 1.5
Qt 4.3.5
NVidia GeForce 9200M GS

My question here is: this only happens with openSuse or also with other linuxes?

Because if it only happens with OpenSuse i will try to change to ubuntu. If happens with any OS it its a problem of graphic board software.
oort is offline   Reply With Quote

Old   June 28, 2009, 13:17
Default I have a solution
  #26
New Member
 
Sergei D.
Join Date: Mar 2009
Posts: 4
Rep Power: 0
Se9a is on a distinguished road
Hello!
I have a solution to the problem. I have installed the ParaView 3.4 from source and Native OpenFOAM Reader for ParaView from here. This works very well on OpenSUSE 11.1 with OpenFOAM 1.5, NVidia Quadro NVS 140M, QT 4.4.3 and NVidia drivers.
Se9a is offline   Reply With Quote

Old   August 26, 2009, 03:14
Default
  #27
Senior Member
 
stephane sanchi
Join Date: Mar 2009
Posts: 305
Rep Power: 10
openfoam_user is on a distinguished road
Hi,

I have installed OpenFOAM-1.6 under Linux 11.1.

My problem with paraFoam has disappeared.

Now paraFoam (paraview 3.6.1) runs well.

Regards,

Stephane.
openfoam_user is offline   Reply With Quote

Old   January 7, 2010, 16:55
Default Alternative solution
  #28
New Member
 
Thomas Clark
Join Date: Mar 2009
Location: Cambridge, UK
Posts: 10
Rep Power: 9
t_clark is on a distinguished road
This is a problem with the glx module, not with paraview.

Try running glxgears and glxinfo. That will test whether the glx module is working correctly.

One suggestion is to try running them as root - in my case, a permissions error was preventing various libraries from loading. Everything worked fine as root, though.

Incidentally, I experienced the problem using OpenSUSE 11.1, an NVIDIA QuadroFX1700 in a Dell T7400 workstation, with current drivers from the NVIDIA repository.

As it was a permissions error, I did not need to edit xorg.conf at all.

** Edit ** I had already gone through installing paraview from source, with the appropriate version of Qt - it might be worth checking this permissions issue first.
t_clark is offline   Reply With Quote

Old   May 25, 2010, 16:42
Default GLX and paraview
  #29
Senior Member
 
chegdan's Avatar
 
Daniel P. Combest
Join Date: Mar 2009
Location: St. Louis, USA
Posts: 581
Rep Power: 20
chegdan will become famous soon enoughchegdan will become famous soon enough
I had been receiving the error:

vtkXOpenGLRenderWindow (0x13476b0): Cannot create GLX context. Aborting.

when starting parafoam and resolved it by deleting all nvidia drivers and packages and reinstalling them. After that, the glxgears and glxinfo worked like a charm...as well as parafoam. this is all in Ubuntu 9.04 amd64 with OF-1.5-dev of course with paraview 3.3. This was an issue with glx module.
chegdan is offline   Reply With Quote

Old   June 11, 2011, 11:07
Default
  #30
Senior Member
 
Suresh kumar Kannan
Join Date: Mar 2009
Location: Luxembourg, Luxembourg, Luxembourg
Posts: 129
Rep Power: 9
kumar is on a distinguished road
Hello ,
one of the solution that worked for me was this:
http://www.starnet.com/xwin32kb/Coul...uffered_Visual

if your ./ALLclean
./makeparaview
and
  • ./Allwclean
  • ./Allwmake
did not give any error message and you get the error
ERROR: In /home/local/UNI/kumar.kannan/OpenFOAM/ThirdParty-1.7.x/paraview-3.8.0/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 404
vtkXOpenGLRenderWindow (0x26398b0): Could not find a decent visual



ERROR: In /home/local/UNI/kumar.kannan/OpenFOAM/ThirdParty-1.7.x/paraview-3.8.0/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 404
vtkXOpenGLRenderWindow (0x26398b0): Could not find a decent visual



X Error: BadValue (integer parameter out of range for operation) 2
Extension: 128 (Uknown extension)
Minor opcode: 3 (Unknown request)
Resource id: 0x21
ERROR: In /home/local/UNI/kumar.kannan/OpenFOAM/ThirdParty-1.7.x/paraview-3.8.0/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 631
vtkXOpenGLRenderWindow (0x26398b0): Cannot create GLX context. Aborting.

then try to just run
export LIBGL_ALWAYS_INDIRECT=1


then try opening paraFoam or paraview.
it should work.

regards
K.Suresh kumar
Daniel Sinka likes this.
kumar is offline   Reply With Quote

Old   July 19, 2011, 06:02
Default
  #31
New Member
 
Ira Sheinman
Join Date: Apr 2010
Posts: 2
Rep Power: 0
Ira_Sheinman is on a distinguished road
Hi! I'm begginer in openFoam and Linux. Now I'm using CAE-Linux 2008 Live DVD. I don't install OS and openFoam on my hard disk. When I lunch paraview, I see the message
XLib: extension "GLX'' missing on display': 0.0". line 75 : 27415 Aborted. paraview paraFoam.pvs.
What is wrong? Many thanks for any advice.
Ira_Sheinman is offline   Reply With Quote

Old   July 19, 2011, 06:24
Default
  #32
Senior Member
 
Suresh kumar Kannan
Join Date: Mar 2009
Location: Luxembourg, Luxembourg, Luxembourg
Posts: 129
Rep Power: 9
kumar is on a distinguished road
HI

The message is clear glx libraries are not installed

Type glxinfo on command prompt

If the packages are not installed install openGL and glx

then try it

http://www.starnet.com/xwin32kb/Coul...uffered_Visual

check this site it may help.

regards
K.SUresh kumar
kumar is offline   Reply With Quote

Old   July 20, 2011, 04:16
Default
  #33
New Member
 
Ira Sheinman
Join Date: Apr 2010
Posts: 2
Rep Power: 0
Ira_Sheinman is on a distinguished road
Many thanks, kumar!
Ira_Sheinman is offline   Reply With Quote

Old   November 22, 2011, 16:39
Default
  #34
New Member
 
Join Date: Jan 2010
Posts: 23
Rep Power: 8
jdiorio is on a distinguished road
Quote:
Originally Posted by kumar View Post
Hello ,
one of the solution that worked for me was this:
http://www.starnet.com/xwin32kb/Coul...uffered_Visual

if your ./ALLclean
./makeparaview
and
  • ./Allwclean
  • ./Allwmake
did not give any error message and you get the error
ERROR: In /home/local/UNI/kumar.kannan/OpenFOAM/ThirdParty-1.7.x/paraview-3.8.0/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 404
vtkXOpenGLRenderWindow (0x26398b0): Could not find a decent visual



ERROR: In /home/local/UNI/kumar.kannan/OpenFOAM/ThirdParty-1.7.x/paraview-3.8.0/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 404
vtkXOpenGLRenderWindow (0x26398b0): Could not find a decent visual



X Error: BadValue (integer parameter out of range for operation) 2
Extension: 128 (Uknown extension)
Minor opcode: 3 (Unknown request)
Resource id: 0x21
ERROR: In /home/local/UNI/kumar.kannan/OpenFOAM/ThirdParty-1.7.x/paraview-3.8.0/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 631
vtkXOpenGLRenderWindow (0x26398b0): Cannot create GLX context. Aborting.

then try to just run
export LIBGL_ALWAYS_INDIRECT=1


then try opening paraFoam or paraview.
it should work.

regards
K.Suresh kumar
Thanks Kumar - that worked for me.
jdiorio is offline   Reply With Quote

Old   January 9, 2013, 20:40
Default
  #35
cnd
New Member
 
Chris
Join Date: Jan 2013
Posts: 1
Rep Power: 0
cnd is on a distinguished road
This is all that you need to fix it:-

export LIBGL_ALWAYS_INDIRECT=1
cnd is offline   Reply With Quote

Old   June 10, 2013, 00:04
Default Found solution
  #36
New Member
 
Ildebrando
Join Date: Jun 2013
Posts: 1
Rep Power: 0
Ildebrando is on a distinguished road
Hi Stephane,

I had exactly the same problem. I know you already solved by changing the paraview version it but I hope this could be useful

http://ubuntuforums.org/archive/inde...t-1418849.html

Quote:
Originally Posted by openfoam_user View Post
Dear OF users,

When i want to lauch paraview (or paraFoam) I got the following error message :

ERROR: In /shared/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWindow .cxx, line 398
vtkXOpenGLRenderWindow (0x1289b90): Could not find a decent visual



ERROR: In /shared/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWindow .cxx, line 398
vtkXOpenGLRenderWindow (0x1289b90): Could not find a decent visual



X Error: BadValue (integer parameter out of range for operation) 2
Extension: 129 (Uknown extension)
Minor opcode: 3 (Unknown request)
Resource id: 0x21
ERROR: In /shared/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWindow .cxx, line 623
vtkXOpenGLRenderWindow (0x1289b90): Cannot create GLX context. Aborting.


Could someone help me to solve this problem. Thanks in advance.

Stephane.
Ildebrando is offline   Reply With Quote

Old   May 13, 2014, 07:37
Default
  #37
New Member
 
Join Date: Apr 2014
Posts: 1
Rep Power: 0
cfd_engineer_2014 is on a distinguished road
Quote:
Originally Posted by kumar View Post
Hello ,
one of the solution that worked for me was this:
http://www.starnet.com/xwin32kb/Coul...uffered_Visual

if your ./ALLclean
./makeparaview
and
  • ./Allwclean
  • ./Allwmake
did not give any error message and you get the error
ERROR: In /home/local/UNI/kumar.kannan/OpenFOAM/ThirdParty-1.7.x/paraview-3.8.0/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 404
vtkXOpenGLRenderWindow (0x26398b0): Could not find a decent visual



ERROR: In /home/local/UNI/kumar.kannan/OpenFOAM/ThirdParty-1.7.x/paraview-3.8.0/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 404
vtkXOpenGLRenderWindow (0x26398b0): Could not find a decent visual



X Error: BadValue (integer parameter out of range for operation) 2
Extension: 128 (Uknown extension)
Minor opcode: 3 (Unknown request)
Resource id: 0x21
ERROR: In /home/local/UNI/kumar.kannan/OpenFOAM/ThirdParty-1.7.x/paraview-3.8.0/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 631
vtkXOpenGLRenderWindow (0x26398b0): Cannot create GLX context. Aborting.

then try to just run
export LIBGL_ALWAYS_INDIRECT=1


then try opening paraFoam or paraview.
it should work.

regards
K.Suresh kumar
Thanks Kumar! This worked for me, too.
cfd_engineer_2014 is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


LinkBacks (?)
LinkBack to this Thread: http://www.cfd-online.com/Forums/openfoam-paraview/61051-problem-paraview-parafoam.html
Posted By For Type Date
Untitled document This thread Refback July 13, 2009 13:10

Similar Threads
Thread Thread Starter Forum Replies Last Post
Error starting paraFoam line 67 paraview command not found jango OpenFOAM Installation 4 July 19, 2007 01:39
Both paraview and paraFoam crash on Redhat Linux WS v4 64bit sek OpenFOAM Paraview & paraFoam 4 August 17, 2006 16:26
ParaFoam conflicting version of paraview xponticq OpenFOAM Paraview & paraFoam 3 May 16, 2006 12:52
Building Paraview with reader builtin instead of parafoam script tj22 OpenFOAM Paraview & paraFoam 2 April 7, 2006 12:55
Problem running paraFoam paraview command not found spdracer22 OpenFOAM Pre-Processing 2 December 7, 2005 06:32


All times are GMT -4. The time now is 03:54.