CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Paraview & paraFoam

Problem with paraview and paraFoam

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   January 16, 2009, 06:06
Default Dear OF users, When i want
  #1
Senior Member
 
stephane sanchi
Join Date: Mar 2009
Posts: 300
Rep Power: 9
openfoam_user is on a distinguished road
Dear OF users,

When i want to lauch paraview (or paraFoam) I got the following error message :

ERROR: In /shared/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWindow .cxx, line 398
vtkXOpenGLRenderWindow (0x1289b90): Could not find a decent visual



ERROR: In /shared/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWindow .cxx, line 398
vtkXOpenGLRenderWindow (0x1289b90): Could not find a decent visual



X Error: BadValue (integer parameter out of range for operation) 2
Extension: 129 (Uknown extension)
Minor opcode: 3 (Unknown request)
Resource id: 0x21
ERROR: In /shared/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWindow .cxx, line 623
vtkXOpenGLRenderWindow (0x1289b90): Cannot create GLX context. Aborting.


Could someone help me to solve this problem. Thanks in advance.

Stephane.
openfoam_user is offline   Reply With Quote

Old   January 16, 2009, 07:39
Default Hi Stephane, Did you rebuil
  #2
Senior Member
 
Gijsbert Wierink
Join Date: Mar 2009
Posts: 383
Rep Power: 9
gwierink is on a distinguished road
Hi Stephane,

Did you rebuild ParaView or just unpacked the binary? I think you need to build it as explained in the README (http://www.opencfd.co.uk/openfoam/do...ME.html#README). I also had some problems with openGL headers and stuff and installing "X Software Development" solved it (yum groupinstall 'X Software Development' in Fedora).

Rgds, Gijsbert
__________________
Regards, Gijs
gwierink is offline   Reply With Quote

Old   January 16, 2009, 07:54
Default Hi Gijsbert, Now we use Sus
  #3
Senior Member
 
stephane sanchi
Join Date: Mar 2009
Posts: 300
Rep Power: 9
openfoam_user is on a distinguished road
Hi Gijsbert,

Now we use Suse 11.1 (since last week).

I have rebuilt Paraview.

Paraview alone (with setenv for OpenFoam) works well. But when I want to use it (or paraFoam) with the setenv parameters for OpenFoam (.cshrc file) it does not work.

I have done the installation test and have the following critical error :
gcc ...figure
WARNING: Conflicting installations:
OpenFOAM settings : /bin/gcc
current path : /usr/bin/X11/gcc
CRITICAL ERROR

Stephane.
openfoam_user is offline   Reply With Quote

Old   January 19, 2009, 09:58
Default Dear O-F users, I have inst
  #4
Senior Member
 
stephane sanchi
Join Date: Mar 2009
Posts: 300
Rep Power: 9
openfoam_user is on a distinguished road
Dear O-F users,

I have installed OpenFOAM-1.5 with Suse 11.1.

The installation test seems ok.
Checking basic setup...
-------------------------------------------------------------------------------
Shell: tcsh
Host: cfs10
OS: Linux version 2.6.27.7-9-default
-------------------------------------------------------------------------------


Checking main OpenFOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /shared/OpenFOAM yes yes
$WM_PROJECT_USER_DIR /home/sanchi/OpenFOAM/sanchi-1.5 yes no
$WM_THIRD_PARTY_DIR /shared/OpenFOAM/ThirdParty yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /shared/OpenFOAM/OpenFOAM-1.5 yes yes yes

$FOAM_APPBIN ...1.5/applications/bin/linux64GccDPOpt yes yes yes
$FOAM_USER_APPBIN ...1.5/applications/bin/linux64GccDPOpt yes yes no
$WM_DIR /shared/OpenFOAM/OpenFOAM-1.5/wmake yes yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ...OAM/OpenFOAM-1.5/lib/linux64GccDPOpt yes no yes
$FOAM_USER_LIBBIN ...nFOAM/sanchi-1.5/lib/linux64GccDPOpt yes no no
$MPI_ARCH_PATH ...nmpi-1.2.6/platforms/linux64GccDPOpt yes no yes
-------------------------------------------------------------------------------


Third party software
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
gcc 4.3.1 ...penFOAM/ThirdParty/gcc-4.3.1/platforms/linux64/bin/gcc
gzip 1.3.12 /usr/bin/X11/gzip
tar 1.20 /bin/tar
icoFoam .../OpenFOAM-1.5/applications/bin/linux64GccDPOpt/icoFoam
-------------------------------------------------------------------------------


Checking networking...
-------------------------------------------------------------------------------
Action Result Crit
-------------------------------------------------------------------------------
Pinging_cfs10 Successful yes
Pinging_localHost Successful yes
Test_rsh: Unsuccessful_connection_refused* yes
Test_ssh: Successful yes
(*) Only one of rsh or ssh is required by the OpenFOAM enviroment.

-------------------------------------------------------------------------------

Base configuration ok.

Critical systems ok.

I have also installed Qt-4.3.5.

But when I launch paraFoam (or paraview) paraview opens and suddently close with the following error message :
ERROR: In /shared/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWindow .cxx, line 398
vtkXOpenGLRenderWindow (0x12876e0): Could not find a decent visual



ERROR: In /shared/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWindow .cxx, line 398
vtkXOpenGLRenderWindow (0x12876e0): Could not find a decent visual



X Error: BadValue (integer parameter out of range for operation) 2
Extension: 129 (Uknown extension)
Minor opcode: 3 (Unknown request)
Resource id: 0x21
ERROR: In /shared/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWindow .cxx, line 623
vtkXOpenGLRenderWindow (0x12876e0): Cannot create GLX context. Aborting.

I need your help to solve this problem !!!

Stephane.
openfoam_user is offline   Reply With Quote

Old   January 20, 2009, 06:43
Default Dear OpenFOAM users, nobody
  #5
Senior Member
 
stephane sanchi
Join Date: Mar 2009
Posts: 300
Rep Power: 9
openfoam_user is on a distinguished road
Dear OpenFOAM users,

nobody has encountered the same kind of problem ?

I do not have any idea how to solve it.

Stephane.
openfoam_user is offline   Reply With Quote

Old   January 20, 2009, 06:50
Default Hi, i had also a lot of pro
  #6
New Member
 
Bastien Holbek
Join Date: Mar 2009
Posts: 15
Rep Power: 8
bholbek is on a distinguished road
Hi,

i had also a lot of problem with paraFoam. Converting the data to VTK format with foamToVTK utility and visualising them directly with paraview is a solution (not the best...)

Bastien
bholbek is offline   Reply With Quote

Old   January 20, 2009, 07:39
Default Hi, I have also the same pr
  #7
Senior Member
 
stephane sanchi
Join Date: Mar 2009
Posts: 300
Rep Power: 9
openfoam_user is on a distinguished road
Hi,

I have also the same problem with paraview !

So with paraFoam and paraview I have the following error message :

ERROR: In /shared/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWindow .cxx, line 398
vtkXOpenGLRenderWindow (0x12876e0): Could not find a decent visual



ERROR: In /shared/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWindow .cxx, line 398
vtkXOpenGLRenderWindow (0x12876e0): Could not find a decent visual



X Error: BadValue (integer parameter out of range for operation) 2
Extension: 129 (Uknown extension)
Minor opcode: 3 (Unknown request)
Resource id: 0x21
ERROR: In /shared/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWindow .cxx, line 623
vtkXOpenGLRenderWindow (0x12876e0): Cannot create GLX context. Aborting.

The problem is linked with /OpenFOAM/ThirdParty/Paraview3.3-cvs !!!

Because when I use Paraview3.5 I have no problem and the Paraview window remains normally openned !

Stephane.
openfoam_user is offline   Reply With Quote

Old   January 21, 2009, 05:47
Default Any idea how to solve my probl
  #8
Senior Member
 
stephane sanchi
Join Date: Mar 2009
Posts: 300
Rep Power: 9
openfoam_user is on a distinguished road
Any idea how to solve my problem ?

Linux 11.1
OpenFOAM 1.5

I need your help.

Thanks in advance,

Stephane.
openfoam_user is offline   Reply With Quote

Old   January 21, 2009, 06:37
Default Hi Stephane, Check out this
  #9
Senior Member
 
Gijsbert Wierink
Join Date: Mar 2009
Posts: 383
Rep Power: 9
gwierink is on a distinguished road
Hi Stephane,

Check out this post: http://www.cfd-online.com/OpenFOAM_D...es/1/4438.html. Also, try to install the X Software development package. This solved it for me when I had problems with openGL libraries in Fedora and your error seems similar. In Fedora I just did "yum groupinstall 'X Software Development'". I think, in your openSUSE system, you need to go to Yast, select Software Management, and install gcc, xorg-x11-devel, and libpng-devel. My experience with openSUSE is minimal, but you could give it a go.
Your error message contains "Cannot create GLX context. Aborting." and this issue seems to have been solved by pUl| in the post mentioned above. I hope any of this is useful.

Regards, Gijsbert
__________________
Regards, Gijs
gwierink is offline   Reply With Quote

Old   January 21, 2009, 06:59
Default Hi Gijsbert, gcc, xorg-x11-
  #10
Senior Member
 
stephane sanchi
Join Date: Mar 2009
Posts: 300
Rep Power: 9
openfoam_user is on a distinguished road
Hi Gijsbert,

gcc, xorg-x11-devel, and libpng-devel are already installed. The problem does not seem to be here.

It is very strange because :

1. When I use ParaView 3.5 it works well and the window remains openned !
2. When I use ParaView3.3-cvs it (paraFoam and paraview) does not work any more and the paraFoam window closes immediatly with the ERROR message written in the previous post !

Stephane.
openfoam_user is offline   Reply With Quote

Old   January 21, 2009, 07:38
Default Hi Stephane, Line 623 in Op
  #11
Senior Member
 
Gijsbert Wierink
Join Date: Mar 2009
Posts: 383
Rep Power: 9
gwierink is on a distinguished road
Hi Stephane,

Line 623 in OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWindow.cxx checks that your system supports GLX rendering. Maybe it's an issue with your GLX modules and extensions (check http://www.susegeek.com/graphics/setup-nvidia-graphics-card-with-aiglx-rendering -for-opensuse-110/) and I guess you need /usr/lib64/xorg/modules/extensions/libglx.so or /usr/lib/xorg/modules/extensions/libglx.so, but this is all a shot from the hip .

Gijsbert
__________________
Regards, Gijs
gwierink is offline   Reply With Quote

Old   January 22, 2009, 04:36
Default Hi Gijsbert, I have tried
  #12
Senior Member
 
stephane sanchi
Join Date: Mar 2009
Posts: 300
Rep Power: 9
openfoam_user is on a distinguished road
Hi Gijsbert,

I have tried to modify the settings of the NVIDIA card but without any success. The problem still remains.

Dear users any suggestion is welcome !!!

Stephane.
openfoam_user is offline   Reply With Quote

Old   January 23, 2009, 04:03
Default Dear OF users, Any ideas ?
  #13
Senior Member
 
stephane sanchi
Join Date: Mar 2009
Posts: 300
Rep Power: 9
openfoam_user is on a distinguished road
Dear OF users,

Any ideas ?

I can't use paraFoam (and paraview) any more ...

Stephane.
openfoam_user is offline   Reply With Quote

Old   January 26, 2009, 05:40
Default I need help. I can't solve
  #14
Senior Member
 
stephane sanchi
Join Date: Mar 2009
Posts: 300
Rep Power: 9
openfoam_user is on a distinguished road
I need help.

I can't solve this problem !!!

Stephane.
openfoam_user is offline   Reply With Quote

Old   January 26, 2009, 11:58
Default Hi Stephane, What version
  #15
Senior Member
 
Michael Jaworski
Join Date: Mar 2009
Location: Champaign, IL, USA
Posts: 126
Rep Power: 8
mike_jaworski is on a distinguished road
Hi Stephane,
What version of QT do you have installed? You *need* to have QT-4.3.5 installed if you're going to use ParaView 3.3 and the buildParaView3 script file. If you search the forum, there are some explicit instructions for how to do this into a home directory.

Good luck!
-Mike J.
mike_jaworski is offline   Reply With Quote

Old   January 27, 2009, 03:39
Default Hi Michael, I have Qt 4.3.5
  #16
Senior Member
 
stephane sanchi
Join Date: Mar 2009
Posts: 300
Rep Power: 9
openfoam_user is on a distinguished road
Hi Michael,

I have Qt 4.3.5 installed !

But Alberto passalacqua told me that it is not necessary. With Linux 11.1 you could use Qt4 with libqt4-devel. Now I am trying his solution.

Stephane.
openfoam_user is offline   Reply With Quote

Old   January 27, 2009, 05:51
Default Dear OF users, Alberto Pass
  #17
Senior Member
 
stephane sanchi
Join Date: Mar 2009
Posts: 300
Rep Power: 9
openfoam_user is on a distinguished road
Dear OF users,

Alberto Passalacqua told me that it is possible to run paraView with Qt4 under Linux 11.1. I did it following the installation commands (his website).

But I have the following ERROR message :

paraview: symbol lookup error: /shared/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linux64Gcc/bin/libpqCore.s o: undefined symbol: _ZN11QFormLayout16staticMetaObjectE

Has someone already encountered the same error message. Thanks for helping me ..

Stephane
openfoam_user is offline   Reply With Quote

Old   January 27, 2009, 10:12
Default Hi, After having followed t
  #18
Senior Member
 
stephane sanchi
Join Date: Mar 2009
Posts: 300
Rep Power: 9
openfoam_user is on a distinguished road
Hi,

After having followed the instructions of Alberto Passalacqua I have again the same ERROR message :

ERROR: In /shared/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWindow .cxx, line 398
vtkXOpenGLRenderWindow (0x12876e0): Could not find a decent visual

ERROR: In /shared/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWindow .cxx, line 398
vtkXOpenGLRenderWindow (0x12876e0): Could not find a decent visual

X Error: BadValue (integer parameter out of range for operation) 2
Extension: 129 (Uknown extension)
Minor opcode: 3 (Unknown request)
Resource id: 0x21
ERROR: In /shared/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWindow .cxx, line 623
vtkXOpenGLRenderWindow (0x12876e0): Cannot create GLX context. Aborting.

The problem is linked with /OpenFOAM/ThirdParty/Paraview3.3-cvs !!!

Because when I use Paraview3.5 I have no problem and the Paraview window remains normally openned !

Stephane.
openfoam_user is offline   Reply With Quote

Old   January 29, 2009, 08:45
Default Hi, I still have the foolow
  #19
Senior Member
 
stephane sanchi
Join Date: Mar 2009
Posts: 300
Rep Power: 9
openfoam_user is on a distinguished road
Hi,

I still have the foolowing problem :

ERROR: In /shared/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWindow .cxx, line 398
vtkXOpenGLRenderWindow (0x12876e0): Could not find a decent visual

ERROR: In /shared/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWindow .cxx, line 398
vtkXOpenGLRenderWindow (0x12876e0): Could not find a decent visual

X Error: BadValue (integer parameter out of range for operation) 2
Extension: 129 (Uknown extension)
Minor opcode: 3 (Unknown request)
Resource id: 0x21
ERROR: In /shared/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWindow .cxx, line 623
vtkXOpenGLRenderWindow (0x12876e0): Cannot create GLX context. Aborting.

Nobody with the same problem ?

Need help !!! I can't use OpenFOAM anymore !!!

With Suse11.0 paraview was running well. With Suse11.1 I can't run anymore paraview !!!

Stephane.
openfoam_user is offline   Reply With Quote

Old   February 5, 2009, 10:08
Default Dear OpenFOAM users, I enco
  #20
New Member
 
Markus Ritter
Join Date: Mar 2009
Location: Göttingen, Germany
Posts: 1
Rep Power: 0
markus_ritter is on a distinguished road
Dear OpenFOAM users,

I encountered the same problem when starting Paraview 3.4.0. The window closed immediately after starting. The error message was:

[ritt_mu@kauz ~]$ /opt/paraview/bin/paraview
> ERROR: In
> /tmp/Kitware/ParaView3/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 623
> vtkXOpenGLRenderWindow (0x9b7d2b0): Cannot create GLX context. Aborting.
>
>
> Abort


Adding the line

Option "AIGLX" "false"

to the xorg.conf file like proposed in [1] didn't solve the problem.

I don't know the exact origin of this error, but after reconfiguring the driver of the graphics card (nvidia) paraview starts normally. (We updated the kernel some days ago but not the driver of the graphics card)
BTW, we use Red Hat in our Institute.

Maybe this information helps you.

Regards,
Markus

[1] http://www.cfd-online.com/OpenFOAM_D...es/1/4438.html
markus_ritter is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


LinkBacks (?)
LinkBack to this Thread: http://www.cfd-online.com/Forums/openfoam-paraview/61051-problem-paraview-parafoam.html
Posted By For Type Date
Untitled document This thread Refback July 13, 2009 13:10

Similar Threads
Thread Thread Starter Forum Replies Last Post
Error starting paraFoam line 67 paraview command not found jango OpenFOAM Installation 4 July 19, 2007 01:39
Both paraview and paraFoam crash on Redhat Linux WS v4 64bit sek OpenFOAM Paraview & paraFoam 4 August 17, 2006 16:26
ParaFoam conflicting version of paraview xponticq OpenFOAM Paraview & paraFoam 3 May 16, 2006 12:52
Building Paraview with reader builtin instead of parafoam script tj22 OpenFOAM Paraview & paraFoam 2 April 7, 2006 12:55
Problem running paraFoam paraview command not found spdracer22 OpenFOAM Pre-Processing 2 December 7, 2005 06:32


All times are GMT -4. The time now is 21:30.