CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Paraview & paraFoam (http://www.cfd-online.com/Forums/openfoam-paraview/)
-   -   Error in paraFoam (http://www.cfd-online.com/Forums/openfoam-paraview/61055-error-parafoam.html)

mattlee March 2, 2009 00:24

Hi, everyone I installed o
 
Hi, everyone

I installed openfoam 1.5 on ubuntu 8.04.2 x64 sucessfully according to the readme file and ran the first example case of incompressible laminar flow in a cavity.

cd $HOME/OpenFOAM/$USER-$WM_PROJECT_VERSION/run/tutorials/icoFoam/cavity
blockMesh
icoFoam
paraFoam

the first 3 commands were OK, while paraFoam gave error as follows:

lee@lee-desktop:~/OpenFOAM/lee-1.5/run/tutorials/icoFoam/cavity$ paraFoam
paraview: symbol lookup error: /home/lee/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linux64Gcc/bin/libpqCore .so: undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv

How can I solve this problem?

smart June 18, 2009 13:22

Same problems
 
Hi, do you find the way to solve this problem? Thanks

smart June 29, 2009 15:36

OpenFOAM-1.5-dev is OK (with paraFoam)
 
Hi all,

I finaly get the OpenFOAM-1.5-dev running perfectly. I changed my linux system to Ubuntu 8.04. I experienced problems with paraFoam and paraview under ubuntu 9.04.

I solved the problem by installing paraview 3.4.0 instead of 3.3-cvs. For this, I changed some file (buildParaView3.3-cvs, in OpenFOAM-1.5-dev/bin and in OpenFOAM-1.5-dev/bin/tools and the bashrc in OpenFOAM-1.5-dev/etc/apps to point to the ParaView-3.4.0 folder (OpenFOAM/ThirdParty/ParaView-3.4.0).

I think it should be OK too with the ubuntu 9.04 in which the qmake version 4.3.5 should be installed.

For me, I used qmake 4.3.4 and gcc 4.3.1.

Thank to all!


All times are GMT -4. The time now is 23:48.