CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Paraview & paraFoam

No figure is plotted

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 18, 2008, 09:46
Default Hi, I have generated a mesh
  #1
New Member
 
Rina Oldek
Join Date: Mar 2009
Posts: 4
Rep Power: 8
rinaoldek is on a distinguished road
Hi,

I have generated a mesh using FoamX, however, when using the command of "paraFoam...." the paraview box opens,and when I push the accept button nothing happens. It doesn't give me any warning.

What is the problem

Ol
rinaoldek is offline   Reply With Quote

Old   February 12, 2009, 13:56
Default You have to select the availab
  #2
Senior Member
 
musaddeque hossein
Join Date: Mar 2009
Posts: 307
Rep Power: 9
musahossein is on a distinguished road
You have to select the available meshes and patch and click on accept. Then click on the dsiplay tab, and select the wireframe option. The mesh should then show. if it still does not show, then open your foam case in a new terminal, load parafaom and go thru the steps again.

Musa
musahossein is offline   Reply With Quote

Old   February 24, 2009, 09:57
Default Hi, I have a problem with p
  #3
New Member
 
amin ziaforoughi
Join Date: Mar 2009
Location: kerman, iran
Posts: 6
Rep Power: 8
prettyflower is on a distinguished road
Hi,

I have a problem with paraview when I ran cavity tutorial,when I ran paraview after icofoam command,paraview is opended but nothings is displayed even eye shape in near cavity.foam.
I don't know why.
everything is ok when generating mesh with polyMesh
and solving problem by icoFoam command.
please help me.
regard
prettyflower is offline   Reply With Quote

Old   February 24, 2009, 10:33
Default Amin: How did you run the p
  #4
Senior Member
 
musaddeque hossein
Join Date: Mar 2009
Posts: 307
Rep Power: 9
musahossein is on a distinguished road
Amin:

How did you run the problem? If you did not use allrun, then you would have to execute the processes separately in order to create output. Common processes that you have to run are:
1. Blockmesh
2. Setfields
3. IcoFoam (or whatever solver you need to run).

To determine whether any output has been generated, just check the directory . You should see folders for each timestep in the directory if output has been generated.

Musa
musahossein is offline   Reply With Quote

Old   February 26, 2009, 04:06
Default Hello Dear Musa; yes I make
  #5
New Member
 
amin ziaforoughi
Join Date: Mar 2009
Location: kerman, iran
Posts: 6
Rep Power: 8
prettyflower is on a distinguished road
Hello Dear Musa;

yes I make a mistake to run paraFoam command.

thanks for your help and your attention.

best regard
prettyflower is offline   Reply With Quote

Old   July 12, 2009, 12:47
Default Same Problem
  #6
New Member
 
Sebastian
Join Date: Jul 2009
Location: Darmstadt, Germany
Posts: 11
Rep Power: 8
sparbroetchen is on a distinguished road
Hello,

I just tried to Install OpenFOAM and so far everything worked fine. As the Installation Guide said, I tried to solve the cavity case.
  1. blockMesh
  2. icoFoam
  3. paraFoam
After exeuting ParaFoam Paraview opened but nothing was displayed. I think this is the same problem discussed in that thread. No error message ocuured.

Can you help me?

best regard

Sebastian
sparbroetchen is offline   Reply With Quote

Old   July 19, 2009, 15:07
Default
  #7
IGG
New Member
 
Igor Galdona
Join Date: Jun 2009
Posts: 14
Rep Power: 8
IGG is on a distinguished road
Hi everybody,

I have the same problem that Sebastian. I can see nothing in the cavity example of the user's guide. There was no error message, first i write blockMesh, then paraFoam, icoFoam and paraFoam again (in a terminal). First time when i run paraview i can't see the mesh and second time i can't see nothing.

When i wrote first, the next messages appeared in the terminal:

get fences failed: -1
param: 6, val: 0

Could anybody hel us please?

Thank you very much!
IGG is offline   Reply With Quote

Old   July 23, 2009, 07:03
Default no figure plottet
  #8
New Member
 
Sebastian
Join Date: Jul 2009
Location: Darmstadt, Germany
Posts: 11
Rep Power: 8
sparbroetchen is on a distinguished road
Hello,

I compiled it again, and then it worked. Can you attach a screenshot of your paraFoam?

If it doesn't work, try the foamToVTK tool.

Greetings

Sebastian
sparbroetchen is offline   Reply With Quote

Old   July 23, 2009, 08:17
Default
  #9
IGG
New Member
 
Igor Galdona
Join Date: Jun 2009
Posts: 14
Rep Power: 8
IGG is on a distinguished road
Hi Sebastian!

So did you have the same problem? What can i do to compile the Paraview module? Was it included in the ThirdParty pack?

I'll attach a screenshot this afternoon.
IGG is offline   Reply With Quote

Old   July 23, 2009, 12:21
Default
  #10
IGG
New Member
 
Igor Galdona
Join Date: Jun 2009
Posts: 14
Rep Power: 8
IGG is on a distinguished road
Good afternoon,

Here are the captures. As you can see, nothing can be watched. A can't understand where is the problem...



IGG is offline   Reply With Quote

Old   July 23, 2009, 12:58
Default no figure plotted
  #11
New Member
 
Sebastian
Join Date: Jul 2009
Location: Darmstadt, Germany
Posts: 11
Rep Power: 8
sparbroetchen is on a distinguished road
Hello Igor,

I solved the Problem by compiling paraview.

Did you try to use foamToVTK ? This will create vtk files, which can be opened with paraView.
Just start paraview and the open the vtk - file. If this doesn't work I have no idea...

Greatings

Sebastian
sparbroetchen is offline   Reply With Quote

Old   July 23, 2009, 13:14
Default Compiling ParaView
  #12
New Member
 
Sebastian
Join Date: Jul 2009
Location: Darmstadt, Germany
Posts: 11
Rep Power: 8
sparbroetchen is on a distinguished road
Sorry,

to use the foamToVTK there's no need to compile paraview. The difference is, that you can't start paraview with the paraFoam command. Use the paraview command instead.

Can you tell me, what ubunut version you have?

Thx

Sebastian
sparbroetchen is offline   Reply With Quote

Old   July 23, 2009, 13:29
Default
  #13
IGG
New Member
 
Igor Galdona
Join Date: Jun 2009
Posts: 14
Rep Power: 8
IGG is on a distinguished road
Hi Sebastian, thank you for your fast answer.

I have Ubuntu 9.0.4 and i tried foamToVTK command and it works!!!But for the cavity example it creates 6 files, and i think each of them are different time steps, so if i open a file, i cannot go directly to the next time step without closing the active file...I realized that an openFOAM flie extension is not created either when i make icoFoam in the terminal. I don't know if it is common?

Could you tell me how to compile paraView? Is it in ThirParty folder?

I am a Ubuntu very begginer, so excuse me please.
IGG is offline   Reply With Quote

Old   July 23, 2009, 13:35
Default compiling doesn't work wit5h Ubuntu 9.04
  #14
New Member
 
Sebastian
Join Date: Jul 2009
Location: Darmstadt, Germany
Posts: 11
Rep Power: 8
sparbroetchen is on a distinguished road
I also tried to compile OpenFOAM in Ubuntu 9.04, and that didn't work, because openFoam need qt 4.3 for compiling. Ubuntu 9.04 delivers only QT 4.4. So I installed Ubuntu 8.04 and now it works really fine. I've written a howTo for Installing OpenFOAM, but it's in German. The Compiler is in the ThirPartyPackage.


Greatings

Sebastian
sparbroetchen is offline   Reply With Quote

Old   July 23, 2009, 13:42
Default
  #15
IGG
New Member
 
Igor Galdona
Join Date: Jun 2009
Posts: 14
Rep Power: 8
IGG is on a distinguished road
Ok. Thanks to a post here i think i have openFOAM running on this Ubuntu 9.0.4 version. I think it solves and it gives no error.

Do you think I can't see openFoam flies in paraView because i have Ubuntu 9.0.4?
IGG is offline   Reply With Quote

Old   July 23, 2009, 13:55
Default Ubuntu 9.04
  #16
New Member
 
Sebastian
Join Date: Jul 2009
Location: Darmstadt, Germany
Posts: 11
Rep Power: 8
sparbroetchen is on a distinguished road
paraview alone works fine, because the vtk - import seems to work. The problem is, that the paraFoam command doesn't work properly. the easiest way is, to use Ubuntu 8.04 instead of 9.04.
sparbroetchen is offline   Reply With Quote

Old   July 23, 2009, 13:59
Default
  #17
IGG
New Member
 
Igor Galdona
Join Date: Jun 2009
Posts: 14
Rep Power: 8
IGG is on a distinguished road
Ok, i'll see what i do...

Could i work whit VTK files, or are they just a patch and is better to work on ubuntu 8.0.4?
IGG is offline   Reply With Quote

Old   July 23, 2009, 14:15
Default vtk
  #18
New Member
 
Sebastian
Join Date: Jul 2009
Location: Darmstadt, Germany
Posts: 11
Rep Power: 8
sparbroetchen is on a distinguished road
You could work with vtk files. They are nescessary if you want to do your postprocessing under windows.

The disatvantage is, that you can't animate your results.

Greetings

Sebastian
sparbroetchen is offline   Reply With Quote

Old   July 23, 2009, 14:22
Default
  #19
IGG
New Member
 
Igor Galdona
Join Date: Jun 2009
Posts: 14
Rep Power: 8
IGG is on a distinguished road
Thank you very much Sebastian.

Best regards,

Igor
IGG is offline   Reply With Quote

Old   August 16, 2009, 18:12
Default
  #20
Member
 
Jean-Peer Lorenz
Join Date: Mar 2009
Location: Rostock, Germany
Posts: 33
Rep Power: 8
jploz is on a distinguished road
I faced the problem described above as well when installing OpenFOAM 1.6.x and ParaView 3.6.1 on a machine running Ubuntu 9.04: no output in paraFoam but using the VTK converter works.

I solved the problem following this advice:

OpenFOAM 1.6 package - CentOS 5.3 x86_64

Quote:
I guess your ParaView (PV3FoamReader) is affected by a problem which is reportedly occurs only when ParaView built with Qt 4.5.x is run under certain locales [1]. Try running paraFoam after running "export LC_ALL=C". If it works, write the "export LC_ALL=C" line into somewhere in the paraFoam script for later convenience.
Everything works fine now!

Regards.
jploz is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Really weird problem could nbt figure it out 21kalee OpenFOAM Running, Solving & CFD 2 December 30, 2007 11:30
How to get together plotted results and solid part Giuseppe CFX 0 September 20, 2007 07:54
figure rati FLUENT 4 July 17, 2006 06:18
How to get data out of figure? Boying Lin Main CFD Forum 4 October 30, 2005 17:36
Timestep value plotted in animation, CFX 5.5 POST Sjoerd Romkes CFX 7 March 5, 2002 11:34


All times are GMT -4. The time now is 08:52.