CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Paraview & paraFoam

Paraview command not found

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   August 22, 2007, 07:50
Default Hello! I canīt get paraFoam
  #1
New Member
 
Hardy
Join Date: Mar 2009
Location: Sweden
Posts: 19
Rep Power: 8
hardy is on a distinguished road
Hello!

I canīt get paraFoam to start.

It says: "OpenFOAM-1.4/bin/paraFoam: line 67: paraview: command not found"

I guess its a simple problem to fix but my skills in OpenFoam and C++ are not the best....yet :-)

Any clues out there!!

Thank you!!

/H
hardy is offline   Reply With Quote

Old   August 22, 2007, 12:29
Default Did you forget to install para
  #2
Senior Member
 
Srinath Madhavan (a.k.a pUl|)
Join Date: Mar 2009
Location: Edmonton, AB, Canada
Posts: 698
Rep Power: 12
msrinath80 is on a distinguished road
Did you forget to install paraview in addition to OpenFOAM (general and binary).
msrinath80 is offline   Reply With Quote

Old   August 22, 2007, 12:58
Default Did you compile OpenFOAM from
  #3
connclark
Guest
 
Posts: n/a
Did you compile OpenFOAM from source? If so I found that it took some hacking to get parafoam to compile. Unfortunately they don't distribute a tar ball of the paraview source that OpenFOAM expects so you have to track down some header files in the official paraview source tree.
  Reply With Quote

Old   August 23, 2007, 07:55
Default Hello! Is there some kind o
  #4
New Member
 
Hardy
Join Date: Mar 2009
Location: Sweden
Posts: 19
Rep Power: 8
hardy is on a distinguished road
Hello!

Is there some kind of installation instruction for paraview available somewhere??

/H
hardy is offline   Reply With Quote

Old   August 23, 2007, 12:53
Default Hello Hardy, A Good evening
  #5
Senior Member
 
Philippose Rajan
Join Date: Mar 2009
Location: Germany
Posts: 530
Rep Power: 16
philippose will become famous soon enough
Hello Hardy,

A Good evening to you!

Are you looking for instructions for installing the Binary version of ParaView (The version which you dont need to compile), or do you want to actually compile Paraview on your computer ?

In case you want to just install the Binaries, then all you need to do is to download the right version (32 bit or 64 bit) of the ParaView binaries from the "downloads" section of the OpenFOAM website, and unzip it into one of the following folders:

[your OpenFOAM directory]/linux <-- If its a 32 bit version

[your OpenFOAM directory]/linux64 <-- If its a 64 bit version

This should be all you need to do... then, the command "paraFoam <root> <case>" should bring up the Paraview interface.

On the other hand, if you want to recompile Paraview, its a little more complex, and if you want to do this, let me know, and I can give you the instructions :-)!

Enjoy!

Philippose
philippose is offline   Reply With Quote

Old   August 28, 2007, 20:06
Default Philippose, Perhaps you cou
  #6
connclark
Guest
 
Posts: n/a
Philippose,

Perhaps you could put directions to compiling paraview to work with OpenFOAM on the wiki as not everybody uses an x86 processor and there are no other precompiled binary files for other archs.


Conn
  Reply With Quote

Old   July 19, 2008, 12:02
Default hi i am having the same proble
  #7
Senior Member
 
mayank gupta
Join Date: Mar 2009
Posts: 110
Rep Power: 8
mgz1985 is on a distinguished road
hi i am having the same problem as the post here

mayank-guptas-macbook:icoFoam mayankgupta$ paraFoam ~/openfoam/mayank-1.4.1/run/icoFoam cavity
/Users/mayankgupta/OpenFOAM/OpenFOAM-1.4.1/bin/paraFoam: line 75: paraview: command not found

the thing is i m using macintosh and i have installed paraview as a disk image.......can some please help and let me know what to do in order to visualize the mesh
mgz1985 is offline   Reply With Quote

Old   September 18, 2008, 04:59
Default Hello All, During installat
  #8
New Member
 
Ameya Durve
Join Date: Mar 2009
Location: Mumbai, Maharashtra, India
Posts: 20
Rep Power: 8
ameya is on a distinguished road
Hello All,

During installation of ParaView, I got following error .
After
[Ameya@localhost PV3FoamReader]$ ./Allwmake


I got following error

+ '[' -d /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linuxGcc -a -r /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linuxGcc ']'
+ case "$ParaView_VERSION" in
+ wmake libso vtkPV3Foam
wmakeLnInclude: linking include files to /home/Ameya/OpenFOAM/OpenFOAM-1.5/applications/utilities/postProcessing/graphics /PV3FoamReader/vtkPV3Foam/lnInclude

Making dependency list for source file vtkPV3Foam.C
Making dependency list for source file vtkPV3FoamAddVolumeMesh.C
Making dependency list for source file vtkPV3FoamAddLagrangianMesh.C
Making dependency list for source file vtkPV3FoamAddPatchMesh.C
Making dependency list for source file vtkPV3FoamAddFaceZoneMesh.C
Making dependency list for source file vtkPV3FoamAddPointZoneMesh.C
Making dependency list for source file vtkPV3FoamAddFaceSetMesh.C
Making dependency list for source file vtkPV3FoamAddPointSetMesh.C
Making dependency list for source file vtkPV3FoamUpdate.C
Making dependency list for source file vtkPV3FoamUpdateInformation.C
Making dependency list for source file vtkPV3FoamConvertMesh.C
SOURCE=vtkPV3Foam.C ; g++ -m32 -Dlinux -DDP -Wall -Wno-strict-aliasing -Wextra -Wno-unused-parameter -Wold-style-cast -O3 -DNoRepository -ftemplate-depth-40 -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/finiteVolume/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/lagrangian/basic/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/meshTools/lnInclude -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linuxGcc/VTK -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Filtering -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering -I../PV3FoamReader -IlnInclude -I. -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/OpenFOAM/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/OSspecific/Unix/lnInclude -fPIC -pthread -c $SOURCE -o Make/linuxGccDPOpt/vtkPV3Foam.o
In file included from /home/Ameya/OpenFOAM/ThirdParty/gcc-4.3.1/linux/bin/../lib/gcc/i686-pc-linux-gnu /4.3.1/../../../../include/c++/4.3.1/backward/strstream:51,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkIOStream.h:112,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkSystemIncludes.h:4 0,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkIndent.h:24,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkObjectBase.h:43,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkObject.h:41,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Filtering/vtkAlgorithm.h:32,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Filtering/vtkMultiBlockDataS etAlgorithm.h:25,
from ../PV3FoamReader/vtkPV3FoamReader.h:26,
from vtkPV3Foam.C:36:
/home/Ameya/OpenFOAM/ThirdParty/gcc-4.3.1/linux/bin/../lib/gcc/i686-pc-linux-gnu /4.3.1/../../../../include/c++/4.3.1/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated or antiquated header which may be removed without further notice at a future date. Please use a non-deprecated interface with equivalent functionality instead. For a listing of replacement headers and interfaces, consult the file backward_warning.h. To disable this warning use -Wno-deprecated.
SOURCE=vtkPV3FoamAddVolumeMesh.C ; g++ -m32 -Dlinux -DDP -Wall -Wno-strict-aliasing -Wextra -Wno-unused-parameter -Wold-style-cast -O3 -DNoRepository -ftemplate-depth-40 -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/finiteVolume/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/lagrangian/basic/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/meshTools/lnInclude -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linuxGcc/VTK -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Filtering -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering -I../PV3FoamReader -IlnInclude -I. -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/OpenFOAM/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/OSspecific/Unix/lnInclude -fPIC -pthread -c $SOURCE -o Make/linuxGccDPOpt/vtkPV3FoamAddVolumeMesh.o
In file included from /home/Ameya/OpenFOAM/ThirdParty/gcc-4.3.1/linux/bin/../lib/gcc/i686-pc-linux-gnu /4.3.1/../../../../include/c++/4.3.1/backward/strstream:51,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkIOStream.h:112,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkSystemIncludes.h:4 0,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkIndent.h:24,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkObjectBase.h:43,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkObject.h:41,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkPoints.h:23,
from vtkPV3FoamInsertNextPoint.H:34,
from vtkPV3FoamAddVolumeMesh.C:39:
/home/Ameya/OpenFOAM/ThirdParty/gcc-4.3.1/linux/bin/../lib/gcc/i686-pc-linux-gnu /4.3.1/../../../../include/c++/4.3.1/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated or antiquated header which may be removed without further notice at a future date. Please use a non-deprecated interface with equivalent functionality instead. For a listing of replacement headers and interfaces, consult the file backward_warning.h. To disable this warning use -Wno-deprecated.
SOURCE=vtkPV3FoamAddLagrangianMesh.C ; g++ -m32 -Dlinux -DDP -Wall -Wno-strict-aliasing -Wextra -Wno-unused-parameter -Wold-style-cast -O3 -DNoRepository -ftemplate-depth-40 -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/finiteVolume/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/lagrangian/basic/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/meshTools/lnInclude -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linuxGcc/VTK -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Filtering -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering -I../PV3FoamReader -IlnInclude -I. -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/OpenFOAM/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/OSspecific/Unix/lnInclude -fPIC -pthread -c $SOURCE -o Make/linuxGccDPOpt/vtkPV3FoamAddLagrangianMesh.o
In file included from /home/Ameya/OpenFOAM/ThirdParty/gcc-4.3.1/linux/bin/../lib/gcc/i686-pc-linux-gnu /4.3.1/../../../../include/c++/4.3.1/backward/strstream:51,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkIOStream.h:112,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkSystemIncludes.h:4 0,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkIndent.h:24,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkObjectBase.h:43,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkObject.h:41,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkPoints.h:23,
from vtkPV3FoamInsertNextPoint.H:34,
from vtkPV3FoamAddLagrangianMesh.C:35:
/home/Ameya/OpenFOAM/ThirdParty/gcc-4.3.1/linux/bin/../lib/gcc/i686-pc-linux-gnu /4.3.1/../../../../include/c++/4.3.1/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated or antiquated header which may be removed without further notice at a future date. Please use a non-deprecated interface with equivalent functionality instead. For a listing of replacement headers and interfaces, consult the file backward_warning.h. To disable this warning use -Wno-deprecated.
SOURCE=vtkPV3FoamAddPatchMesh.C ; g++ -m32 -Dlinux -DDP -Wall -Wno-strict-aliasing -Wextra -Wno-unused-parameter -Wold-style-cast -O3 -DNoRepository -ftemplate-depth-40 -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/finiteVolume/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/lagrangian/basic/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/meshTools/lnInclude -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linuxGcc/VTK -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Filtering -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering -I../PV3FoamReader -IlnInclude -I. -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/OpenFOAM/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/OSspecific/Unix/lnInclude -fPIC -pthread -c $SOURCE -o Make/linuxGccDPOpt/vtkPV3FoamAddPatchMesh.o
In file included from /home/Ameya/OpenFOAM/ThirdParty/gcc-4.3.1/linux/bin/../lib/gcc/i686-pc-linux-gnu /4.3.1/../../../../include/c++/4.3.1/backward/strstream:51,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkIOStream.h:112,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkSystemIncludes.h:4 0,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkIndent.h:24,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkObjectBase.h:43,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkObject.h:41,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkPoints.h:23,
from vtkPV3FoamInsertNextPoint.H:34,
from vtkPV3FoamAddPatchMesh.C:34:
/home/Ameya/OpenFOAM/ThirdParty/gcc-4.3.1/linux/bin/../lib/gcc/i686-pc-linux-gnu /4.3.1/../../../../include/c++/4.3.1/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated or antiquated header which may be removed without further notice at a future date. Please use a non-deprecated interface with equivalent functionality instead. For a listing of replacement headers and interfaces, consult the file backward_warning.h. To disable this warning use -Wno-deprecated.
SOURCE=vtkPV3FoamAddFaceZoneMesh.C ; g++ -m32 -Dlinux -DDP -Wall -Wno-strict-aliasing -Wextra -Wno-unused-parameter -Wold-style-cast -O3 -DNoRepository -ftemplate-depth-40 -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/finiteVolume/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/lagrangian/basic/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/meshTools/lnInclude -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linuxGcc/VTK -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Filtering -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering -I../PV3FoamReader -IlnInclude -I. -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/OpenFOAM/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/OSspecific/Unix/lnInclude -fPIC -pthread -c $SOURCE -o Make/linuxGccDPOpt/vtkPV3FoamAddFaceZoneMesh.o
In file included from /home/Ameya/OpenFOAM/ThirdParty/gcc-4.3.1/linux/bin/../lib/gcc/i686-pc-linux-gnu /4.3.1/../../../../include/c++/4.3.1/backward/strstream:51,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkIOStream.h:112,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkSystemIncludes.h:4 0,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkIndent.h:24,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkObjectBase.h:43,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkObject.h:41,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkPoints.h:23,
from vtkPV3FoamInsertNextPoint.H:34,
from vtkPV3FoamAddFaceZoneMesh.C:32:
/home/Ameya/OpenFOAM/ThirdParty/gcc-4.3.1/linux/bin/../lib/gcc/i686-pc-linux-gnu /4.3.1/../../../../include/c++/4.3.1/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated or antiquated header which may be removed without further notice at a future date. Please use a non-deprecated interface with equivalent functionality instead. For a listing of replacement headers and interfaces, consult the file backward_warning.h. To disable this warning use -Wno-deprecated.
SOURCE=vtkPV3FoamAddPointZoneMesh.C ; g++ -m32 -Dlinux -DDP -Wall -Wno-strict-aliasing -Wextra -Wno-unused-parameter -Wold-style-cast -O3 -DNoRepository -ftemplate-depth-40 -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/finiteVolume/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/lagrangian/basic/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/meshTools/lnInclude -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linuxGcc/VTK -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Filtering -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering -I../PV3FoamReader -IlnInclude -I. -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/OpenFOAM/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/OSspecific/Unix/lnInclude -fPIC -pthread -c $SOURCE -o Make/linuxGccDPOpt/vtkPV3FoamAddPointZoneMesh.o
In file included from /home/Ameya/OpenFOAM/ThirdParty/gcc-4.3.1/linux/bin/../lib/gcc/i686-pc-linux-gnu /4.3.1/../../../../include/c++/4.3.1/backward/strstream:51,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkIOStream.h:112,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkSystemIncludes.h:4 0,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkIndent.h:24,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkObjectBase.h:43,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkObject.h:41,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkPoints.h:23,
from vtkPV3FoamInsertNextPoint.H:34,
from vtkPV3FoamAddPointZoneMesh.C:32:
/home/Ameya/OpenFOAM/ThirdParty/gcc-4.3.1/linux/bin/../lib/gcc/i686-pc-linux-gnu /4.3.1/../../../../include/c++/4.3.1/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated or antiquated header which may be removed without further notice at a future date. Please use a non-deprecated interface with equivalent functionality instead. For a listing of replacement headers and interfaces, consult the file backward_warning.h. To disable this warning use -Wno-deprecated.
SOURCE=vtkPV3FoamAddFaceSetMesh.C ; g++ -m32 -Dlinux -DDP -Wall -Wno-strict-aliasing -Wextra -Wno-unused-parameter -Wold-style-cast -O3 -DNoRepository -ftemplate-depth-40 -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/finiteVolume/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/lagrangian/basic/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/meshTools/lnInclude -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linuxGcc/VTK -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Filtering -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering -I../PV3FoamReader -IlnInclude -I. -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/OpenFOAM/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/OSspecific/Unix/lnInclude -fPIC -pthread -c $SOURCE -o Make/linuxGccDPOpt/vtkPV3FoamAddFaceSetMesh.o
In file included from /home/Ameya/OpenFOAM/ThirdParty/gcc-4.3.1/linux/bin/../lib/gcc/i686-pc-linux-gnu /4.3.1/../../../../include/c++/4.3.1/backward/strstream:51,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkIOStream.h:112,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkSystemIncludes.h:4 0,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkIndent.h:24,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkObjectBase.h:43,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkObject.h:41,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkPoints.h:23,
from vtkPV3FoamInsertNextPoint.H:34,
from vtkPV3FoamAddFaceSetMesh.C:33:
/home/Ameya/OpenFOAM/ThirdParty/gcc-4.3.1/linux/bin/../lib/gcc/i686-pc-linux-gnu /4.3.1/../../../../include/c++/4.3.1/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated or antiquated header which may be removed without further notice at a future date. Please use a non-deprecated interface with equivalent functionality instead. For a listing of replacement headers and interfaces, consult the file backward_warning.h. To disable this warning use -Wno-deprecated.
SOURCE=vtkPV3FoamAddPointSetMesh.C ; g++ -m32 -Dlinux -DDP -Wall -Wno-strict-aliasing -Wextra -Wno-unused-parameter -Wold-style-cast -O3 -DNoRepository -ftemplate-depth-40 -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/finiteVolume/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/lagrangian/basic/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/meshTools/lnInclude -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linuxGcc/VTK -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Filtering -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering -I../PV3FoamReader -IlnInclude -I. -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/OpenFOAM/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/OSspecific/Unix/lnInclude -fPIC -pthread -c $SOURCE -o Make/linuxGccDPOpt/vtkPV3FoamAddPointSetMesh.o
In file included from /home/Ameya/OpenFOAM/ThirdParty/gcc-4.3.1/linux/bin/../lib/gcc/i686-pc-linux-gnu /4.3.1/../../../../include/c++/4.3.1/backward/strstream:51,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkIOStream.h:112,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkSystemIncludes.h:4 0,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkIndent.h:24,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkObjectBase.h:43,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkObject.h:41,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkPoints.h:23,
from vtkPV3FoamInsertNextPoint.H:34,
from vtkPV3FoamAddPointSetMesh.C:33:
/home/Ameya/OpenFOAM/ThirdParty/gcc-4.3.1/linux/bin/../lib/gcc/i686-pc-linux-gnu /4.3.1/../../../../include/c++/4.3.1/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated or antiquated header which may be removed without further notice at a future date. Please use a non-deprecated interface with equivalent functionality instead. For a listing of replacement headers and interfaces, consult the file backward_warning.h. To disable this warning use -Wno-deprecated.
SOURCE=vtkPV3FoamUpdate.C ; g++ -m32 -Dlinux -DDP -Wall -Wno-strict-aliasing -Wextra -Wno-unused-parameter -Wold-style-cast -O3 -DNoRepository -ftemplate-depth-40 -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/finiteVolume/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/lagrangian/basic/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/meshTools/lnInclude -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linuxGcc/VTK -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Filtering -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering -I../PV3FoamReader -IlnInclude -I. -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/OpenFOAM/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/OSspecific/Unix/lnInclude -fPIC -pthread -c $SOURCE -o Make/linuxGccDPOpt/vtkPV3FoamUpdate.o
In file included from /home/Ameya/OpenFOAM/ThirdParty/gcc-4.3.1/linux/bin/../lib/gcc/i686-pc-linux-gnu /4.3.1/../../../../include/c++/4.3.1/backward/strstream:51,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkIOStream.h:112,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkSystemIncludes.h:4 0,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkIndent.h:24,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkObjectBase.h:43,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkObject.h:41,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Filtering/vtkAlgorithm.h:32,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Filtering/vtkMultiBlockDataS etAlgorithm.h:25,
from ../PV3FoamReader/vtkPV3FoamReader.h:26,
from vtkPV3FoamUpdate.C:33:
/home/Ameya/OpenFOAM/ThirdParty/gcc-4.3.1/linux/bin/../lib/gcc/i686-pc-linux-gnu /4.3.1/../../../../include/c++/4.3.1/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated or antiquated header which may be removed without further notice at a future date. Please use a non-deprecated interface with equivalent functionality instead. For a listing of replacement headers and interfaces, consult the file backward_warning.h. To disable this warning use -Wno-deprecated.
SOURCE=vtkPV3FoamUpdateInformation.C ; g++ -m32 -Dlinux -DDP -Wall -Wno-strict-aliasing -Wextra -Wno-unused-parameter -Wold-style-cast -O3 -DNoRepository -ftemplate-depth-40 -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/finiteVolume/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/lagrangian/basic/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/meshTools/lnInclude -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linuxGcc/VTK -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Filtering -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering -I../PV3FoamReader -IlnInclude -I. -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/OpenFOAM/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/OSspecific/Unix/lnInclude -fPIC -pthread -c $SOURCE -o Make/linuxGccDPOpt/vtkPV3FoamUpdateInformation.o
In file included from /home/Ameya/OpenFOAM/ThirdParty/gcc-4.3.1/linux/bin/../lib/gcc/i686-pc-linux-gnu /4.3.1/../../../../include/c++/4.3.1/backward/strstream:51,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkIOStream.h:112,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkSystemIncludes.h:4 0,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkIndent.h:24,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkObjectBase.h:43,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkObject.h:41,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Filtering/vtkAlgorithm.h:32,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Filtering/vtkMultiBlockDataS etAlgorithm.h:25,
from ../PV3FoamReader/vtkPV3FoamReader.h:26,
from vtkPV3FoamUpdateInformation.C:39:
/home/Ameya/OpenFOAM/ThirdParty/gcc-4.3.1/linux/bin/../lib/gcc/i686-pc-linux-gnu /4.3.1/../../../../include/c++/4.3.1/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated or antiquated header which may be removed without further notice at a future date. Please use a non-deprecated interface with equivalent functionality instead. For a listing of replacement headers and interfaces, consult the file backward_warning.h. To disable this warning use -Wno-deprecated.
SOURCE=vtkPV3FoamConvertMesh.C ; g++ -m32 -Dlinux -DDP -Wall -Wno-strict-aliasing -Wextra -Wno-unused-parameter -Wold-style-cast -O3 -DNoRepository -ftemplate-depth-40 -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/finiteVolume/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/lagrangian/basic/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/meshTools/lnInclude -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linuxGcc/VTK -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Filtering -I/home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering -I../PV3FoamReader -IlnInclude -I. -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/OpenFOAM/lnInclude -I/home/Ameya/OpenFOAM/OpenFOAM-1.5/src/OSspecific/Unix/lnInclude -fPIC -pthread -c $SOURCE -o Make/linuxGccDPOpt/vtkPV3FoamConvertMesh.o
In file included from /home/Ameya/OpenFOAM/ThirdParty/gcc-4.3.1/linux/bin/../lib/gcc/i686-pc-linux-gnu /4.3.1/../../../../include/c++/4.3.1/backward/strstream:51,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkIOStream.h:112,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkSystemIncludes.h:4 0,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkIndent.h:24,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkObjectBase.h:43,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkObject.h:41,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Filtering/vtkAlgorithm.h:32,
from /home/Ameya/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Filtering/vtkMultiBlockDataS etAlgorithm.h:25,
from ../PV3FoamReader/vtkPV3FoamReader.h:26,
from vtkPV3FoamConvertMesh.C:36:
/home/Ameya/OpenFOAM/ThirdParty/gcc-4.3.1/linux/bin/../lib/gcc/i686-pc-linux-gnu /4.3.1/../../../../include/c++/4.3.1/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated or antiquated header which may be removed without further notice at a future date. Please use a non-deprecated interface with equivalent functionality instead. For a listing of replacement headers and interfaces, consult the file backward_warning.h. To disable this warning use -Wno-deprecated.
'/home/Ameya/OpenFOAM/OpenFOAM-1.5/lib/linuxGccDPOpt/libvtkPV3Foam.so' is up to date.
+ cd PV3FoamReader
+ mkdir -p Make/linuxGccDPOpt
+ cd Make/linuxGccDPOpt
+ cmake ../..
-- Check for working C compiler: /home/Ameya/OpenFOAM/ThirdParty/gcc-4.3.1/linux/bin/gcc
-- Check for working C compiler: /home/Ameya/OpenFOAM/ThirdParty/gcc-4.3.1/linux/bin/gcc -- works
-- Check size of void*
-- Check size of void* - done
-- Check for working CXX compiler: /home/Ameya/OpenFOAM/ThirdParty/gcc-4.3.1/linux/bin/c++
-- Check for working CXX compiler: /home/Ameya/OpenFOAM/ThirdParty/gcc-4.3.1/linux/bin/c++ -- works
-- Loading ParaView CMake commands
-- Loading ParaView CMake commands - done
CMake Error: Error in cmake code at
#ifndef _@PLUGIN_NAME@Plugin_h:458:
Unknown CMake command "QT4_WRAP_CPP".
CMake Error: Error in cmake code at
/home/Ameya/OpenFOAM/OpenFOAM-1.5/applications/utilities/postProcessing/graphics /PV3FoamReader/PV3FoamReader/CMakeLists.txt:44:
A command failed during the invocation of macro "ADD_PARAVIEW_GUI_EXTENSION".
CMake Error: Error in cmake code at
#ifndef _@PLUGIN_NAME@Plugin_h:562:
ADD_PARAVIEW_GUI_EXTENSION unknown error.
Current CMake stack: /home/Ameya/OpenFOAM/OpenFOAM-1.5/applications/utilities/postProcessing/graphics /PV3FoamReader/PV3FoamReader/CMakeLists.txt;/home/Ameya/OpenFOAM/ThirdParty/cmak e-2.4.6/platforms/linux/share/cmake-2.4/Modules/CMakeCInformation.cmake;/home/Am eya/OpenFOAM/ThirdParty/cmake-2.4.6/platforms/linux/share/cmake-2.4/Modules/CMak eCXXInformation.cmake
CMake Error: Error in cmake code at
/home/Ameya/OpenFOAM/OpenFOAM-1.5/applications/utilities/postProcessing/graphics /PV3FoamReader/PV3FoamReader/CMakeLists.txt:44:
A command failed during the invocation of macro "ADD_PARAVIEW_PLUGIN".
CMake Error: Error in cmake code at
/home/Ameya/OpenFOAM/OpenFOAM-1.5/applications/utilities/postProcessing/graphics /PV3FoamReader/PV3FoamReader/CMakeLists.txt:43:
ADD_PARAVIEW_PLUGIN unknown error.
Current CMake stack: /home/Ameya/OpenFOAM/OpenFOAM-1.5/applications/utilities/postProcessing/graphics /PV3FoamReader/PV3FoamReader/CMakeLists.txt;/home/Ameya/OpenFOAM/ThirdParty/cmak e-2.4.6/platforms/linux/share/cmake-2.4/Modules/CMakeCInformation.cmake;/home/Am eya/OpenFOAM/ThirdParty/cmake-2.4.6/platforms/linux/share/cmake-2.4/Modules/CMak eCXXInformation.cmake
-- Configuring done
+ make
make: *** No targets specified and no makefile found. Stop.

it seems that the problem is of cmake

Any help will be apprecited

IO am using Fedora 8
ameya is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
ParaView command not found joey OpenFOAM Paraview & paraFoam 3 August 28, 2010 21:37
IcoFoam Not Installed and blockMesh command not found cesarbz OpenFOAM Installation 6 July 4, 2008 04:44
Bash g command not found mamaly60 OpenFOAM Installation 0 October 18, 2007 17:14
Error starting paraFoam line 67 paraview command not found jango OpenFOAM Installation 4 July 19, 2007 01:39
Problem running paraFoam paraview command not found spdracer22 OpenFOAM Pre-Processing 2 December 7, 2005 06:32


All times are GMT -4. The time now is 19:12.