CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Paraview & paraFoam (http://www.cfd-online.com/Forums/openfoam-paraview/)
-   -   Help no mesh is displayed (http://www.cfd-online.com/Forums/openfoam-paraview/61186-help-no-mesh-displayed.html)

alice August 7, 2007 04:34

hallo all, I'm a new user. I
 
hallo all,
I'm a new user. I learn the Openfoam at first with the cavity in the tutorial. I was doing it step by step by the introduction, but no mesh has emerged always. What is the problem?

alice

marhamat August 7, 2007 05:37

It's completly strange. So ex
 
It's completly strange.
So explan your problem with more details .
When you do the cavity tutorial step by step take care to messages that you recieve

Marhamat

alice August 7, 2007 06:37

hallo, the process is: I
 
hallo,

the process is:

In the Selection Window of Paraview stayed already a file cavity.foam. I have clicked the button of Accept. Then a case geometry should be shown. But I cought only a blue picture with no mesh.

good wishes

alice

marhamat August 7, 2007 07:05

Do you change Display Style fr
 
Do you change Display Style from surface to wireframe of surface in Display menu?
What is the result?

Marhamat

alice August 7, 2007 07:51

hallo marhamat, thank you v
 
hallo marhamat,

thank you very much for your help. Through your introduction I have alreaday got the case geometry. But I have fund that the data of the calculation haven't been transfered to the paraview. Because when i click the butten information. Under data arrays stay only zero. why? I think that the concret values should be shown after calculation.


good wishes


alice

make August 7, 2007 08:45

Did you run in parallel? If so
 
Did you run in parallel? If so you have to run reconstructPar first.
What does your console say when running ParaFoam?

alice August 7, 2007 09:06

what is the reconstructPar? I
 
what is the reconstructPar? I don't know. Tomorrow I will try it again. Thank you for your today's help.

alice

make August 7, 2007 09:19

If you run your simulation in
 
If you run your simulation in parallel it decomposes your grid into several pieces. On for each processor. This is defined in your system/decomposeParDict. So your solution is spread into directions named processorN while N is the number of the processor. ParaFoam is looking for solutions only in the root dir of your case. So you have to use reconstructPar first which reconstructs the solution pieces into one solution within your root dir of the case. Read the "Breaking of a dam" tutorial in the users guide!

alice August 7, 2007 09:34

it seems like very complex. je
 
it seems like very complex. jetzt i can't digest it. Tomorrow i will read it carefully. Then I'll do it. If i have questions again, I'll ask you again.Thank you very much.

good wishes


alice

philippose August 7, 2007 13:02

Hello, A Good evening to yo
 
Hello,

A Good evening to you....!

Ok... lets go through this step by step... you need to do the following in order to run the cavity tutorial:

1. Change to the "icoFoam" directory within the "tutorials" directory

2. Run the command: blockMesh . cavity

3. Solve the case using the command: icoFoam . cavity

4. For post-processing, you need to following command: paraFoam . cavity

5. I have taken a couple of screen-shots to show you the steps within paraview... lets see if the attach function works.. :-)!

If not.... these are the steps within paraview:

1. When you press the "Accept" button, you should see a blue rectangular geometry on the screen...

2. Click on the time-step "0.5", and then click on "Accept" again, and you should see the pressure distribution solved by icoFoam.

http://www.cfd-online.com/OpenFOAM_D...ges/1/5094.jpg

http://www.cfd-online.com/OpenFOAM_D...ges/1/5095.jpg

http://www.cfd-online.com/OpenFOAM_D...ges/1/5096.jpg

http://www.cfd-online.com/OpenFOAM_D...ges/1/5097.jpg

Have a nice day :-)!

Philippose

msrinath80 August 7, 2007 14:56

Philippose, I wish to thank yo
 
Philippose, I wish to thank you for your dedication to newbies. Thanks a lot!

philippose August 7, 2007 15:34

Hey Srinath, Whats that now
 
Hey Srinath,

Whats that now :-)! Thats one of the funniest replies I have seen :-)! If only you could see my big grin :-)! (Its bigger than what the smiley implies)!

Philippose

msrinath80 August 7, 2007 15:49

No I'm serious. You see there
 
No I'm serious. You see there are many new users every week and to keep responding to their queries amidst your daily schedule is something commendable.

alice August 8, 2007 05:46

hallo philippose, thank you
 
hallo philippose,

thank you very much for your help. I have tried. But i haven't got the pressure figure. The error is:
there was a VTK Error in file:.../../../../paraview-2.4.2/GUI/Client/vtkPVColourselectionWidget.cxx (136) vtkPVColourSelectionWidget (0x95c84d8):invalid arrayinfo
This error message emerges in the Openfoam window.

good wishes

alice

philippose August 8, 2007 06:29

Hello again, Oops.... looks
 
Hello again,

Oops.... looks like the problem goes deeper than I thought :-)! Ok... first, for some questions...

1. Which version of OpenFOAM are you trying this out with??

2. Did you recompile OpenFOAM, or did you just download and unzip the binaries as available on the OpenFOAM download website?

3. I noticed that you are using paraview-2.4.2. Did you compile this yourself, or did you download a version available from the OpenFOAM website? Or... does your computer have a version of Paraview installed, independent of the version which can be downloaded from the OpenFOAM website?

Philippose

alice August 8, 2007 07:19

hallo, 1. My openfoam is op
 
hallo,

1. My openfoam is openfoam 1.3
2. I haven't recompiled openfoam. I download and unzip the binaries like the steps what the openfoam website has said.
3. I haven't compiled any programme and downloaded any version. all are no for what you said.

alice

philippose August 8, 2007 11:38

Hello people, Question....
 
Hello people,

Question.... does anyone remember what version of Paraview the stock version of OpenFOAM 1.3 was paired up with?

All the OpenFOAM 1.3 installations I have (even ones from July 2006), are running with Paraview 2.4.4.

Alice...If the version of OpenFOAM 1.3 being used by you is set up to work with Paraview 2.4.4, you may get errors if you try to use Paraview 2.4.2

Could you paste the contents of the following file:

[home directory]/OpenFOAM/OpenFOAM-1.3/.OpenFOAM-1.3/apps/paraview/bashrc

That way we can see which version of Paraview may have been used during the compile process.

Philippose

msrinath80 August 8, 2007 14:55

paraview-2.4.2
 
paraview-2.4.2

philippose August 8, 2007 16:58

Hi there :-)! Hmmmmm.... if
 
Hi there :-)!

Hmmmmm.... if the stock version of OpenFOAM 1.3 used Paraview 2.4.2, looks like something else is amiss in this particular case....!

The error says "invalid arrayinfo"... which seems to point towards something on the solution side of things.....

Though on the other hand, paraFoam seems to be starting up fine, and when the "Accept" button is clicked, it does load the geometry.... which means the mesh part is ok.....

Alice....One way of sorting things out would be, if you can zip up the entire "cavity" folder AFTER you run "icoFoam" on the case, and E-Mail it to me .

My suggestion would be... run icoFoam with the following command....:

icoFoam . cavity >& ./cavity/log

So that a log is created.

Any other ideas anyone ?

Have a nice evening!

Philippose

alice August 9, 2007 04:45

hallo philippose, thank you
 
hallo philippose,

thank you for your help. Now it seems that the question isn't so easy. I have checked again my software data. The version of paraview is 2.4.2. this is sure. Then what should i do now?

have a nice day

alice


All times are GMT -4. The time now is 19:26.