CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Paraview & paraFoam

Paraview cannot startup

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   April 11, 2007, 14:35
Default On my local PC I am using Xter
  #1
New Member
 
Dean Wang
Join Date: Mar 2009
Posts: 2
Rep Power: 0
gnom is on a distinguished road
On my local PC I am using Xterm (exceed) to connet to the linux server on which the openFOAM is installed. But when I type the conmand "paraview", the paraview windown does not open up, and the error message says "Xlib: Extension "GLX" missing on display "192.168.0.170:0.0".

Please help. Thanks
gnom is offline   Reply With Quote

Old   June 8, 2007, 09:32
Default You need to update the driver
  #2
New Member
 
MK_MAT
Join Date: Mar 2009
Posts: 6
Rep Power: 7
mardit is on a distinguished road
You need to update the driver of your graphic card - if it is NVIDIA go to the website download latest driver, follow instruction to install and it should work.
I had the same problem.
mardit is offline   Reply With Quote

Old   October 7, 2009, 01:30
Default
  #3
Member
 
Scott
Join Date: Sep 2009
Posts: 30
Rep Power: 7
scottneh is on a distinguished road
I have been experiencing the same problem but I have the lates nvidia drivers and have loaded the glx module in xorg.com but still get the same error. Any other ideas? Could some libray file be pointing to the wrong location for the OpenGL drivers?

Thanks
Scott
scottneh is offline   Reply With Quote

Old   October 8, 2009, 06:11
Default
  #4
Senior Member
 
Laurence R. McGlashan
Join Date: Mar 2009
Posts: 370
Rep Power: 13
l_r_mcglashan will become famous soon enough
Does 'glxgears' show up an animation?

I have had various problems with paraView on different machines, and I find the best way is just to compile it from scratch. Your problem could be related to a number of things. What steps have you taken?
__________________
Laurence R. McGlashan :: Website
l_r_mcglashan is offline   Reply With Quote

Old   October 9, 2009, 14:02
Default
  #5
Senior Member
 
bigphil's Avatar
 
Philip Cardiff
Join Date: Mar 2009
Location: Dublin,Ireland
Posts: 543
Rep Power: 17
bigphil will become famous soon enough
Gnom,

A number of guys in my research group have similar errors connecting (using xterm) to our linux server. Yet the guys in the room using Mac don't have this problem. The work around the windows' guys do is:
they install paraview for windows on their windows machine (obviously ), and then run foamToVTK and use scp/sftp to transfer the VTK files to their windows machine for post-processing with paraview.
It's a bit annoying but if you use a gui scp/sftp program like winscp (http://winscp.net/eng/index.php) then it's fine.
Luckily I use Mac and don't have this problem, but this is a handy work-around.

This does not solve your problem but gets around it, as Laurence said the problem could be related to many different things.


Hope it helps,
Philip C
bigphil is offline   Reply With Quote

Old   October 9, 2009, 14:43
Default
  #6
Member
 
Scott
Join Date: Sep 2009
Posts: 30
Rep Power: 7
scottneh is on a distinguished road
I'm currently working this issue in Gentoo Linux on another forum and it has to do with the GLX module not being loaded properly due to an nVidia driver mismatch. I suspect that this is an nVidia issue and not a GLX or Paraview issue.

I'll post a complete solution and steps on how to resolve it a a few days once I have it worked out on my end
scottneh is offline   Reply With Quote

Old   October 14, 2009, 01:30
Default
  #7
Member
 
Scott
Join Date: Sep 2009
Posts: 30
Rep Power: 7
scottneh is on a distinguished road
ok so here is what I have found. I am using an ASUS board with an nVidia graphics card and running Gentoo linux.

This issue comes from using the "nv" drivers under the Module section in the Xorg.conf file which defines how your desktop is laid out. The "nv" drivers do not have any 3D accelration and will not load the GLX module. To correct this you need to make sure you have the latest nVidia drivers installed and replace "nv" with "nvidia" in your Xorg.conf file. Also you need to add Load "glx" in the Module section. I do not have the latest drivers so I am having to work out a low resolution issuse. Check your version of linux to see what file you have to define the desktop layout and make sure you have the closed source nVidia drivers. Everything should work after that.
scottneh is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fluent startup problem CFDnewbie FLUENT 7 March 21, 2012 00:05
GAMBIT STARTUP error Farhat FLUENT 3 February 9, 2010 14:52
★ HELP! startup problem, help me Conan FLUENT 4 October 16, 2009 16:21
Gambit startup options PAD FLUENT 0 July 21, 2006 06:38
startup required for Combustion Chetan Shah FLUENT 4 October 6, 2003 05:03


All times are GMT -4. The time now is 16:28.