CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Paraview & paraFoam (http://www.cfd-online.com/Forums/openfoam-paraview/)
-   -   Paraview problem (http://www.cfd-online.com/Forums/openfoam-paraview/61215-paraview-problem.html)

nzy102 April 3, 2007 15:42

Hi there: I am an OpenFOAM
 
Hi there:

I am an OpenFOAM starter. I have a question with paraview: when I tried to open paraview using parFoam to view mesh, paraview ooped up and GUI looked fine except I couldn't see mesh window. Anybody knows why this happens?

Ning

dmoroian April 4, 2007 03:16

Press the big button "Accept"
 
Press the big button "Accept" in paraview http://www.cfd-online.com/OpenFOAM_D...part/happy.gif

Dragos

nzy102 April 4, 2007 11:00

I already did. No response.
 
I already did. No response.

Ning

dmoroian April 5, 2007 06:21

Do you have a time directory?
 
Do you have a time directory?
Your case directory should look like this:
case_dir/0
case_dir/constant
case_dir/system

Anyway, if you follow the first tutorial in the "User's Guide", it should work, and that will give you a hint on what are you doing wrong now.

Dragos

rafal April 6, 2007 03:38

one possible thing is "/" at t
 
one possible thing is "/" at the end of
paraFoam <root> <case>/
which is added when you press TAB instead
of typing a full case name.
other:
how did you installed your paraFoam?
if you compiled on your own than you can have
problems like this if you didnt do it correctly
(i did have when i compiled first two times -
solution: Follow the guide on wiki).
do you have any messages in your shell
(usually OF provides usefull hints in shell)?
hope that helped
good luck and happy easter
rafal

gnom April 11, 2007 14:28

On my local PC I am using Xter
 
On my local PC I am using Xterm (exceed) to connet to the linux server on which the openFOAM is installed. But when I type the conmand "paraview", the paraview windown does not open up, and the error message says "Xlib: Extension "GLX" missing on display "192.168.0.170:0.0".

Please help. Thanks

paka April 11, 2007 16:05

OK, I am not the exact "proble
 
OK, I am not the exact "problem solver", but couple tips.

BTW. What linux distribution are you using?

First of all, the problem requires administration privalages.

1 tip:
Go to you admin and just ask about it. He, as an UNIX guru, should know what is wrong. Just tell him and explain you use VTK (Visualization Toolkit), and you just NEED it http://www.cfd-online.com/OpenFOAM_D...part/happy.gif

2 tip:
I assume you got these administrative privalages.

The reason why it doesn't work is the GLX (OpenGL Extension to the X Window System). So in order to make it run do followings:

1. Be sure you have the newest graphics drivers. nVidia? ATI? Whatever you use. Exception could be a built-in Intel card, then use 955resolution drivers. Just type XGL or GLX Intel graphic card driver in Google, this should help for some solutions.

2. step.
Write in xterm:
sudo gedit /etc/X11/xorg.conf

Add in "Module" section

Load "glx"

These steps probably COULD help, but DON'T have to. In my case the whole modification process was "a bit" more complicated and took much more time.

To check if GLX is enabled type in your terminal window:
glxgears

if this doesn't work it means GLX is not working. When they appear you can be sure GLX is fine(!).

Hope that helped a little bit, and forgive me my very brief descriptions. It is really hard to say what you should do, because Linux is always different case depending on the used machine.

PS. Try to use Google for XGL/AIXGL or GLX enableing. It will take you some time, but sure finally (if you are lucky enough) it will work.

PS2. Sorry for sending you out to Google, but it really works and helps me a lot http://www.cfd-online.com/OpenFOAM_D...part/happy.gif

PS3. The best solution is go to your linux distro internet forum and ask for help over there. They are the best guys to ask for help.

Good luck!
Krystian

santos April 12, 2007 10:20

Dean Wang In order to launc
 
Dean Wang

In order to launch Paraview from a remote machine, you'll need to forward X from the remote server to your local computer.

If you are using ssh, you can do so by:
ssh user@server -X

Best regards,
Josť Santos


All times are GMT -4. The time now is 17:41.