CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Paraview & paraFoam

Paraview problem

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   April 3, 2007, 14:42
Default Hi there: I am an OpenFOAM
  #1
Member
 
Ning Yang
Join Date: Mar 2009
Location: University Park, PA, USA
Posts: 85
Rep Power: 8
nzy102 is on a distinguished road
Hi there:

I am an OpenFOAM starter. I have a question with paraview: when I tried to open paraview using parFoam to view mesh, paraview ooped up and GUI looked fine except I couldn't see mesh window. Anybody knows why this happens?

Ning
nzy102 is offline   Reply With Quote

Old   April 4, 2007, 02:16
Default Press the big button "Accept"
  #2
Senior Member
 
dmoroian's Avatar
 
Dragos
Join Date: Mar 2009
Posts: 647
Rep Power: 11
dmoroian is on a distinguished road
Press the big button "Accept" in paraview

Dragos
dmoroian is offline   Reply With Quote

Old   April 4, 2007, 10:00
Default I already did. No response.
  #3
Member
 
Ning Yang
Join Date: Mar 2009
Location: University Park, PA, USA
Posts: 85
Rep Power: 8
nzy102 is on a distinguished road
I already did. No response.

Ning
nzy102 is offline   Reply With Quote

Old   April 5, 2007, 05:21
Default Do you have a time directory?
  #4
Senior Member
 
dmoroian's Avatar
 
Dragos
Join Date: Mar 2009
Posts: 647
Rep Power: 11
dmoroian is on a distinguished road
Do you have a time directory?
Your case directory should look like this:
case_dir/0
case_dir/constant
case_dir/system

Anyway, if you follow the first tutorial in the "User's Guide", it should work, and that will give you a hint on what are you doing wrong now.

Dragos
dmoroian is offline   Reply With Quote

Old   April 6, 2007, 02:38
Default one possible thing is "/" at t
  #5
Member
 
rafal zietara
Join Date: Mar 2009
Location: Manchester, UK
Posts: 60
Rep Power: 8
rafal is on a distinguished road
one possible thing is "/" at the end of
paraFoam <root> <case>/
which is added when you press TAB instead
of typing a full case name.
other:
how did you installed your paraFoam?
if you compiled on your own than you can have
problems like this if you didnt do it correctly
(i did have when i compiled first two times -
solution: Follow the guide on wiki).
do you have any messages in your shell
(usually OF provides usefull hints in shell)?
hope that helped
good luck and happy easter
rafal
rafal is offline   Reply With Quote

Old   April 11, 2007, 13:28
Default On my local PC I am using Xter
  #6
New Member
 
Dean Wang
Join Date: Mar 2009
Posts: 2
Rep Power: 0
gnom is on a distinguished road
On my local PC I am using Xterm (exceed) to connet to the linux server on which the openFOAM is installed. But when I type the conmand "paraview", the paraview windown does not open up, and the error message says "Xlib: Extension "GLX" missing on display "192.168.0.170:0.0".

Please help. Thanks
gnom is offline   Reply With Quote

Old   April 11, 2007, 15:05
Default OK, I am not the exact "proble
  #7
Senior Member
 
Join Date: Mar 2009
Posts: 225
Rep Power: 9
paka is on a distinguished road
OK, I am not the exact "problem solver", but couple tips.

BTW. What linux distribution are you using?

First of all, the problem requires administration privalages.

1 tip:
Go to you admin and just ask about it. He, as an UNIX guru, should know what is wrong. Just tell him and explain you use VTK (Visualization Toolkit), and you just NEED it

2 tip:
I assume you got these administrative privalages.

The reason why it doesn't work is the GLX (OpenGL Extension to the X Window System). So in order to make it run do followings:

1. Be sure you have the newest graphics drivers. nVidia? ATI? Whatever you use. Exception could be a built-in Intel card, then use 955resolution drivers. Just type XGL or GLX Intel graphic card driver in Google, this should help for some solutions.

2. step.
Write in xterm:
sudo gedit /etc/X11/xorg.conf

Add in "Module" section

Load "glx"

These steps probably COULD help, but DON'T have to. In my case the whole modification process was "a bit" more complicated and took much more time.

To check if GLX is enabled type in your terminal window:
glxgears

if this doesn't work it means GLX is not working. When they appear you can be sure GLX is fine(!).

Hope that helped a little bit, and forgive me my very brief descriptions. It is really hard to say what you should do, because Linux is always different case depending on the used machine.

PS. Try to use Google for XGL/AIXGL or GLX enableing. It will take you some time, but sure finally (if you are lucky enough) it will work.

PS2. Sorry for sending you out to Google, but it really works and helps me a lot

PS3. The best solution is go to your linux distro internet forum and ask for help over there. They are the best guys to ask for help.

Good luck!
Krystian
paka is offline   Reply With Quote

Old   April 12, 2007, 09:20
Default Dean Wang In order to launc
  #8
Senior Member
 
santos's Avatar
 
Jose Luis Santos
Join Date: Mar 2009
Location: Portugal
Posts: 213
Rep Power: 9
santos is on a distinguished road
Send a message via Skype™ to santos
Dean Wang

In order to launch Paraview from a remote machine, you'll need to forward X from the remote server to your local computer.

If you are using ssh, you can do so by:
ssh user@server -X

Best regards,
Josť Santos
santos is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with paraview and paraFoam openfoam_user OpenFOAM Paraview & paraFoam 36 May 13, 2014 07:37
ParaView display problem holzmichel OpenFOAM Bugs 7 April 27, 2009 18:42
Paraview installation problem mcjicpm2 OpenFOAM Paraview & paraFoam 0 March 9, 2009 08:15
Paraview installation problem please help mcjicpm2 OpenFOAM Installation 0 March 9, 2009 07:55
Some problem with paraview thermo OpenFOAM Paraview & paraFoam 10 December 25, 2005 14:20


All times are GMT -4. The time now is 07:59.