CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Paraview & paraFoam (http://www.cfd-online.com/Forums/openfoam-paraview/)
-   -   Paraview batch mode (http://www.cfd-online.com/Forums/openfoam-paraview/61255-paraview-batch-mode.html)

liu March 17, 2006 14:00

Did anyone use paraview batch
 
Did anyone use paraview batch mode to create animation? My simulation data is huge. When I use GUI mode, it just crashed. So I tried my luck with batch mode. But it ended up with following error message:

ERROR: In ../../../../../paraview-2.2.0/Servers/Common/vtkProcessModule.cxx, line 548
vtkPVProcessModule (0x9ace538): Cannot create object of type "vtkFoamReader".
while processing
Message 0 = New
Argument 0 = string_value {vtkFoamReader}
Argument 1 = id_value {89}


ERROR: In ../../../../../paraview-2.2.0/Servers/Common/vtkProcessModule.cxx, line 550
vtkPVProcessModule (0x9ace538): Aborting execution for debugging purposes.

mattijs March 17, 2006 14:30

Not directly answering your qu
 
Not directly answering your question but can you do your animation on vtk files (so using foamToVTK)?

(I assume you have deselected the cache/record buttons in the animation panel?)

liu March 17, 2006 14:35

I didn't try vtk files for ani
 
I didn't try vtk files for animation (I don't know how to do it honestly). Also my data is so huge that I can't afford to convert every time step to vtk files. That will double the data size.

When I use the GUI to record the animation, paraview complains about not enough memory and then terminated. Maybe that's because I didn't use cache. I will try it.

liu March 17, 2006 14:50

Well, I tried again. I am sure
 
Well, I tried again. I am sure the cache is one. The problem is still like that. Here is the message of paraview:

new cannot satisfy memory request.
This does not necessarily mean you have run out of virtual memory.
It could be due to a stack violation caused by e.g. bad use of pointers or an out of date shared library
/home/liu19/research/OpenFOAM/OpenFOAM-1.2/bin/paraFoam: line 57: 10034 Aborted paraview paraFoam.pvs


Any thought?

eugene March 17, 2006 15:04

Nah you're supposed to switch
 
Nah you're supposed to switch the cash OFF, otherwise it keeps everything for each timestep.

hjasak March 17, 2006 15:29

There's a little button on the
 
There's a little button on the Animation Control panel which say "Record All properties". Switch that off and all will be well.

I have done 500-odd frame animations this way so if the case fits into memory you should not have a problem.

Enjoy,

Hrv

liu March 17, 2006 16:14

Now it's working fine. Thank
 
Now it's working fine.
Thank you, guys.

kmurphy July 20, 2006 13:17

Hi, I would like to be use t
 
Hi,
I would like to be use the paraview batch mode but I get a similar error to that reported in the original post in this thread. Does anyone know of a solution?

Regards,
KM


All times are GMT -4. The time now is 10:16.