CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Paraview & paraFoam

Missing library libPVFoamReaderso

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   March 7, 2006, 05:40
Default Hello all! After downloadin
  #1
dirk_kehrwald
Guest
 
Posts: n/a
Hello all!

After downloading the sources of OpenFOAM 1.2 together with gcc 4.0.1, j2dsk 1.4.2_05 and paraview-2.2.0 for 32 bit Linux, I could successfully buildt the OpenFOAM package on my Suse 9.0 system. Performing the lid-driven cavity tutorial (Section 2.1 of the User's guide), I was able to follow the instructions until Section 2.1.1.6 (Saving data to file).

Calling now paraview as described in Section 2.1.2., I get the following error message:

--

ErrorMessage
# Error or warning: ERROR: In ../../../../../paraview-2.2.0/Utilities/VTKClientServer/vtkClientServerInterpret er.cxx, line 866
vtkClientServerInterpreter (0x8064070): Cannot find module "libPVFoamReader.so". The following paths were searched:

<a_lot_of_search_paths>


ERROR: In ../../../../../paraview-2.2.0/GUI/Client/vtkPVXMLPackageParser.cxx, line 677
vtkPVXMLPackageParser (0x87e1b48): Error loading Library component PVFoamReader

ErrorMessage end
<long_path>/paraFoam: line 57: 26343 Segmentation fault paraview paraFoam.pvs

--

Searching my disc with find, I found that neither libPVFoamReader.so nor any of the source files mentioned in the error message are there. How can I get the missing files?


Kind regards
Dirk Kehrwald
  Reply With Quote

Old   March 7, 2006, 05:54
Default The problem is that you cannot
  #2
Senior Member
 
Hrvoje Jasak
Join Date: Mar 2009
Location: London, England
Posts: 1,758
Rep Power: 21
hjasak will become famous soon enough
The problem is that you cannot build the paraview reader module without building paravie wyourself locall on your machine. I have posted detailed instructions on how to do this somewhere around - have a look and let me know if you cannot find them.

As a check, go to

OpenFOAM-1.2/applications/utilities/postProcessing/graphics/PVFoamReader

try

./Allwmake

and have a look at the messages - this is the bit that did not get built properly and you'll get paraview-related messages.

Enjoy,

Hrv
__________________
Hrvoje Jasak
Providing commercial FOAM/OpenFOAM and CFD Consulting: http://wikki.co.uk
hjasak is offline   Reply With Quote

Old   July 18, 2006, 06:21
Default hi...I have the same problem a
  #3
New Member
 
Sreekanth Kolan
Join Date: Mar 2009
Posts: 13
Rep Power: 8
sreekanth is on a distinguished road
hi...I have the same problem and i searched for your post and couldnot find. So, can you please post the message in detail how to do the above one because i tried re-building and ended up with same problem again.

please don't mind
sreekanth is offline   Reply With Quote

Old   July 19, 2006, 06:50
Default Dear Sreekanth Kolan, unfor
  #4
dirk_kehrwald
Guest
 
Posts: n/a
Dear Sreekanth Kolan,

unfortunately, I did not solve the problem. I kept trying for a few more days, then I had do do some more urgent work and I did not return to openFOAM since then.


Kind regards
Dirk
  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Libsslso098 library missing ahorvat OpenFOAM Bugs 8 October 23, 2009 07:05
LES --> AM I MISSING SOMETHING!? Forrest FLUENT 1 March 4, 2009 18:22
ParaFoam error missing libPVFoamReaderso agrahn OpenFOAM Bugs 3 June 23, 2008 12:34
Missing file nfoxley OpenFOAM Pre-Processing 2 March 31, 2006 08:57
HELP!!! LES missing in fluent 6 ravi FLUENT 2 March 5, 2003 19:27


All times are GMT -4. The time now is 14:49.